BLAG Forums
It is currently Sat Dec 15, 2018 11:21 pm

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: amarok engine trouble
PostPosted: Sat Oct 14, 2006 6:19 pm 

Joined: Mon Jul 17, 2006 10:13 am
Posts: 17
Location: Chicago
hey all,

just wondering whether anyone else has had problems (or not) getting amarok to load the xine engine (as helix without realplayer doesn't seem to support mp3, etc. files). (my system is up-to-date btw.) originally when i tried to load the xine engine, there was no option to do so even though i'd already installed xine-lib. after installing amarok-extras-nonfree package from the livna repo there then was an option for loading xine, but it didn't seem to actually load anything (the helix settings remain and when i try to "apply" the settings, it hangs). have tried to reinstall / completely remove and install these programs (amarok, xine-lib, amarok-extras), also from other repositories, but with no luck in getting the engine to load. just now downloaded the xine-lib source files and in configuring it, was told that:

xine-lib will be installed to /usr/local/lib

This path is not mentioned among the linker search paths in your
/etc/ This means it is possible that xine-lib will
not be found when you try to compile or run a program using it.
If this happens, you should add /usr/local/lib to
the environment variable LD_LIBRARY_PATH like that:

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

Alternatively you can add a line "/usr/local/lib"
to your /etc/

there were some errors i didn't understand so i didn't go through with compiling it, but i thought this message might apply to the binary on the blag repo as well. i ran that "export..." command as root, but xine still didn't load (should i have run it as a regular user since i'm running amarok as a regular user?).

i've been busily encoding my cds into ogg vorbis format, which i prefer anyway, so amarok will play most of my music. it's just the old stuff i have on mp3 that's a problem; not a big deal if i have to wait for an application update, but all ideas and shedding of light are welcome!

p.s. sorry if this post should go to the amarok/xine folks; after i got that configuration msg., i thought it might be an issue for other blaggers as well.

Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group