installation: anaconda reboots
Page 1 of 1

Author:  impert [ Sat May 01, 2010 9:05 pm ]
Post subject:  installation: anaconda reboots

Hi all,
I'm trying to install 90k on an AMD64 box. I've tried both with the x86_64 netinstall iso and the i386 iso.
In both cases, anaconda runs, but when I ask it to format the partition where I want to install Blag, it stops, the screen goes black, and the machine reboots.
Anaconda warns me that I have more than 15 partitions on sda and sdb, which is quite true, but I'm trying to put it onto sdb9, which surely should be ok. I thought it might be because there was an old Slackware on that partition, so I dd'd it full of zeros, but that didn't help.
Incidentally I would have thought that since kernels later than 2.6.28 or thereabouts can handle more than 15 partitions there should be no probs, but apparently anaconda hasn't caught up yet.
Does anyone have any ideas? Am I the only one with this problem? Thanks in advance.

Author:  Junichirô [ Sat May 01, 2010 10:33 pm ]
Post subject: 

Maybe because of the kernel on the installation ISO is 2.6.25 or 2.6.26?

Author:  impert [ Sun May 02, 2010 7:40 am ]
Post subject: 

Hi, and thanks for the speedy reply.
I downloaded the CD's on Friday so I think they would have the most recent kernel - 2.6.33 I think. In any case I've one or two other elderly kernels running quite happily on partitions below no 15. Slackware was 2.6.24 on the same partition. (sdb9)
EDIT According to the readme the i386cd has the 2.6.25 kernel-libre, but I don't think that is the problem. The i386 checksum and self-check were ok. The machine reboots when about 80% through formatting, and thus before anything has been installed, which makes me think it's an anaconda problem. I'll try again on another machine.

Author:  impert [ Sun May 02, 2010 9:46 am ]
Post subject: 

Tried the text-install (i386), same deal; tried on the other machine (amd64 also) ; machine freezes before getting to formatting stage, hard reboot required.

Author:  Junichirô [ Sun May 02, 2010 10:15 am ]
Post subject: 

Don't know what happened to you because I never had a problem to install it. i386 or x86_64 netinstall.

Author:  Saint of Killers [ Sun May 02, 2010 2:38 pm ]
Post subject: 

90k is based on Fedora 9, there have been no new releases for a little bit, and folk are now gathering efforts to start releasing again. There was some disruption when the sole developer quit the project, and the community has stepped in to try and co-ordinate a newer, more up to date release. 90k is therefore not a recent release, and the kernel with the install is "old". It can be upgraded after install, but is not recent upon install.

Author:  impert [ Sun May 02, 2010 5:38 pm ]
Post subject: 

I've managed to get the wrong version (i386) installed on the wrong machine using the pci=nomsi kernel option.
My immediate problem now is that yum update gives an error message:
Quote: [Errno 4] IOError:>urlopenerror (-3, 'Temporary failure in name resolution')>
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: blag. Please verify its path and try again)

I got this address from the wiki - is it no longer current?

EDIT: Aargh! It's a network config problem. Thought it had been done.

I'll try a few kernel options on the other machine later (suggestions, anyone? It's an AMD X2 4850e on a GA-MA78GM-S2H mobo, with amd 780G northbridge and amd700 s.b.)
Oh, and thanks for the info, let's hope the project goes ahead!

Author:  impert [ Sun May 02, 2010 7:43 pm ]
Post subject: 

One more cheer!
sudo /sbin/service network restart

and now I'm downloading package 45 of 215 to update. With a bit of luck I'll have a desktop soon.[/code]

Author:  Junichirô [ Sun May 02, 2010 8:04 pm ]
Post subject: 

We are waiting for you on IRC!
Don't forget to add lvna repo during installation if you do a netinstall. Because now repo are on fsf server so libdvdcss is not in the repo but still in the default packages list.

Author:  impert [ Mon May 03, 2010 12:19 pm ]
Post subject: 

Thank you. I'm still about half a cheer from getting everything working. I've got a cli environment, but the X hangs at present while doing the gnome desktop.

Author:  impert [ Mon May 03, 2010 2:14 pm ]
Post subject: 

Another half cheer, which makes three in all. It turns out the trouble was the chrome driver. Changing it to "vesa" fixed it.
Later on I'll try for an x86-64 netinstall on the othe box.
Read the thread 'Is blag dead?' while waiting for things to download. Not very encouraging when I've only just discovered Blag! I hope reports of its death are exaggerated.

Author:  Junichirô [ Mon May 03, 2010 2:30 pm ]
Post subject: 

You can help us to maintain the distro and develop the future version that will be based on Fedora 12.

Author:  impert [ Tue May 04, 2010 10:08 am ]
Post subject: 

Thank you, Junichirô, but I'm afraid that my lack of skills is such that I would need so much coaching that it would be easier for someone more knowledgeable to simply do the work. I'm not at all sure just what is involved in maintaining a distro, any distro, nor what is involved in the particular case of one that seeks to be 100% free. I'm maybe a bit ideologically suspect, too: I confess to having a box-full of such evil distros as Ubuntu, Debian, Gentoo, Mandriva . . . ;-)
I have discovered though that I can manage very well without Mr Gates' software, and he seems to get by quite well without my money.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group