BLAG
http://forums.blagblagblag.org/

What the frag?
http://forums.blagblagblag.org/viewtopic.php?f=3&t=5118
Page 1 of 1

Author:  fcassia2010 [ Fri Jul 23, 2010 12:01 pm ]
Post subject:  What the frag?

I had good memories abount Blag. I switched some time ago to Fedora.

But this time, I needed to test something so I downloaded Blag 90001, and proceeded to install it into a Virtualbox VM.

I created an account Virtualbox, with password virtualb0x.

I can log-in just fine, but as soon as I try "su" I get "invalid password".

What gives? does Blag 90001 refuse to log-in as root? How is one supposed to install new apps??

First I thought that maybe root passwords were truncated to 8 chars, so I tried virtualb, with the same results.

FC

Author:  Saint of Killers [ Sat Jul 24, 2010 12:40 am ]
Post subject: 

No chance you mistyped it? Or your caps-lock key was on when you were setting the password?

Author:  fcassia2010 [ Fri Jul 30, 2010 9:30 am ]
Post subject: 

Saint of Killers wrote:
No chance you mistyped it? Or your caps-lock key was on when you were setting the password?


I know what is the problem, but I cannot fix it.

The SAME problem happened to me with Ubuntu (Netbook remix is what I´m using but I suppose the regular Ubuntu does as well) which comes with the root account disabled by default.

So you cannot "su" to root from a shell. You always get
"authentication failed" despite entering the right password. The
number of incidents if you do a Google search for "su authentication
failed" is mind blowing.... over 55,000 results.

All why? Because the error message "authentication failed" should
really say "root account logins are disabled". Now THAT would give
users some hint about what is happening.

WHO THOUGHT OF THIS??? Surely Microsª1

The usual response to this problem is to ". To work around this, enter "sudo -i" and run your root stuff there.

Well, I tried, but Blag gives me the finger....
saying my user is not in sudoers.

I fire the text editor and try to edit /etc/sudoers.... and I´m told I dont have permission.

F*ck.

There goes the VM. byebye Blag, you once were good.

Author:  ineiev [ Sat Jul 31, 2010 7:02 pm ]
Post subject: 

Strange. I'm running Blag 90001 from a virtual volume
on three USB flash discs; I have no difficulties with su.
I also easily login as root.

I'm not sure I recollect correctly, it was more then a year ago
when I installed it, but I think I logged in as root and edited
the sudoers file.

Author:  renilgh [ Tue Aug 03, 2010 5:49 pm ]
Post subject: 

BLAG90k did not have sudo enabled by default afair.
I think you are mistaken in your analysis.

Are you able to log in as root via a tty? Could you do so or boot into runlevel 1 and passwd the superusers pw?

Author:  nikR [ Tue Sep 14, 2010 4:15 pm ]
Post subject: 

I had the same problem. But I could fix it easily. Try one of the following:

At the $ prompt: type "su -" and then enter your password.
Or
Switch user. Login as "root" and enter your password.

The password to be entered is of the user created at the time of installation, or the current adminsitrative account. (I'm not sure of using the term "administrative" here)

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/