grub/dualboot problem maybe +SOLVED+
Page 1 of 1

Author:  zcat [ Tue Jun 17, 2008 2:39 pm ]
Post subject:  grub/dualboot problem maybe +SOLVED+

ok so i am up grading my dual boot blag winXP thinkpad 40gig drive to a 120 gb drive I use some windows program to make a copy of the drive and to proportionally make all the partitions bigger eg so what was a 5 gig partition is now a 15 gb partition on the new hd.
When i boot up the new drive grub is gone so i reinstall blag and grub is back but when i boot into winxp (which unfortunatly i do need) i get this msg
rootnoverify (hd0,0) chainloader +1 A disk read error occurred
so i boot blag and run fdisk
Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        1912    15358108+   7  HPFS/NTFS
/dev/hda2            2306       14594    98705911+   f  W95 Ext'd (LBA)
Partition 2 does not end on cylinder boundary.
/dev/hda5            2306        5736    27559476    b  W95 FAT32
/dev/hda6           10709       14594    31208782+   b  W95 FAT32
/dev/hda7            5737        7039    10466316   83  Linux
/dev/hda8            7040        7238     1598436   82  Linux swap / Solaris

and look at grub config
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,6)
#          kernel /boot/vmlinuz-version ro root=/dev/hda7
#          initrd /boot/initrd-version.img
title BLAG (2.6.18-1.2869.fc6)
   root (hd0,6)
   kernel /boot/vmlinuz-2.6.18-1.2869.fc6 ro root=LABEL=/1 rhgb quiet selinux=0
   initrd /boot/initrd-2.6.18-1.2869.fc6.img
title Whatever
   rootnoverify (hd0,0)
   chainloader +1

I think this is the same grub .config as other machines i got and they work i did notice that hda1 / HPFS/NTFS system starts on cylinder 1 is that right?
so is there somthing up with grub or is the winxp on that partition fucked?
Any ideas anyone i have googled a bit and dont seem to find anything that makes sense (to me anyway) and being command line dyslexic dosnt help :(
thanks zcat
installed blag60k

Author:  zcat [ Tue Jun 17, 2008 3:19 pm ]
Post subject: 

Now im wondering if there is anyway I can do the same thing in blag rather than a crappy windowz program.
Migrate a drive to a new one but it has to be able to do it proportionally so that I get all partitions bigger than they were on the original hd as then i know it would work the way I want it to
i have tried to do it in windoz and if i just make a straight copy it works but i have the same problems as i had on the old 40gb hd (not enough space on the win C drive and no way of making it bigger) (because of the extended partition, I think)
as i said im fairly command line dyslexic so need either very clear instructions or a gui.
cheers zcat

Author:  john maclean [ Tue Jun 17, 2008 6:27 pm ]
Post subject: 

Check up on the process that you used to copy the original data in the
first place, unless you know that you got it right first time. There
are quite a few tools that you can use to repartition your disk(s)....

man -k partition
GNU Parted [parted]  (8)  - a partition manipulation program
addpart              (8)  - simple wrapper around the add partition ioctl
delpart              (8)  - simple wrapper around the del partition ioctl
fdisk                (8)  - Partition table manipulator for Linux
jfs_mkfs             (8)  - create a JFS formatted partition
jfs_mkfs [mkfs]      (8)  - create a JFS formatted partition
kpartx               (8)  - Create device maps from partition tables
kpartx              (rpm) - Partition device manager for device-mapper devices
mpartition           (1)  - partition an MSDOS hard disk
parted              (rpm) - The GNU disk partition manipulation program
partprobe            (8)  - inform the OS of partition table changes
partx                (8)  - telling the kernel about presence and numbering of on-disk partitions
pvcreate             (8)  - initialize a disk or partition for use by LVM
pvresize             (8)  - resize a disk or partition in use by LVM2
qtparted            (rpm) - Partition Magic clone written in C++ using the Qt toolkit
sfdisk               (8)  - Partition table manipulator for Linux

You'd prefer the gui tool, huh? Go for qtparted and use it as user root.

Author:  john maclean [ Tue Jun 17, 2008 6:32 pm ]
Post subject: 

also you could try "rootnoverify (hd0,0)". Other than that the doze partition could be pffffft.

Author:  zcat [ Thu Jun 19, 2008 10:06 pm ]
Post subject: 

I got some advice from shawoho in irc and reformated the partition with ntfs (upgraded to 70k) and then simply cp,ed the original partition into the newly reformatted one.
it couldnt have been easier :)
after dicking about with bloody windows apps for days it took 2 hours
oh i wish that some linux geek would write some good film and photo apps
then i wouldnt need windoze

Author:  jebba [ Fri Jun 20, 2008 2:37 pm ]
Post subject: 

Well gimp kicks ass, so i'm not sure what you're missing there.

Hopefully there will be something usable for video in the "future". kdenlive appears to be heading in the direction of something with a decent feature set yet still being noobie friendly:

Author:  noldrin [ Fri Jun 20, 2008 3:12 pm ]
Post subject: 

I find gimp at lot easier than Photoshop.

Author:  gr00ve [ Mon Jul 21, 2008 10:39 pm ]
Post subject: 

Gimp has a looooong way to go before it can be even compared to Photoshop, much like open office & microcrap office comparison really, they are different products, very different in fact.

Author:  meandean [ Mon Jul 21, 2008 10:46 pm ]
Post subject: 

Gimp Isnt Mimicking Photoshop

I hope it is never compared to photoshop but keeps its own identity and different-ness. Gimp ROCKS!

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group