FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
updating my nvidia drivers

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
magnet
PostPosted: Fri Aug 06, 2004 1:10 pm    Post subject: updating my nvidia drivers Reply with quote

When I run their installer to update to the latest drivers, this happens.

Code:
-> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86' (1.0-6111):
   executing: './usr/src/nv/makedevices.sh'...
   executing: '/sbin/ldconfig'...
ERROR: Failed to execute `/sbin/ldconfig`:
-> The installer has encountered the following error during installation: 'Fail
   ed to execute `/sbin/ldconfig`'.  Continue anyway? ("no" will abort)? (Answe
   r: Yes)
   executing: '/sbin/depmod -aq'...
-> done.
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Sanity check passed.
-> Shared memory test passed.
-> Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
   (version: 1.0-6111) is now complete.  Please update your XF86Config or
   xorg.conf file as appropriate; see the file
   /usr/share/doc/NVIDIA_GLX-1.0/README for details.


So, sorry if this is a really dumb question, but why is /sbin/ldconfig failing? I tried to run it myself and it said 'Bus Error.' How do I fix this?

Also, at the end there when it tells me to update my XF86Config file, what do I need to update? I looked at the readme and on their forums but I'm still lost at what it is I need to update in the config to get it working.

Thanks in advance.

jebba
PostPosted: Fri Aug 06, 2004 8:36 pm    Post subject: Reply with quote

I don't know the answers to your questions...But I have a suggestion.

Try the RPMs available at ATrpms: http://atrpms.net

They may have a fix to your problem.

-Jeff

magnet
PostPosted: Sat Aug 07, 2004 11:14 am    Post subject: Reply with quote

Hmm, I couldn't find something that would fix it there. I did get the drivers working somewhat despite the install errors. I could once again run something like glxgears, albeit it was slower than usual. But for some reason now, it can't load the glx module even though I didn't make any changes concerning it.
jebba
PostPosted: Sat Aug 07, 2004 11:44 am    Post subject: Reply with quote

If you did an rpm of nvidia, I think there is a nvidia-glx rpm as well.

Also, make sure your Driver: line in XF86Config is nvidia and not vesa or something.

magnet
PostPosted: Sat Aug 07, 2004 3:20 pm    Post subject: Reply with quote

I didn't find a glx rpm there, but I did get it working again. I know for a fact that I changed the driver from 'nv' to 'nvidia' in XF86config, but I opened it up again out of sheer frustration and lo and behold, it was reverted to 'nv.' I also had to once again take out the options to load dri and GLcore, restarted x and glxgears pumps away once again.
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP