FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Enabling ntfs access - how I did it

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
red devil
PostPosted: Tue Aug 29, 2006 11:07 am    Post subject: Enabling ntfs access - how I did it Reply with quote

Hi,
I'm totally new to BLAG - and I'm liking it a lot.
One of the first surprises I found was that BLAG doesn't have ntfs support 'out of the box', which is a necessity for me as I'm dual-booting with XP Pro.
Then I learnt from a bit of googling that this is common with all Red Hat/Fedora-based distros (something to do with licences/legalities??).
So, to maybe help other BLAG newbies, I thought I'd post a short HOWTO on ntfs.
I must stress this works for me, but I'm nowhere near experienced enough to guarantee this will work for everyone, and I'd be happy to have it corrected/improved by more experienced forum users.
Also, I apologise in advance if this is like teaching grandma to suck eggs to a lot of you!
Anyway, here's how I did it:

Open a terminal and enter:

su
(root password)
uname -r

This will give you your kernel version - note it down. Next, enter:

uname -m

This gives you your system architecture (i386, i586, i686 etc). Note it down.
Open your web browser and go to www.linux-ntfs.org/content/view/130/66, where you will find a list of ntfs kernel modules. Select the one that matches your kernel and architecture, and download it.

Open a terminal, and su to root, then navigate to the folder containing your ntfs rpm by entering:

CD /location_of_rpm

Now you are going to install the rpm with the command:

rpm -Uvh full_package_name_here.rpm

It should only take a few seconds to install, and you'll be returned to your [root@localhost yourname].

Next, enter:

mkdir /mnt/windows

(You can call the mount directory whatever you like but Windows is the most obvious option, and you must use the same name when you edit your fstab later)

To determine which name BLAG has given to your Windows partition during install, enter:

fdisk -l

In my case, my Windows partition (it'll be the one labelled HPFS/NTFS) is sda1 but make sure you note down the correct name for your system. Now, as root, enter:

gedit /etc/fstab

This launches your fstab (filesystem table) in your text editor, and you need to add a line for your Windows partition as follows:

/dev/your_partition_name_here mnt/windows ntfs auto,umask=0222 0 0

What this means is that your Windows ntfs partition is automatically mounted in /mnt/windows/ and is accessible to both root and users.
If you now reboot, log in with your user name, open your file browser and navigate to /mnt/windows. you should be able to see - and copy across to BLAG - any files from your Windows partition.

HTH someone!



Last edited by red devil on Tue Aug 29, 2006 12:41 pm; edited 1 time in total

_________________
What happens if I click on this...?

Registered Linux user No. 382639
NicePics13
PostPosted: Tue Aug 29, 2006 11:19 am    Post subject: Reply with quote

What about this: http://osnews.com/story.php?news_id=15196 ?

_________________
jebba
PostPosted: Tue Aug 29, 2006 3:52 pm    Post subject: Reply with quote

Cool. Thanks for the post on how you got NTFS going. :)

We have some info here:
http://wiki.blagblagblag.org/NTFS

But I am not sure if it is as up-to-date as your post or as informative. Perhaps you could review that. :)

Ciao,

-Jeff

red devil
PostPosted: Mon Sep 04, 2006 7:36 pm    Post subject: Reply with quote

Hi Jeff,
I've added my HOWTO on the end of the existing Wiki stuff about enabling NTFS access - I didn't like to remove the other entries, being a new guy on the BLAG scene. I haven't tried the other ways but I know my way works, at least for me.
Cheers,
Red Devil


_________________
What happens if I click on this...?

Registered Linux user No. 382639
jebba
PostPosted: Mon Sep 04, 2006 7:53 pm    Post subject: Reply with quote

Nice, thanks :)
blaggard
PostPosted: Sun Sep 10, 2006 12:59 pm    Post subject: Reply with quote

Red Devil,

The procedures worked for me and I got to my backed up data on a NTFS
drive. Thanks. For me the issue was that the drive got mounted as root read only.
After I follwed your procedures, I got it to mount as read-write for normal users.

I also found out that if you use the "WIne FIle", the NTFS drive showed up.
Don't know if wine could have detected it with out the kernel upgrade.
I will have to try if using wine file, I can write to it as a normal user.

Blaggard

mullenbrock
PostPosted: Sun Sep 10, 2006 6:17 pm    Post subject: Reply with quote

i only have read access, no write access for both my ntfs drive and my fat32 drive, is there a way i can enable write access? i would like to use my fat32 drive as common storage space until i completely switch over to linux.
mullenbrock
PostPosted: Wed Sep 13, 2006 2:18 am    Post subject: Reply with quote

mullenbrock wrote:
i only have read access, no write access for both my ntfs drive and my fat32 drive, is there a way i can enable write access? i would like to use my fat32 drive as common storage space until i completely switch over to linux.


here is my fstab:
Code:

/dev/VolGroup00/LogVol00 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0
/dev/sda1 mnt/windows ntfs auto,umask=0222 0 0
/dev/hda1 /mnt/shared vfat auto,umask=0222 0 0
[/code]
Caraibes
PostPosted: Thu Sep 14, 2006 12:47 pm    Post subject: Reply with quote

Thank you very much, Red Devil, as your method worked perfectly for me !

I had given up on NTFS with my Blag boxes... Good job !

dkpw
PostPosted: Mon Oct 23, 2006 6:39 pm    Post subject: Reply with quote

Thnx for your work there Red Devil!

Coming from Slackware - I was initially perturbed by the alert following a mount command with "ntfs -filesystem not known."

Regards

dkpw

jebba
PostPosted: Mon Oct 23, 2006 6:51 pm    Post subject: Reply with quote

I think in the near future fedora is going to start enabling it in their kernels. I'm not sure exactly what the change is, but they initially disabled it do to lawyerie stuff.

-Jeff

dkpw
PostPosted: Tue Oct 24, 2006 2:33 pm    Post subject: Reply with quote

jebba wrote:
I think in the near future fedora is going to start enabling it in their kernels. I'm not sure exactly what the change is, but they initially disabled it do to lawyerie stuff.

-Jeff


That's the way - always trouble when the lawyers get involved...

Kind regards,

dkpw

PS Thanks for a blinding distro Jeff - I'm sticking with Slack for servers - I mostly know what I'm doing but the ThinkPad is now dual booting Blag and XP.

vx
PostPosted: Thu Aug 20, 2009 11:46 pm    Post subject: Reply with quote

I didn't have to edit anything on /etc/fstab on my 9k

I just installed 'ntfs-3g' and the cool front-end 'ntfs-config' from repo to have read/write support on a HPFS/NTFS drive,
( screenshot --> http://flomertens.free.fr/ntfs-config/image2.png )

(...)
but ...
the only thing I have to consider is that, if the ntfs drive (external in my case) is not connected at boot time, only root can mount it later

my fstab is like this now:
Code:

#Entry for /dev/sdb1 :
UUID=55D189L54   /media/external  ntfs-3g defaults,nosuid,nodev,locale=es_ES.utf8 0 0

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP