FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Help playing streaming audio

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
contents
PostPosted: Wed Nov 22, 2006 8:01 pm    Post subject: Help playing streaming audio Reply with quote

I'm not able to get the BBC World Service to play--(here and then click on any of the "Listen" buttons). The preferences asks to select Windows Media Player or Readplayer. I had thought that mplayer should be able to play one or both of these streams, but neither choice works for me. Is there some setting I need to change? Or am I wrong about mplayer?

Thanks.

slick50
PostPosted: Wed Nov 22, 2006 8:29 pm    Post subject: Reply with quote

Well, Mplayer plug-in not working for me,but Realplayer works. (Volume is kinda low so check that it's up pretty good when listening).

No special setting that I know of.

stevo32
PostPosted: Wed Nov 22, 2006 9:02 pm    Post subject: Reply with quote

You may need mplayer win32 codecs. Grab them from mplayer's official website and shove them in /usr/lib/codecs/.

Thanks,
Stephen Clement


_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).
contents
PostPosted: Thu Nov 23, 2006 1:55 pm    Post subject: Reply with quote

Thanks much slick50 and stevo32,

Following your instructions I was able to get streaming audio to work with mplayer, though not right away. I'm not sure if this was "the right way" or "the best way". Here's what I did:

1. I downloaded the all of the "essential" codecs from the mplayer homepage here (about halfway down the page) plus the win32 codecs and the rp9 codecs from here, unpacked them, and then as root pasted all of included files into /usr/lib/codecs

2. I downloaded and installed the mplayerplug-in from here.

3. Then, according to the instructions for gnome users on the mplayerplug-in configuration page, I added this line to the .mplayer file in my home directory:
ao=esd

I am not sure if that last part was necessary. Looking around on google, I found that ao means "audio output", and that "esd" is a daemon that allows different applications to run sound at the same time.

I'm going to post another message in the development forum with questions I've come up with about this...

Thanks

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP