BLAG

BLAG Forums
It is currently Sat Dec 20, 2014 4:32 pm

All times are UTC




Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: Wed Jun 27, 2007 6:56 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
An alpha test image of BLAG 70k is available on the FTP site. This release is
meant for people who would like to preview and test the next stable release of
BLAG which will be 70000. The current stable release of BLAG is 60001.

This 70k series is updated to use Fedora 7 as a base and kernel 2.6.21. It's in pretty good shape already, but has a few things to smooth out.

To download go to:
ftp://ftp.blagblagblag.org/pub/blag/linux/70000/en/iso/

The latest image as of this post is:
BLAG-69999.10002.iso (698M)

http://bugzilla.blagblagblag.org

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 28, 2007 6:49 pm 
Offline

Joined: Tue May 22, 2007 10:26 am
Posts: 18
Hi jebba,
I have just installed the alpha in an old P III 667 MHz 392 MB RAM and it performs quite well. I really like the wallpaper :-)

I don't know if some kind of bug reports are required, but here are mine:

- During installation, test cd fails, even having tested the MD5SUM before burning the CD and using writing check in k3b.
- Installed OpenOffice through Synaptic, but fails to appear in the gnome menu. When I try to open a file with the dialog box "open with", the application (Firefox-Bon Echo) freezes and shuts down.
-Duplicated Synaptic's icon in System Administration.

I hope it helps.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 28, 2007 7:43 pm 
Offline

Joined: Tue May 22, 2007 10:26 am
Posts: 18
Sorry. Forget about the bug with OpenOffice. It was my fault for not installing all the necessary packages.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 28, 2007 10:07 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
harmattan wrote:
During installation, test cd fails, even having tested the MD5SUM before burning the CD and using writing check in k3b.
When I try to open a file with the dialog box "open with", the application (Firefox-Bon Echo) freezes and shuts down.
-Duplicated Synaptic's icon in System Administration.


Try burning with this:
cdrecord -pad -dao -data BLAG-69999.10002.iso

I burned and tested a CD fine. If it fails the media check, well, it means some data was "off".

I've noted the synaptic icons here:
http://bugzilla.blagblagblag.org/show_bug.cgi?id=905

I'm not sure about firefox.

Thanks,

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 29, 2007 10:11 pm 
Offline

Joined: Sat Jun 09, 2007 4:16 pm
Posts: 56
Just to report that I have just upgraded from 60001 to 69999.10002 with the CD.

Better that I was not a newbie though! Because of the new naming of the partitions (from /dev/hdaX to /dev/sdaX) in Linux 2.6.21, I had this message leading to a reboot:
Code:
Error enabling swap device hda3: No such file or directory

The /etc/fstab on your upgrade partition does not reference a valid swap partition.

Press OK to reboot your system.


To fix the problem (which, fortunately, I was aware of), I commented every partition in my /etc/fstab that was not labelled and I relaunched the upgrade. The upgrade went well but the "finalization" (once the progress bar ended) of the upgrade took ages. I was about to hard reboot my computer when it completed. I do not know what is done during this phase. Maybe it is due to the quantity of extra softwares present on my system...

When I reboot I was greeted with a kernel panic. I edited the kernel line from grub to modify the "root=/" item with the actual label of my root partition. After a new reboot, I was invited to repair my file systems. What I did: I (re)labelled them with /sbin/e2label, checked my /etc/fstab and profit from the occasion to add the partitions I previously commented and which totally disappeared during the upgrade process. This last reboot was the good one![/code]


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 29, 2007 11:51 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Yes, the /dev/hd* to /dev/sd* renaming is the biggest change in F7 that I see. Though it should "just work". Had you created your partitions outside of anaconda and used /dev/hd* in your fstab? Or was the previous 60k install just a "standard" install? I'm guessing the former.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 30, 2007 12:44 am 
Offline

Joined: Sat Jun 09, 2007 4:16 pm
Posts: 56
If I remember well, the standard install did not put any line for my other partitions (another ext3, a fat and a ntfs which I keep just in case I want to sell my laptop). I added them to /etc/fstab and, maybe, I edited some other things (I come from Gentoo, it's like a disease)... but I don't remember I touched the line regarding the swap partition. Maybe I did... :-)

Other trouble: gcc-c++ broken once the upgrade done. From dependence to dependence I had to remove 34 packages which I am currently reinstalling along with the update of all the rest of my softwares.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 30, 2007 4:24 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Magic Banana wrote:
Other trouble: gcc-c++ broken once the upgrade done. From dependence to dependence I had to remove 34 packages which I am currently reinstalling along with the update of all the rest of my softwares.


Oh, I should mention, after upgrading this is probably the best series of commands to run to get your non-cd packages up to date:

Code:
apt-get update
apt-get -f dist-upgrade


-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 30, 2007 4:33 am 
Offline

Joined: Wed Sep 14, 2005 6:08 pm
Posts: 108
Location: Oakland, CA, U$A, Earth, Milky Way
Any guestimates about when 70000 will go gold? Fedora 5 is no longer supported, but I don't feel like upgrading my Blag 50k boxen to 60001 if 70000 is just around the corner (say, less than 3 months).

No Linux upgrade process is clean enough that I'd want to do an upgrade with a Alpha (or even Beta), plus my Blag installs are very heavily customized, so I'd want to use the Developer DVDs (looooots of KDE). Jeez, even upgrading Debian Stable from Sarge to Etch was a big PITA, which is to be expected given that it was a 2.5 year jump in technology.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 30, 2007 8:53 am 
Offline

Joined: Sat Jun 09, 2007 4:16 pm
Posts: 56
There seems to be a trouble with the upgrade of the fonts:

Code:
Lors de l'installation du paquet tetex-dvips-3.0-39.fc7 :

warning: /usr/share/texmf/fonts/map/dvips/antp/antp.map created as /usr/share/texmf/fonts/map/dvips/antp/antp.map.rpmnew
warning: /usr/share/texmf/fonts/map/dvips/antt/cork-antt.map created as /usr/share/texmf/fonts/map/dvips/antt/cork-antt.map.rpmnew
...
warning: /usr/share/texmf/fonts/map/pdvips/psfonts_jp.map created as /usr/share/texmf/fonts/map/pdvips/psfonts_jp.map.rpmnew

Lors de l'installation du paquet yum-3.2.1-1.fc7 :

W: Échec de la récupération de http://www.blagblagblag.org/70000/i386/RPMS.extras/fontforge-20061220-1.fc7.i386.rpm
  Connection timed out


Thank you for the couple of commands jebba. I do not really have the habit of apt-get...[/code]


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 30, 2007 8:59 am 
Offline
Site Admin

Joined: Wed Mar 17, 2004 6:17 pm
Posts: 1340
Location: London, UK
Code:
apt-get --fix-broken install

Also works for me when I install from a USB key,

_________________
BLAG 'em up!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 01, 2007 3:27 pm 
Offline

Joined: Fri Nov 18, 2005 3:07 am
Posts: 699
Praxis wrote:
Any guestimates about when 70000 will go gold? Fedora 5 is no longer supported, but I don't feel like upgrading my Blag 50k boxen to 60001 if 70000 is just around the corner (say, less than 3 months).

No Linux upgrade process is clean enough that I'd want to do an upgrade with a Alpha (or even Beta), plus my Blag installs are very heavily customized, so I'd want to use the Developer DVDs (looooots of KDE). Jeez, even upgrading Debian Stable from Sarge to Etch was a big PITA, which is to be expected given that it was a 2.5 year jump in technology.


Yes, wait for the official release. I imagine BLAG 70K will get released when it's done. No one knows when that will be, but the process is underway. I'd personally guessitimate we'll see it in July. Actually July 14th will be the 6 month mark from 60K. I'd wait for 70K unless you have a burning reason to upgrade. I never bothered to upgrade my 50K box to 60K, but when 70K is released. I'll upgrade both my 50K box and my 60K boxes to 70K. It's looking that snazzy.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jul 01, 2007 5:16 pm 
Offline

Joined: Wed Sep 14, 2005 6:08 pm
Posts: 108
Location: Oakland, CA, U$A, Earth, Milky Way
Great, I'm looking forward to it (sort of, upgrades always fill me with a bit of apprehension).

I'm typing this on Fedora 7 which is my little living room Shuttle SFF stereo rack SPDIF sound and 32" 800x600 tube TV machine, upgraded from Fedora 5. The upgrade was fairly rocky and all the kinks aren't quite worked out (like I have to start a root console and go through system-config-soundcard to get the sound to work decently through my receiver every session). I'm still half considering blowing it away and replacing it with Mythdora 4.0 based on FC6 if it doesn't start shaping up.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 04, 2007 9:22 am 
Offline

Joined: Sun May 27, 2007 6:17 pm
Posts: 10
Running it now. Very nice. And not having any of the problems I had in the previous release (not that they were major, just damn annoying)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 08, 2007 12:31 pm 
Offline

Joined: Sat May 01, 2004 3:42 pm
Posts: 129
Location: 'Burbs of the Windy City
Hi,

Upgraded to BLAG 69K last night from 60K. Smoothest upgrade ever!

After upgrade, I uninstalled and tried to reinstall pdftk. I get a missing dependency
error stating "Depends: libgcj.so.8rh". Trying to uninstall libgcj uninstalls a lot
of packages so I didn't choose that option. How can I resolve this dependency?

Also libgcc (4.1.2-13.fc6) and libgcj (4.1.2-13.fc6) appear in installed (local or
obsolete) section. I have fixed the broken links, did the apt & yum udpates etc.,
after the upgrade. How do I get these libs to the right version? Is it important?

As always, BLAG rocks with this newest alpha! Kudos to Jebba & the team!

Regards.

Blaggard


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group