FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
avidemux broken

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
gr00ve
PostPosted: Sun Nov 18, 2007 5:40 pm    Post subject: avidemux broken Reply with quote

Upgraded to BLAG 70K, runs a lot faster then 60K which is great :) ! One slight problem though - is there any chance to get avidemux fixed please? it's kinda essential tool in easy to use video editing. Thanks!

------------------------------
apt-get install avidemux
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
avidemux: Depends: libx264.so.54 but it is not installable
E: Broken packages

jebba
PostPosted: Sun Nov 18, 2007 10:54 pm    Post subject: Reply with quote

I think you'll need the x264 packages from livna. I have the freshrpms ones in the repo. If you bugzilla it I can look at what will break if i just switch from freshrpms to livna, or you can just download them from livna now ;)
gr00ve
PostPosted: Mon Nov 19, 2007 8:35 pm    Post subject: Reply with quote

thanks!

still a problem though
ehhhh ok, so i've installed

http://livna-dl.reloumirrors.net/fedora/7/i386/x264-0-0.8.20061028.lvn7.i386.rpm
http://livna-dl.reloumirrors.net/fedora/7/i386/avidemux-2.3.0-3.lvn7.i386.rpm

but after this lots of other *multimedia* stuff is gone :)

apt-get install dvdrip ffmpeg ffmpeg-libpostproc kino libquicktime mencoder mjpegtools mplayer ogmrip qdvdauthor subtitleripper thoggen transcode vlc xvidcap
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
gstreamer-plugins-bad x264
The following packages will be upgraded
x264
The following packages will be REMOVED:
avidemux

noldrin
PostPosted: Mon Nov 19, 2007 9:47 pm    Post subject: Reply with quote

remove the foreign packages and then reinstall stuff. If it doesn't work, foward to bugzilla so jebba can fix the packages correctly for the BLAG repo.
gr00ve
PostPosted: Tue Dec 25, 2007 12:24 pm    Post subject: Reply with quote

ok, so looks i finally got avidemux to work in blag 70k (bug was also filed)
what needed to be done was as following in case somebody else needs to have this tool without uninstalling current version of x264 as a lot of other multimedia packages depend on it:

find
avidemux-2.4-10_preview2.fc7.i386.rpm & x264-0-0.8.20061028.lvn7.i386.rpm

(yes higher version of x264 is likely to already be installed, but you do not need to uninstall it)

unpack both rpm's without installing them (right click in nautilus and to extract here)
for avidemux this creates /usr/bin & /usr/share
for x264 this creates /usr/bin, /usr/lib, /usr/share

copy contents of avidemux's dir's into /usr/local/bin & /usr/local/share respectively.

copy x264's /usr/lib/libx264.so.54 into /usr/lib/ (nothing else is needed)

adjust shortcut to point to /usr/local/bin/avidemux2

Note: While it is possible to edit/re encode & etc, playback audio in avidemux is not available, everything else appears to work fine including audio in output files.

brunob
PostPosted: Thu Dec 27, 2007 11:40 pm    Post subject: Reply with quote

gr00ve,

thanks for the directions...worked great for me and saved me quite some time
to figure out how to get Avidemux working!

cheers
Bruno

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP