BLAG

BLAG Forums
It is currently Fri Dec 19, 2014 3:52 pm

All times are UTC




Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject:
PostPosted: Sat Jan 12, 2008 10:01 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
extraspecialbitter wrote:
The problem is that Red Hat doesn't support XFS


You sure? It's there in fedora (and used to be in redhat last i used it). It isn't a "supported" system in that they don't recommend it to customers, but it's in the kernel (at least fedora):

/lib/modules/2.6.23.12-52.fc7/kernel/fs/xfs/xfs.ko


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jan 12, 2008 11:47 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
jebba wrote:
extraspecialbitter wrote:
The problem is that Red Hat doesn't support XFS


You sure? It's there in fedora (and used to be in redhat last i used it). It isn't a "supported" system in that they don't recommend it to customers, but it's in the kernel (at least fedora):

/lib/modules/2.6.23.12-52.fc7/kernel/fs/xfs/xfs.ko


I thought it very bizarre that Fedora and CentOS would support XFS and that Red Hat wouldn't, but an exhaustive search through the Red Hat Network turned up empty. Ultimately our Account Rep confirmed what I had read through a source as authoritative as Wikipedia - that Red Hat had stripped the XFS module (among others) out of the 2.6 kernel and had no plans to support the filesystem in the future, instead putting all of their eggs in the ext4 basket. Imagine the surreal experience of showing up at a customer site with a USB stick full of "unsanctioned" packages in hand...


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jan 14, 2008 3:41 am 
Offline

Joined: Fri Jan 04, 2008 3:21 am
Posts: 44
i just don't understand a lot of what everyone is talking about. i did find this article
http://aptgetanarchy.org/blag/nvidia
[/url]http://aptgetanarchy.org/blag/nvidia[url]
i followed the directions but the installer was unable to find the kernel source????
what is it and how do i down load that from blag?
also its kinda getting frustrated, earlier i tried to down load a torrent file from pirate bay and it downloaded with miro. I have down loaded a billion things off pirate bay with XP using Azureus but i could get the download manager to offer anything other Miro, then i tried to burn the torrent using QDVD Author but was met with additional errors and unable to. I did all this things fine on xp but I hate the Microsoft Corpo-rape take over of the world. I thought also maybe a video of basic instructions of the various task and even how to use a few programs would be good instead of a video what blag looks like after the distro is installed(referring to "support videos" in the support forum) no doubt thats what scares most people away from Linux they just don't understand it. All i have learned has been from this forum and others online. I going to give a few more go's before i toss in my dell Xp recovery disk and go back to being Bill Gates concubine. If any know the answers to the questions above i greatly appreciate it.
Thanks
//sunny//[/url]


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jan 15, 2008 1:22 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
s6k wrote:
i just don't understand a lot of what everyone is talking about. i did find this article
http://aptgetanarchy.org/blag/nvidia
[/url]http://aptgetanarchy.org/blag/nvidia[url]
i followed the directions but the installer was unable to find the kernel source????
what is it and how do i down load that from blag?
also its kinda getting frustrated,


I'd say until you learn more, if you're really getting frustrated stop with the proprietary nvidia thing. It's /their/ fault they don't make truly Free drivers.

s6k wrote:
earlier i tried to down load a torrent file from pirate bay and it downloaded with miro. I have down loaded a billion things off pirate bay with XP using Azureus but i could get the download manager to offer anything other Miro,


Menu->Internet->BitTorrent File Transfer

Try that program instead of Miro, which is meant to be more like a full blown "internet tv".

s6k wrote:
then i tried to burn the torrent using QDVD Author but was met with additional errors and unable to.


qdvdauthor is not for burning CDs, but more for making DVD menus and stuff like that. http://lwn.net did an article about it (and DVDStyler) recently. I think the very best burning program is `k3b`, but it isn't on the CD since it drags in lots of KDE stuff. If you have enough RAM (like 512M or so) download that and check it out.

s6k wrote:
I did all this things fine on xp but I hate the Microsoft Corpo-rape take over of the world.


You can burn CDs and download bittorrents with BLAG.


s6k wrote:
I thought also maybe a video of basic instructions of the various task and even how to use a few programs would be good instead of a video what blag looks like after the distro is installed(referring to "support videos" in the support forum)


Yes, that's a good idea. John is heading that way, methinks.

s6k wrote:
I going to give a few more go's before i toss in my dell Xp recovery disk and go back to being Bill Gates concubine. If any know the answers to the questions above i greatly appreciate it.


Yuck. Anyway, try to do it /truly/ free without the proprietary crap if you're going to try it. It seems you've spent a good deal of time trying to force some non-Free binary into BLAG. Don't take it out on BLAG that crap binary things don't work!

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jan 15, 2008 7:42 pm 
Offline

Joined: Mon Mar 27, 2006 11:05 pm
Posts: 286
s6k wrote:
i followed the directions but the installer was unable to find the kernel source????
what is it and how do i down load that from blag?



1) yum clean all
2) yum update (just to make sure you have the latest kernel & etc, otherwise don;t need to do this)
3) yum install gcc binutils make
4) yum install kernel-devel
5) http://www.nvidia.com/Download/index.aspx?lang=en-us select * download the driver corresponding to your vid card
6) chmod 555 NVIDIA-Linux-x86-xxx.xx.xx-pkg1.run
7) telinit 3
8) ./NVIDIA-Linux-x86-xxx.xx.xx-pkg1.run
when prompted to download prebuilt module say no
9) upon booting and hopefully getting x to start run nvidia-settings to fine tune settings
if it doesn't start either telinit 5 or ctrl + alt + f7 if all else fails post what the config for x looks like


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 17, 2008 2:47 am 
Offline

Joined: Fri Jan 04, 2008 3:21 am
Posts: 44
Thanks Jebba,
I really like the idea and the OS, Thanks for the suggestion on the burning program. I'm currently reading around the web trying to increase my Linux skill . And thanks Gr00ve for the advice, I was under the impression that Livna was a free source and not just a repackaging of NVIDIA's stuff. I'll be interested in a 3-d graphics driver when a free one is out, freedom is worth waiting for.
one thing though when i did run
Code:
yum update


I got the following error

Code:
Error Downloading Packages:
  nautilus-sendto - 0.12-1.fc7.i386: failure: nautilus-sendto-0.12-1.fc7.i386.rpm from errata: [Errno 256] No more mirrors to try.
  bash - 3.2-19.fc7.i386: failure: bash-3.2-19.fc7.i386.rpm from errata: [Errno 256] No more mirrors to try.


any ideas?
//sunny//


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 17, 2008 4:35 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
s6k wrote:
Code:
yum update


I got the following error

Code:
Error Downloading Packages:
  nautilus-sendto - 0.12-1.fc7.i386: failure: nautilus-sendto-0.12-1.fc7.i386.rpm from errata: [Errno 256] No more mirrors to try.
  bash - 3.2-19.fc7.i386: failure: bash-3.2-19.fc7.i386.rpm from errata: [Errno 256] No more mirrors to try.


uh. I have fixed a few things related to `yum` and the repos, but apparently not everything. Try a `yum clean all` and then `yum update`. If that doesn't work, use apt. :) `apt-get udpate` then `apt-get dist-upgrade` for example.


Top
 Profile  
 
PostPosted: Fri Jan 18, 2008 1:49 am 
Offline

Joined: Sun Aug 13, 2006 8:26 pm
Posts: 42
Veganbikepunk wrote:
I went to a guide to installing the driver for my NVIDIA graphics card to have 3d support, but in order to install it I obviously need to kill X. So I do Control-Alt-F1, but it says X is still running, so I do Telinit 3, but when I do that it tries to kill the services from Init 4 or 5 (i'm not sure which), but stalls on Starting Jexec Services, and I have to control-alt-delete to a reboot after a while of it not working. Thanks in advance for you help (A)//(E)


I'm surprised by a few things that have been left out in other posts. First, have you checked whether the specific Nvidia chipset you have is supported by the xorg-x11-drv-nv package? By a newer version (from freedesktop.org) not yet packaged?

Second, updating your configuration for display is fairly painless with system-config-display. Do an init3, which will not present a prompt after completed, so perhaps press enter for a prompt. Run "system-config-display --reconfig," verify you are using the correct monitor and video driver, and use the toggle menus to make your modifications.

Hope that helps.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jan 20, 2008 3:19 pm 
Offline

Joined: Mon Mar 27, 2006 11:05 pm
Posts: 286
bash package looks borked - it goes up to about 80% on update and quits. looks like apt-get update to yum solves this.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jan 21, 2008 5:38 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
gr00ve wrote:
bash package looks borked - it goes up to about 80% on update and quits. looks like apt-get update to yum solves this.


I'm not sure what's up there. To get around it, run:

Code:
rpm -Uvh http://www.blagblagblag.org/70000/i386/RPMS.errata/bash-3.2-19.fc7.i386.rpm


bash bugzilla:
http://bugzilla.blagblagblag.org/show_bug.cgi?id=993


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group