FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Update problem with xine-lib package

Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
PostPosted: Sun Feb 03, 2008 11:45 pm    Post subject: Update problem with xine-lib package Reply with quote

For the past week or so the updated xine-lib package shows up as an available update, but I can not get this update.


Magic Banana
PostPosted: Mon Feb 04, 2008 2:08 pm    Post subject: Reply with quote

I go through the same phenomenon here. I am using BLAG 70000. Every package is upgraded but xine-lib and xine-lib-extras:
# apt-get upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
The following packages have been kept back
  xine-lib xine-lib-extras
0 upgraded, 0 newly installed, 0 removed and 2 not upgraded.

I do not know either why it is so.

PostPosted: Mon Feb 04, 2008 7:22 pm    Post subject: Reply with quote

I uninstalled xine-lib-moles, and then the update went through. Not sure what xine-lib-moles does.

When I try to add xine-lib-moles back in, it says I have the wrong version of xine-lib (or something like that).

I don't really use Xine, so I probably wont miss it. Still concerned when there is a little glitch.


Magic Banana
PostPosted: Tue Feb 05, 2008 10:13 am    Post subject: Reply with quote

When you remove xine-lib-moles, xine is removed as well... and xine-lib-moles is reinstalled if you try to reinstall xine...

This problem is well known (just check how many times you count "xine-lib-moles on this page).

A workaround exists for those who cannot wait for the new package in the repositories.[color=blue]

PostPosted: Tue Feb 05, 2008 6:35 pm    Post subject: Reply with quote

Thanks for the info. Since I don't use Xine, I will hold off on re-installing it.


PostPosted: Tue Feb 19, 2008 6:02 pm    Post subject: Reply with quote

I use xine, so I was disappointed to see it disappear after my most recent BLAG 70000 update. I inquired on the Fedora forum (see http://forums.fedoraforum.org/forum/showthread.php?t=181509) and was only told:

You will need to delete the freshrpms repo as it is obsolete, then remove all the xine packages and install the Livna repo. Then re-install xine.

Of course I used the BLAG repo and not freshrpms, but what I think is being suggested is that I remove any references to xine and replace them with xine, xine-lib and xine-lib-moles from Livna. I'm not sure I want to do this. I might just content myself to use mplayer where I had previously used xine.

PostPosted: Tue Feb 19, 2008 7:13 pm    Post subject: Reply with quote

I am switching over the xine in the repo to the livna version and not the freshrpms version.

In the past I "preferred" the freshrpms packages to the livna ones, but from now on I will prefer livna over freshrpms as that appears to be the "approved" trend.

Thanks for tracking this down for me and I'm sorry I didn't do it myself earlier. The time that I have spent in development seems to be getting eaten by kernels.


PostPosted: Mon Mar 03, 2008 3:17 pm    Post subject: new manifestation of the problem... Reply with quote

ok, so now i have a slightly different problem.

[root@box ~]# rpm -q xine xine-lib xine-lib-moles
package xine-lib-moles is not installed
[root@box ~]#

i don't actually use xine for image watching [why would use anythung but vlc?], but use amarok for audio stuff. amarok uses libamarok_xine-engine v1 fw30:

[root@box ~]# rpm -q amarok
[root@box ~]#

tells me that everything i try to play [whether ogg or mp3]:

Error Loading Media
There is no available decoder.

i'm assuming therefore that xine-lib-moles contains the decoders amarok/xine needs. i therefore do

[root@box ~]# apt-get install xine-lib-moles
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  xine-lib-moles: Depends: xine-lib (= 1.1.10)
E: Broken packages
[root@box ~]#

as i mention above we have, so this seems a little odd...

PostPosted: Fri May 02, 2008 12:21 pm    Post subject: same maybe Reply with quote

Maybe same problem here


May 01 00:36:17 Installed: libxcb.i386 1.1-1.fc7
May 01 00:36:21 Updated: xine-lib.i386
May 01 00:36:24 Installed: vcdimager.i386 0.7.23-5.fc7
May 01 00:36:24 Installed: xine-lib-extras.i386
May 01 00:36:26 Updated: xine-lib-moles.i386 1.1.10-1.fc7

no mp3 playback for me ...
(all that was for xine-lib-extras package)


May 02 13:47:39 Erased: xine-lib-moles

and when trying yum install xine-lib-moles ... broken dependencies ...

things like:

rpm -e --justdb --nodeps xine-lib
rpm -e --justdb --nodeps xine-lib-moles
May 02 14:23:26 Installed: xine-lib.i386 1.1.7-1.fc7
May 02 14:24:03 Installed: xine-lib-moles.i386 1.1.7-1.fc7

didn't help ... still no mp3 playback for me ... tired.

PostPosted: Fri May 02, 2008 1:40 pm    Post subject: Reply with quote

Have you tried using APT to straighten it out? You needs the moles for mp3. I'd erase all the xine and then reinstall it using APT.
PostPosted: Fri May 02, 2008 2:15 pm    Post subject: fixed Reply with quote

so my quest is over here is the story:

after removing all xine-lib and xine-lib-moles and all their dependencies i tried to install
xine-lib 1.1.7 and xine-lib-moles 1.1.7, went well but maybe this rpm (xine-lib) has problem with alsa and then amarok complains "xine unable to initialize audio drivers", nothing against amarok didn't help (deleting of configuration files etc)

after short walk through my directories i found that xine-lib installed itself into /usr/lib/xine/plugins/1.20, but xine-lib-moles 1.1.10-1.fc7 was in /usr/lib/xine/plugins/1.1.10


$ pwd
$ ls
1.1.10  1.20

so my solution for mp3 playback - copy all files from xine-lib-moles directory into xine-lib directory, this way i ended up with:


$ yum list installed | grep xine
xine-lib.i386                         installed       
xine-lib-moles.i386                      1.1.10-1.fc7           installed

PostPosted: Mon Jun 02, 2008 11:54 pm    Post subject: [SOLVED] xine/amarok/mp3/ogg Reply with quote

i believe jebba has mucked around with the sources for the various packages and this particular combination works:

[root@box ~]# rpm -q xine xine-lib xine-lib-moles
[root@box ~]#

ta muchly.


Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP