BLAG

BLAG Forums
It is currently Thu Dec 18, 2014 10:38 am

All times are UTC




Post new topic Reply to topic  [ 121 posts ]  Go to page 1, 2, 3, 4, 5 ... 9  Next
Author Message
 Post subject: BLAGHEAD
PostPosted: Wed Apr 23, 2008 5:38 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
I have set up a new repository called BLAGHEAD.

It tracks fedora rawhide/development and a few other repos which are building for this (e.g. atrpms f9 packages).

Code:
$ cat /etc/yum.repos.d/blaghead.repo
[blaghead]
name=BLAGHEAD
baseurl=http://www.blagblagblag.org/blaghead/i386/
enabled=1
gpgcheck=0


I am doing x86_64 as well, and everything should be apt-get'able as well but with directory name changes. Whereas before it was like RPMS.extras and such, the dirs are now: RPMS.atrpms, RPMS.blag, RPMS.dribble, RPMS.fedora, RPMS.livna

Note, this is very bleeding edge with everything.

I wrote a script which goes through and makes a whitelist of everything in a repository which has a FSF-Free license and adds it to our repo. I'll need to come up with blacklists of programs we don't want from particular places (e.g. perhaps we want atrpms mplayer, but not livnas or somesuch). Let me know if you come across things needing blacklisting.

Have fun,

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 9:40 am 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 193
jebba wrote
Quote:
I'm setting up BLAGHEAD on my Eee right now... I think some of the more "robust" blag users should start tracking it, perhaps... ;)

I have just upgraded to Blaghead, it's working with a couple of issues at the moment such as
The following packages have unmet dependencies:
event-compat-sysv: Obsoletes: sysvinit (< 2.86-24)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Also get this error doing an apt-get update:
Reading Package Lists... Done
Building Dependency Tree... Done
Del xmms-1.2.11-36.99 8.fc8 [1787kB]
Del fuse-devel-2.7.3-8 9.fc8 [27.2kB]
Del fuse-libs-2.7.3-8 9.fc8 [74.1kB]
W: There are multiple versions of "ices" in your system.

I suppose these are just the usual teething problems that we have to iron out and as always "HELP" is welcome and appreciated :)

PS: apt-get clean all resolved the first issue.

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 2:46 pm 
Offline
Site Admin

Joined: Wed Mar 17, 2004 6:17 pm
Posts: 1340
Location: London, UK
weyasey, what's the result of cat /etc/issue?

_________________
BLAG 'em up!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 3:48 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
For sysvinit, there's a new one now, which may fix that. If not, you may have to run this first (note once this is run you inittab/startup is changed completely!)

Code:
apt-get install upstart event-compat-sysv


You'll have to `rpm -q ices`, find the older one then `rpm -e ices-0.0.1` or whatever. The sysvinit thing is a repo issue, the ices thing you managed on your own. ;)

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 4:14 pm 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 193
I did try to remove the older ices but got the following error
Code:
rpm -e ices-2.0.1-4.fc7.i386
error: %postun(ices-2.0.1-4.fc7.i386) scriptlet failed, exit status 1


Also still have issues when trying dist-upgrade

[code]apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Failed
The following packages have unmet dependencies:
event-compat-sysv: Obsoletes: sysvinit (< 2.86-24)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This still happens after I installed this
[code]Updating / installing
upstart-0.3.9-17.fc9.i386 ############################## [100%]
event-compat-sysv-0.3.9-14.fc9.noarch ############################## [100%]
sysvinit-tools-2.86-24.i386 ############################## [100%]
Cleaning up / removing
sysvinit-2.86-18.i386 ############################## [100%]
Done.[/code]

I also now have a problem with gnome and cannot log in using gnome was using enlightenment had to remove networkmanager and that removed enlightenment so now i am using fluxbox, lucky me...i install several desktop managers. Gnome won't start because it cannot access /home/user/.dbus/sesson.

Fluxbox is not my favorite desktop need to have gnome or enlightenment back ASAP, i also tried the link to the new repo for enlightenment, that was a total loss i download and setup the repo only to get 404 errors when trying to use it :(

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 9:41 pm 
Offline
Site Admin

Joined: Wed Mar 17, 2004 6:17 pm
Posts: 1340
Location: London, UK
hey! What's wrong with fluxbox?

/* ducks */

_________________
BLAG 'em up!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Apr 27, 2008 11:03 pm 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 193
Hey jayeola, nothing wrong with fluxbox but it's not for me I prefer Enlightenment or gnome, at a push xfce is next best after enlightenment and gnome. Sorry but fluxbox comes way down the list of desktops that I would use.

Have you any suggestions as how to resolve my problems ?

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 28, 2008 12:52 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
To get rid of ices:

Code:
rpm -e --nopostun ices-2.0.1-4.fc7


Top
 Profile  
 
 Post subject:
PostPosted: Mon Apr 28, 2008 1:37 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
If you want enlightenment, you'll have to build the SRPMS.

ftp://ftp.blagblagblag.org/pub/mirrors/ ... a/8/SRPMS/

Code:
rpm -Uvh foo.src.rpm
vim /usr/src/[redhat|blag]/foo.spec
rpmbuild -bb foo.spec


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 30, 2008 2:43 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
Hey all...!

I tried to set up my apt's blag.list this way:
rpm http://www.blagblagblag.org/ blaghead/i386 atrpms blag dribble fedora livna
I fetched all of them, but when processing in order to install, some conflicts with packages like util-linux and the lists go on and on.. I messed up my box... :/

By the way, I disabled current apt's blag.list lines, I just let blaghead line because I was getting a MergeList error...

What is the correct way to use blaghead repos + apt?
I don't use yum, but is there a command like: apt-get dist-upgrade for it. ?

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 30, 2008 3:11 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
shawoho wrote:
I tried to set up my apt's blag.list this way:
rpm http://www.blagblagblag.org/ blaghead/i386 atrpms blag dribble fedora livna


Looks good (there's x86_64 too, by the way)
Code:
$ cat /etc/apt/sources.list.d/blaghead.list
rpm http://www.blagblagblag.org/ blaghead/i386 fedora atrpms dribble livna blag


shawoho wrote:
I fetched all of them, but when processing in order to install, some conflicts with packages like util-linux and the lists go on and on.. I messed up my box... :/


Yes, you may have to install util-linux-ng and upstart semi-manually. I kind of "gather forces" first with a `apt-get --download-only dist-upgrade` then perhaps take it to runlevel 3 or even 1 for the real upgrade. You'll have to try things like:

Code:
apt-get update
apt-get --download-only dist-upgrade
sync
init 3 (or maybe 1)
apt-get dist-upgrade
apt-get install upstart
apt-get install util-linux-ng


On reboot the old glibc wasn't completely removed so i had to:

Code:
rpm -q glibc
rpm -e glibc-2.7-2.i686


You can try `yum update` as well for this. Depends which tool you like better.

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 30, 2008 3:33 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
thanks jeff...!

Let me reinstall my whole blag system... and I'll try your blaghead wiki notes heh :)

This blaghead repo is a great news.... Now newer versions of glom will finally run on my blag box...

what is it excactly?, is it like Fedora's -devel repo...

Qué tal Buenos Aires???

saludos!!!

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 30, 2008 4:43 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
shawoho wrote:
Let me reinstall my whole blag system... and I'll try your blaghead wiki notes heh :)


Haha. You shouldn't have to reinstall anything, just keep battling with apt ;) The devel repo is a bit that way though...

shawoho wrote:
This blaghead repo is a great news.... Now newer versions of glom will finally run on my blag box...

what is it excactly?, is it like Fedora's -devel repo...


Yes, it has fedora's development repo and a few others as listed in blaghead.list

shawoho wrote:
Qué tal Buenos Aires???


Todo bien :)


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 30, 2008 11:19 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
I already installed upstart and util-linux-ng
but
what about this:

conflicts with lame-libs, limp3lame0 x264, libx264, apt, aptrpms-package-config

how do I exactly must battle with this kind of conflicts??? what is the rule??

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 01, 2008 4:48 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
Actually I couldn't deal with the "Package's Conflict" at blaghead apt repo, so turned off my laptop... when restarting, it doesn't finish the boot process...!

Do I need to re- install again to keep trying to achieve blaghead?

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 121 posts ]  Go to page 1, 2, 3, 4, 5 ... 9  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group