BLAG

BLAG Forums
It is currently Sun Dec 21, 2014 5:33 am

All times are UTC




Post new topic Reply to topic  [ 121 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Author Message
 Post subject:
PostPosted: Tue May 06, 2008 11:02 am 
Offline

Joined: Sat Jan 05, 2008 4:16 pm
Posts: 84
jebba wrote:
veganix wrote:
jebba wrote:
rsyslog replaces sysklog. You may be able to remove *most* (but not all) of `rpm -qa | grep fc7`. You could `yum install rsyslog` too.


Thanks:-) Removed some of the fc7 stuff. "Yum install rsyslog" still gives the same error, though.


I think the issue may be here that we are jumping from f7 to f9 basically, and the rsyslog/sysklog migration was handled by anaconda in f8 or somesuch. Anyway, I'm seeing it to. I'm hoping to get together a minicd to make fresh installs easier to get going


Edit: Tried to solve the sysklog-rsyslog migration by installing a rsyslog fc8.rpm, and then upgrade to fc9. It appeared to work at first, but now something is very broken...bad idea.

-robert


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 06, 2008 5:52 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
rsyslog conflict with sysklogd:

Some people have this conflict, just like me... it has been very annoying conflict... it has some important dependencies like initscripts and cronie...
trying to remove initscripts, seems to be dangerous, because its removing list has 173 packages or about...

I just deciced to 'yum remove initscripts' 173 packages removed... Well i checked the packages that were going to be removed, and most of them were gnome-*, sysklogd , a kernel- and applications like streamtuner, ....

This was a risky process, but I thougt that those packages were not so important or might be retrieved later.... so I just went for it....

surprisingly after thist:
yum remove initscripts
yum install event-compat-sysv (which i got an obsolete package, but replacing with initscripts, and installed the rsyslog)
apt-get --fix-missing install
apt-get dist-upgrade
yum update

and the lottery --> shutdown -r now

magically --> a bootable system without conflicts...

I took the risk, because since i upgraded to blaghead, never again got my X environment working, so didn't care loosing gnome-* packages...
Eventhoug I still can do startx, but get the same error i was getting before this process...
A frozen X environment.... then shutdown button to restart :(
thats why I'm booting at runlevel 3

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 06, 2008 6:17 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
By the way...

I upgraded form 70k to blaghead
jebba has post the important stetps, but he is upgradeing from 80K to blaghead

I don't know whether this is the reason of my conflicts....

but seems to be ok.... except by the X environment

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 06, 2008 8:45 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
I upgraded from 70K to BLAGHEAD as well. I decided not to worry about the rsyslog/sysklogd conflict for now, since it doesn't seem to affect the way my system is running.

I was able to get X to work after confirming that the latest gdm was installed, like so:

Code:
pablo@bocajuniors=> rpm -q gdm
gdm-2.22.0-1.fc9.i386


and then removing the /etc/X11/xorg.conf file, which is no longer used. Once I did that, "startx" worked "just like that"...


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 06, 2008 10:02 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
I like the new BLAGHEAD wallpaper! What is it?


Top
 Profile  
 
 Post subject: more Java headaches
PostPosted: Tue May 06, 2008 11:03 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
after failing to install openjdk, I thought I'd try gcj, only to run into the same dependency:

Code:
root@bocajuniors=> apt-get install java-1.5.0-gcj
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or that some of the repositories
in use are in an inconsistent state at the moment.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  java-1.5.0-gcj: Depends: jpackage-utils (>= 1.7.3) but it is not installable
E: Broken packages


jpackage, as we've learned, includes non-free bits, so it seems that java is a non-starter on BLAGHEAD at the moment. other than that, I'm enjoying it as a desktop: I've edited a few images and HTML pages using GIMP and Bluefish, respectively, and performance seems speedier than with 70K.


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 12:58 am 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
My system is working normally... at least it seems....
well, about X, nor even removing xorg.conf... I tried that too...
My problem was and still is a frozen system after starting X...
I use gnome (as before upgrading).. trying 'startfluxbox' sends me a "couldn't connect to Xserver"

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 1:13 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
extraspecialbitter wrote:
I like the new BLAGHEAD wallpaper! What is it?


It's an HDR foto of the terrace. It's fall here now. :) I used qtpfsgui

http://qtpfsgui.sourceforge.net
http://en.wikipedia.org/wiki/High_dynamic_range_imaging


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 1:15 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
shawoho wrote:
trying to remove initscripts, seems to be dangerous, because its removing list has 173 packages or about...

I just deciced to 'yum remove initscripts' 173 packages removed...


Sometimes, though i'm not supposed to, I just `rpm -e --nodeps foo` instead of killing the other zillion packages and then just install the one I want, or do `apt-get --fix-broken install`


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 1:40 am 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
after the latest update, I'm down to only 12 fc7 packages:

Code:
root@bocajuniors=> rpm -qa | grep fc7
htmlview-4.0.0-3.fc7.noarch
gnome-mime-data-2.18.0-2.fc7.noarch
libfame-0.9.1-12.fc7.i386
kpartx-0.4.7-11.fc7.i386
python-xlib-0.13-3.fc7.noarch
pidgin-encryption-3.0-1.fc7.i386
xorg-x11-fonts-truetype-7.1-3.fc7.noarch
amrnb-0.0.1-2.fc7.i386
xorg-x11-drv-nsc-2.8.1-3.fc7.i386
kernel-headers-2.6.22.9-91.fc7.i386
sysklogd-1.4.2-9.fc7.i386
ghostscript-fonts-5.50-16.fc7.noarch


with the exception of sysklogd, if they can't be upgraded, can they be deleted?


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 3:13 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
extraspecialbitter wrote:
after the latest update, I'm down to only 12 fc7 packages:

Code:
root@bocajuniors=> rpm -qa | grep fc7
htmlview-4.0.0-3.fc7.noarch
gnome-mime-data-2.18.0-2.fc7.noarch
libfame-0.9.1-12.fc7.i386
kpartx-0.4.7-11.fc7.i386
python-xlib-0.13-3.fc7.noarch
pidgin-encryption-3.0-1.fc7.i386
xorg-x11-fonts-truetype-7.1-3.fc7.noarch
amrnb-0.0.1-2.fc7.i386
xorg-x11-drv-nsc-2.8.1-3.fc7.i386
kernel-headers-2.6.22.9-91.fc7.i386
sysklogd-1.4.2-9.fc7.i386
ghostscript-fonts-5.50-16.fc7.noarch


with the exception of sysklogd, if they can't be upgraded, can they be deleted?


Some *fc7* packages (and *fc8* and maybe even *fc6*) packages are still fine as they haven't been upgraded. Fonts are a common example of this as the packages don't change frequently so they use the same one from release to release just to save the unneeded upgrade.

something like pidgin-encryption, you likely want a current one.

kernel-headers: well, there's kernel-libre-headers which installs basically the same files as kernel-headers (but deblobbed), but lxoliva's package apparently doesn't do a "Provides: kernel-headers" or somesuch, as some packages complain that there is no kernel-headers installed when only kernl-libre-headers is installed. This only affects you if you are compiling things.

not sure about the others, but they don't look to critical


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 3:15 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
I just did a 70k miniblag install and am dist-upgrading. I also added to the above: `apt-get install ncurses-libs util-linux-ng`


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 7:00 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
Well well well... I decided to reinstall everything again, from a fresh 70K install to blaghead... following the blaghead wiki notes.... due I upgraded a week ago when there was not a blaghead wiki yet....
Following those instructions.. everything gone fine... running at runlevel 5 though...

when running dist-upgrade, the tty1 hung up in 70% or about, installing xorg-x11-drv-foo...
do not remember the name now... but tried tty2 tty3 and ctrl f7 were hung.... so I rebooted...
booting... at runlevel 3 now.... No problem at all... continue with the dist-upgrade, after an apt-get --fix-broken update and an apt-get --fix-broken install
so i continued with the wiki instructions... and apt-get install kernel-libre... .. ... ....
well i finished... so rebooted.....

Perfect.... blaghead running....

BUT still X environment freezes.... even removing xorg.conf, at least this time i see the new background and the desktop... until it freezes...

cheers...

_________________
Be legal, copy GNU/Linux


Last edited by shawoho on Wed May 07, 2008 7:21 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 7:12 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
shawoho wrote:
BUT still X environment freezes.... even removing xorg.conf, at least this time i see the new background and the desktop... until it freezes...


Note your hardware and such... Check /var/log/Xorg.0.log etc...


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 07, 2008 10:44 pm 
Offline

Joined: Thu Oct 12, 2006 10:58 pm
Posts: 27
Location: Salinas - Ecuador
/var/log/Xorg.0.log :

Everything looks normal, except when looking for '(EE)' lines:


Quote:
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.4.99.901, module version = 1.3.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 2.0
(II) OPENCHROME: Driver for VIA Chrome chipsets: CLE266, KM400/KN400,
K8M800/K8N800, PM800/PM880/CN400, P4M800Pro/VN800/CN700,
K8M890/K8N890, P4M900/VN896/CN896, CX700/VX700, P4M890
(II) FBDEV: driver for framebuffer: fbdev
(II) VESA: driver for VESA chipsets: vesa
(II) Primary Device is: PCI 01@00:00:0
(!!) VIA Technologies does not support this driver in any way.
(!!) For support, please refer to http://www.openchrome.org/.
(!!) (development build, compiled on Wed Apr 16 18:16:55 2008)
(WW) Falling back to old probe method for fbdev
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"

(II) Loading /usr/lib/xorg/modules/linux//libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for 1.4.99.901, module version = 0.0.2
ABI class: X.Org Video Driver, version 4.0
(EE) open /dev/fb0: No such file or directory
(WW) Falling back to old probe method for vesa
(II) resource ranges after probing:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]


and this :

Quote:
(EE) Unable to locate/open config file


By the way, when /etc/X11/xorg.conf was set, my freezing X environment showed correct display (horiz. && vert.) parameters, after removing it --> bad horiz. && vert. mmm....

_________________
Be legal, copy GNU/Linux


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 121 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group