FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
issues with muse

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
cfar893fm
PostPosted: Wed Jul 23, 2008 8:37 pm    Post subject: issues with muse Reply with quote

when streaming to the blag icecast server using muse, the terminal frequently sends back an error message:

[w] received signal SIGPIPE (13) on process 2613
[!] shout_send: socket error
[!] broken pipe

repeated several times, then it waits 600 seconds (ten minutes!) before trying to reconnect, which it always does successfully. is there a way to reduce this delay, aside from manually restarting muse? or better yet, keep the pipe from breaking? (it seems like it might be due to our pirated internet connection...)

we're trying to separate a radio transmitter and antenna from the studio by streaming the audio on the internet, but it's critical that the connection is reliable. is there a more stable way to transmit an audio signal than muse/icecast? one person i talked to recommended "setting up a vpn tunnel", but didnt have any advice for how to go about doing that, or how the audio would be streamed through the tunnel.

it's important that we find some solution in the next week or two, so any ideas or links to tutorials, etc. would be very helpful. thanks

cfar893fm
PostPosted: Thu Jul 24, 2008 1:50 am    Post subject: Reply with quote

also, is there a way to have the terminal output include the time, in order to tell when and how often the connection cuts out?

btw, i'm starting muse with
Code:
muse -g gtk2 -i -e mp3 -q 8 -s radio.blagblagblag.org -m cfar893fm.mp3 -l ice2  -p hackme -n CFAR -d Chattanooga_First_Amendment_Radio_89.3_FM
in blag 60001
jebba
PostPosted: Thu Jul 24, 2008 6:55 am    Post subject: Reply with quote

I dont know why muse would take ten minutes to restart it, but i dont know how to change it offhand either.

I see you reporting this for the first time this week, but have been streaming quiteawhile, no? Because on last sunday I stopped/started the blag radio server a few times while working on figuring out freej stuff with jaromil. Perhaps you saw that.

jebba
PostPosted: Thu Jul 24, 2008 6:56 am    Post subject: Reply with quote

Also, there are likely more muse experts around dyne, so you could try their lists to see what scripts and stuff they have:

http://muse.dyne.org

cfar893fm
PostPosted: Fri Jul 25, 2008 2:47 am    Post subject: Reply with quote

yeah we've been streaming on and off for quiteawhile, but our operating budget has been $0 since maybe march and no one's around much these days to check up on the connection status or know what that means. i doubt anyone noticed the server cut out. its mostly a party station these days, [because] the broadcast range is awful, but if we could move the antenna/transmitter up the hill and have an audience again...
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP