FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
BLAGHEAD
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
 
Post new topic   Reply to topic    BLAG Forum Index -> development
View previous topic :: View next topic  
Author Message
brixtoncalling
PostPosted: Sun Jun 15, 2008 7:12 am    Post subject: Reply with quote

Just a quick note on missing packages:

    * libvncserver requires package lzo-minilzo (not available)
    * something else in the repo required packages libcaptury and lzo-minilzo (again, not available)


Otherwise, all is working well on BLAGHEAD.

pp
PostPosted: Fri Jun 27, 2008 3:36 pm    Post subject: Reply with quote

I’m having problems to update and install packages. Apparently, the directories in
www .blagblagblag .org/blaghead/i386 were renamed from Packages.xxx to RPMS.xxx and Yum (I don’t use Apt, coming from Fedora etc.) still looks in Packages.xxx, hence giving me a 404.
Why were the directories renamed and how come this doesn’t seem to affect other people? Above all, of course, what can I do?

jebba
PostPosted: Fri Jun 27, 2008 4:18 pm    Post subject: Reply with quote

pp wrote:
I’m having problems to update and install packages. Apparently, the directories in
www .blagblagblag .org/blaghead/i386 were renamed from Packages.xxx to RPMS.xxx and Yum (I don’t use Apt, coming from Fedora etc.) still looks in Packages.xxx, hence giving me a 404.
Why were the directories renamed and how come this doesn’t seem to affect other people? Above all, of course, what can I do?


Well, if you run apt-get update, it should sort that. I made that change like a month+ ago.


Code:
# cat /etc/yum.repos.d/blaghead.repo
[blaghead]
name=BLAGHEAD
baseurl=http://www.blagblagblag.org/blaghead/x86_64/
enabled=1
gpgcheck=0


(Use i386 instead of x86_64 if you are on 32bit).

Doing `yum update` with that should sort out and RPMS.foo versus Packages.foo differences.

-Jeff

pp
PostPosted: Fri Jun 27, 2008 4:37 pm    Post subject: Reply with quote

I had actually already tried an apt update, to no avail.
My blaghead.repo does look like yours above (with i386).
A yum update always stops with a list of missing dependencies, which I assumed is because it doesn’t find those packages where it’s looking for them (Packages.xxx):
Code:

Fehler: Fehlende Abhängigkeit: libgnutls.so.13 wird benötigt von Paket vlc-core-0.8.6f-6.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.60 wird benötigt von Paket ffmpeg-compat-0.4.9-0.47.20080113.lvn10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket avidemux-2.4.1-3.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket libquicktime-1.0.2-22.2.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket 4:mplayer-1.0-63.01_rc2.fc8_92.i386 (installed)
Fehler: Fehlende Abhängigkeit: audacious >= 1.5.0 wird benötigt von Paket audacious-plugins-jack-1.5.1-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgphoto2.so.2 wird benötigt von Paket gvfs-0.99.1-3.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: audacious >= 1.5.0 wird benötigt von Paket audacious-plugins-1.5.1-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgphoto2_port.so.0 wird benötigt von Paket wine-core-1.0-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket vlc-core-0.8.6f-6.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.60 wird benötigt von Paket ffmpeg-libs-0.4.9-0.46.20080614.lvn10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgnutls.so.13(GNUTLS_1_3) wird benötigt von Paket liferea-1.4.15-5.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libgucharmap.so.6 wird benötigt von Paket stardict-3.0.1-8.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket gstreamer-plugins-bad-0.10.7-1.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.58 wird benötigt von Paket avidemux-gtk-2.4.1-3.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libgphoto2.so.2 wird benötigt von Paket gthumb-2.10.8-3.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libetpan.so.11 wird benötigt von Paket claws-mail-plugins-pgp-3.4.0-1.fc10.i386 (installed)
Fehler: Fehlende Abhängigkeit: libx264.so.60 wird benötigt von Paket x264-0.0.0-0.14.20080613.lvn10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgphoto2_port.so.0 wird benötigt von Paket gthumb-2.10.8-3.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libgphoto2_port.so.0 wird benötigt von Paket gphoto2-2.4.1-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgphoto2_port.so.0 wird benötigt von Paket gvfs-0.99.1-3.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libetpan.so.11 wird benötigt von Paket claws-mail-3.4.0-1.fc10.i386 (installed)
Fehler: Fehlende Abhängigkeit: libgphoto2.so.2 wird benötigt von Paket wine-core-1.0-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgnutls.so.13(GNUTLS_1_3) wird benötigt von Paket vlc-core-0.8.6f-6.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libgphoto2.so.2 wird benötigt von Paket gphoto2-2.4.1-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: wine-desktop = 1.0-1.fc10 wird benötigt von Paket wine-1.0-1.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: libgnutls.so.13 wird benötigt von Paket liferea-1.4.15-5.fc9.i386 (installed)

berkbw
PostPosted: Fri Jun 27, 2008 8:29 pm    Post subject: Reply with quote

--fix-missing?
jebba
PostPosted: Fri Jun 27, 2008 9:16 pm    Post subject: Reply with quote

Ah, you may have to do a `yum clean all` to purge the old stuff.
pp
PostPosted: Sat Jun 28, 2008 9:16 am    Post subject: Reply with quote

Yes, after a yum clean all, I can yum install stuff again, thanks. The update still exits with above unresolved dependencies though. Apt-get upgrade, by the way, gives me other unresolved dependencies than Yum:
Code:

Die folgenden Pakete besitzen unerfülte Abhängigkeiten:
  control-center: Hängt ab von: libmetacity-private.so.0
  firstboot: Hängt ab von: metacity
  gtkglext-devel: Hängt ab von: libGL-devel
                  Hängt ab von: libGLU-devel
  system-config-display: Hängt ab von: metacity
  xorg-x11-proto-devel: Hängt ab von: mesa-libGL-devel
  xulrunner: Hängt ab von: libhunspell.so.1 aber es ist nicht installierbar

It doesn’t seem right to me to mix those two. I’m just going to stick with Yum for now.
So, any ideas as to the dependency problems? Is it me or is it the repo?

jebba
PostPosted: Sat Jun 28, 2008 6:55 pm    Post subject: Reply with quote

What does `yum install metacity` give you? It seems you are missing that somehow.
pp
PostPosted: Mon Jul 28, 2008 2:03 pm    Post subject: Reply with quote

jebba wrote:
What does `yum install metacity` give you? It seems you are missing that somehow.

That installed Metacity. Strange, shouldn’t I have had that already?
Anyway, I managed to do the update by manually adding some packages that were needed but not on the repo (?), excluding or uninstalling others.

Now there are 342 due to be updated and again, I have unresolved dependencies:

Quote:

Fehler: Fehlende Abhängigkeit: libetpan.so.11 wird benötigt von Paket claws-mail-plugins-pgp-3.4.0-1.fc10.i386 (installed)
Fehler: Fehlende Abhängigkeit: librpmio-4.4.so wird benötigt von Paket apt-0.5.15lorg3.94-3.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libraw1394.so.8 wird benötigt von Paket libdc1394_22-2.0.1-10.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libraw1394.so.8 wird benötigt von Paket kino-1.3.0-1.lvn9.i386 (installed)
Fehler: Fehlende Abhängigkeit: librpmdb-4.4.so wird benötigt von Paket apt-0.5.15lorg3.94-3.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: pygobject2-codegen = 2.15.1-2.fc10 wird benötigt von Paket pygobject2-devel-2.15.1-2.fc10.i386 (blaghead)
Fehler: Fehlende Abhängigkeit: librpmdb-4.4.so wird benötigt von Paket synaptic-0.57.2-16.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: librpmio-4.4.so wird benötigt von Paket synaptic-0.57.2-16.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: librpm-4.4.so wird benötigt von Paket synaptic-0.57.2-16.fc9.i386 (installed)
Fehler: Fehlende Abhängigkeit: libetpan.so.11 wird benötigt von Paket claws-mail-3.4.0-1.fc10.i386 (installed)
Fehler: Fehlende Abhängigkeit: librpm-4.4.so wird benötigt von Paket apt-0.5.15lorg3.94-3.fc9.i386 (installed)


How can it be that this doesn’t seem to affect other people? Because, let’s take as an example the package pygobject2-devel: it requires pygobject2-codegen of the same version but that one doesn’t seem to be on the repository/server (here: http://www.blagblagblag.org/blaghead/i386/RPMS.fedora/). So how is this supposed to work then?
I already got the libetpan error for my last update, by the way, so I just excluded it temporarily (now unexcluded).
I just can’t see what it is that keeps me from updating, as others don’t seem to have problems with unresolved dependencies, at least not to such an extent.
Thanks for your help!

jebba
PostPosted: Mon Jul 28, 2008 4:10 pm    Post subject: Reply with quote

It *does* affect other people, but differently, depending upon what they've installed. The BLAGHEAD repo is always in flux.

One category of problems you are seeing is because you have some packages from atrpms. That repo has been removed from BLAGHEAD because of the chaos it caused (e.g. see libraw, lib1394, etc) as it doesnt really mix with the other repos at all. So if you see a package from atrpms, remove it.

Another issue can come up if packages get added upstream, but don't hit blaghead. If you see instances of this, just send me the package names and I'll add them (assuming they are free licenses).

pp
PostPosted: Sat Aug 16, 2008 10:12 am    Post subject: Reply with quote

Thanks for the tip about Atrpms Jebba, removing those packages did solve some of the dependency problems.
One package that is obviously missing on the blaghead repo is pygobject2-codegen. It’s there on the Fedora development repo.

By the way, I see there is a Blaghead mirror at colostore.blagblagblag.org, but it’s not being synched anymore. That’s a pity because it’s twenty times faster for me than www. What is gonna happen to it?

jebba
PostPosted: Sat Aug 16, 2008 4:35 pm    Post subject: Reply with quote

pp wrote:
Thanks for the tip about Atrpms Jebba, removing those packages did solve some of the dependency problems.
One package that is obviously missing on the blaghead repo is pygobject2-codegen. It’s there on the Fedora development repo.

By the way, I see there is a Blaghead mirror at colostore.blagblagblag.org, but it’s not being synched anymore. That’s a pity because it’s twenty times faster for me than www. What is gonna happen to it?


Ok, i added pygobject2-codegen, so that should make an appearance today.

I cronned up the rsync on colostore for you so it should stay fresh.

-Jeff

pp
PostPosted: Sun Aug 17, 2008 9:49 am    Post subject: Reply with quote

This is great. Thanks so much.
Ark74
PostPosted: Sun Aug 17, 2008 10:38 am    Post subject: Reply with quote

Hi!
I added the blaghead repository on my freeeee.

First i ran yum update only with FREEEEE

and then with the blaghead added

but i got this message

Code:

....
---> Package python-pyblock.i386 0:0.31-4 set to be updated
--> Processing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 for package: python-pyblock
--> Finished Dependency Resolution
xorg-x11-drivers-7.3-9.fc10.i386 from blaghead has depsolving problems
  --> Missing Dependency: xorg-x11-drv-r128 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: libdmraid.so.1.0.0.rc14 is needed by package python-pyblock-0.31-4.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 is needed by package python-pyblock-0.31-4.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: libdmraid.so.1.0.0.rc14(Base) is needed by package python-pyblock-0.31-4.i386 (blaghead)
xorg-x11-drivers-7.3-9.fc10.i386 from blaghead has depsolving problems
  --> Missing Dependency: xorg-x11-drv-mach64 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: libdmraid.so.1.0.0.rc14 is needed by package python-pyblock-0.31-4.i386 (blaghead)
Error: Missing Dependency: xorg-x11-drv-mach64 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: xorg-x11-drv-r128 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: libdmraid.so.1.0.0.rc14(Base) is needed by package python-pyblock-0.31-4.i386 (blaghead)
Error: Missing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 is needed by package python-pyblock-0.31-4.i386 (blaghead)


it seems that blaghead is missing the dmraid-libs package, or is it part of the dmraid package?
About the xorg files i think is not necessary to update them, can i ignore them?

Sorry if i'm wrong, i'm kind of new to the yum/rpm manager/package system. :)
Cheers!

jebba
PostPosted: Sun Aug 17, 2008 2:25 pm    Post subject: Reply with quote

Ark74 wrote:
Hi!
I added the blaghead repository on my freeeee.

First i ran yum update only with FREEEEE

and then with the blaghead added

but i got this message

Code:

....
---> Package python-pyblock.i386 0:0.31-4 set to be updated
--> Processing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 for package: python-pyblock
--> Finished Dependency Resolution
xorg-x11-drivers-7.3-9.fc10.i386 from blaghead has depsolving problems
  --> Missing Dependency: xorg-x11-drv-r128 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: libdmraid.so.1.0.0.rc14 is needed by package python-pyblock-0.31-4.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 is needed by package python-pyblock-0.31-4.i386 (blaghead)
python-pyblock-0.31-4.i386 from blaghead has depsolving problems
  --> Missing Dependency: libdmraid.so.1.0.0.rc14(Base) is needed by package python-pyblock-0.31-4.i386 (blaghead)
xorg-x11-drivers-7.3-9.fc10.i386 from blaghead has depsolving problems
  --> Missing Dependency: xorg-x11-drv-mach64 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: libdmraid.so.1.0.0.rc14 is needed by package python-pyblock-0.31-4.i386 (blaghead)
Error: Missing Dependency: xorg-x11-drv-mach64 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: xorg-x11-drv-r128 is needed by package xorg-x11-drivers-7.3-9.fc10.i386 (blaghead)
Error: Missing Dependency: libdmraid.so.1.0.0.rc14(Base) is needed by package python-pyblock-0.31-4.i386 (blaghead)
Error: Missing Dependency: dmraid-libs >= 1.0.0.rc11-FC6.3 is needed by package python-pyblock-0.31-4.i386 (blaghead)


it seems that blaghead is missing the dmraid-libs package, or is it part of the dmraid package?
About the xorg files i think is not necessary to update them, can i ignore them?

Sorry if i'm wrong, i'm kind of new to the yum/rpm manager/package system. :)
Cheers!


I added dmraid-libs. Looks like a new one they just split out.

Note I'm not doing any updates against fedora repos right now so new stuff isn't coming in. Fedora has currently undisclosed "issues" they are dealing with:
http://www.redhat.com/archives/fedora-announce-list/2008-August/msg00009.html

-Jeff

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> development Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 8 of 9

Protected by Anti-Spam ACP