FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Missing Sound

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
pianoplayer
PostPosted: Mon Aug 04, 2008 1:42 am    Post subject: Missing Sound Reply with quote

I installed BLAG 90001 a few days ago and today attempted to play some
audio files from various sources. Of the applications I have tried so
far, xmms went through the motions of playing certain files, but with
complete silence. The same thing happened with both xine and
mplayer. (The volume control is set well above zero.)

Furthermore, when I insert an audio CD under Gnome, I get the
following message:

Select How to open "Audio Disc" and whether to perform this action for
other media of the type "Compact Disc Audio".

This is followed by a menu that begins "No applications found."

I have, xmms, mplayer, grip and xine, but Gnome's menu can't find any
of. (I have not added or removed any multimedia applications since
the install.)

What am I missing, and how can I fix it?

jebba
PostPosted: Mon Aug 04, 2008 2:07 pm    Post subject: Re: Missing Sound Reply with quote

pianoplayer wrote:
I installed BLAG 90001 a few days ago and today attempted to play some
audio files from various sources. Of the applications I have tried so
far, xmms went through the motions of playing certain files, but with
complete silence. The same thing happened with both xine and
mplayer. (The volume control is set well above zero.)

Furthermore, when I insert an audio CD under Gnome, I get the
following message:

Select How to open "Audio Disc" and whether to perform this action for
other media of the type "Compact Disc Audio".

This is followed by a menu that begins "No applications found."

I have, xmms, mplayer, grip and xine, but Gnome's menu can't find any
of. (I have not added or removed any multimedia applications since
the install.)

What am I missing, and how can I fix it?


Double click on the speaker icon up in the corner. If it doesn't give an error, but you don't hear sound it means something is just muted in the mixer. Sometimes you have to enable/disable things in the mixer to get sound out of it.

But to repeat, if you're not getting *errors* than it means the driver is ok, so don't let someone talk you into recompiling alsa and stuff like that...

From the top of my head:
Code:
yum install xmms-cdread

pianoplayer
PostPosted: Mon Aug 04, 2008 4:15 pm    Post subject: More Diagnostics Reply with quote

Here is what I am finding, so far.

The speakers are on and operational. When I run from a live CD distribution, sound apps play normally.

In BLAG (Gnome environment), I can click on the speaker icon. On the first click, it was down to minimum volume, but I can raise and lower the level. There are no error messages

If I start xmms and point it to a shoutcast stream, I get an initial popping sound or two in my speakers, but no other sound. The moving graphics in the xmms window act as if normal play is in progress. I have verified that the following packages are installed:

Code:

xmms-mp3
xmms-cdread


If I open certain menus in xmms, the menus appear to be in unreadable character sets. For example, if open the "Play file" menu, (keystroke l, per the xmms manpage) I get a window titled "Play files". Every other button and list in that window is labelled with rows of squares, of the sort that appear when one is trying to read characters in a language for which fonts are not installed.

Checking through options in the Gnome menus, there is a menu called "Sound Preferences". There are a number of testing options, but every "Test" button results in the following message:

Code:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample !
gconfaudiosink profile=chat: Could not open audio device for
playback. Device is being used by another application.


These tests were all performed when no sound application that I knew of was running.

Any further suggestions?

jebba
PostPosted: Mon Aug 04, 2008 6:00 pm    Post subject: Re: More Diagnostics Reply with quote

pianoplayer wrote:
Here is what I am finding, so far.

The speakers are on and operational. When I run from a live CD distribution, sound apps play normally.

In BLAG (Gnome environment), I can click on the speaker icon. On the first click, it was down to minimum volume, but I can raise and lower the level. There are no error messages

If I start xmms and point it to a shoutcast stream, I get an initial popping sound or two in my speakers, but no other sound. The moving graphics in the xmms window act as if normal play is in progress. I have verified that the following packages are installed:

Code:

xmms-mp3
xmms-cdread


If I open certain menus in xmms, the menus appear to be in unreadable character sets. For example, if open the "Play file" menu, (keystroke l, per the xmms manpage) I get a window titled "Play files". Every other button and list in that window is labelled with rows of squares, of the sort that appear when one is trying to read characters in a language for which fonts are not installed.

Checking through options in the Gnome menus, there is a menu called "Sound Preferences". There are a number of testing options, but every "Test" button results in the following message:

Code:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample !
gconfaudiosink profile=chat: Could not open audio device for
playback. Device is being used by another application.


These tests were all performed when no sound application that I knew of was running.

Any further suggestions?




Try these commands:

Code:
mplayer -ao pulse /usr/share/sounds/phone.wav
mplayer -ao alsa /usr/share/sounds/phone.wav


That will have mplayer play a simple sound via pulseaudo and another directly to alsa (which would likely fail).

Also, double click on that volume icon again, and under Edit->Preferences add some more tracks to be visible. Sometimes things like "headphone jack sense" and such need to be toggled correctly to work.

Currently when i boot up my eees, "Front" gets set all the way down, for example.

-Jeff

pianoplayer
PostPosted: Tue Aug 05, 2008 1:16 am    Post subject: Progress Reply with quote

Now we have progress. At the first try, neither of your two suggested commands was successful. I had not realized that double-clicking on Gnome's speaker icon would produce a panel of sliders. Underneath each slider was an icon that could be clicked to mute or unmute that particular sound source. Most of them were muted (a strange default?). When I unmuted the PC speaker and retried your suggested commands, the following was successful:

Code:
mplayer -ao pulse /usr/share/sounds/phone.wav


After that I was able to substitute some sound files on my HD, and also to start xmms from the command line and play sound files.

As for the weird, unreadable menus in xmms, I was able to find some information through Google. xmms appears to be configured to default to some language with a non-Roman alphabet. The following command line made xmms menus readable to me:

Code:
env LC_ALL=en_US xmms [your options]


(For those of you not in the US, and/or non-English speakers, the value of LC_ALL will be different.)

Now that I can read xmms menus, I can play audio CDs, but not conveniently. On insertion of a CD, a window appears that offers to play the CD but claims that no applications exist. But if I tell xmms to open the location /dev/sr0, it plays the CD without complaint. I don't remember needing to do this when I have used Gnome in the past.

gr00ve
PostPosted: Tue Aug 05, 2008 10:52 am    Post subject: Reply with quote

try this

system > preferences > hardware > sound

set all options to ALSA, then logout and login back to your gnome session.

Crwyddwr
PostPosted: Tue Aug 05, 2008 12:04 pm    Post subject: Re: Progress Reply with quote

pianoplayer wrote:

Now that I can read xmms menus, I can play audio CDs, but not conveniently. On insertion of a CD, a window appears that offers to play the CD but claims that no applications exist. But if I tell xmms to open the location /dev/sr0, it plays the CD without complaint.


That sounds as if Gnome's default cd-player isn't installed. Go to : System > Preferences > Removable Drives and Media and look for the option to set the default application when an audio CD is inserted. If you want to use xmms the command line should read
Code:
xmms -p %d

pianoplayer
PostPosted: Thu Aug 07, 2008 12:56 am    Post subject: Re: Progress Reply with quote

Crwyddwr wrote:

That sounds as if Gnome's default cd-player isn't installed. Go to : System > Preferences > Removable Drives and Media and look for the option to set the default application when an audio CD is inserted. If you want to use xmms the command line should read
Code:
xmms -p %d


I cannot find "Removable Drives and Media" anywhere in my System > Preferences menu.

gr00ve
PostPosted: Thu Aug 07, 2008 11:57 am    Post subject: Reply with quote

i think he meant system > preferences > personal > preferred applications ?
Crwyddwr
PostPosted: Thu Aug 07, 2008 1:58 pm    Post subject: Reply with quote

I actually meant System > Preferences > Hardware > Removable Drives and Media
This should bring up a gui, which has a multimedia tab. However, you need gnome-volume-manager installed for this to work.

At this point I should confess that I don't use Gnome any more and I was trying to answer your question from memory of 2.18. If the menu layout has changed in later versions and I'm causing confusion, then I can only apologise.

gr00ve
PostPosted: Thu Aug 07, 2008 4:40 pm    Post subject: Reply with quote

Removable Drives and Media does not have multimedia tab, Preferred Applications does.

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP