BLAG

BLAG Forums
It is currently Thu Dec 18, 2014 6:22 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Bugs in BLAG 10K -> 30K
PostPosted: Thu Jan 27, 2005 6:47 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 6:08 pm
Posts: 973
Location: Canada
Ok, here is my list of bugs that is also going into bugzilla:

Media Check says it is checking a DVD instead of a CD
Guessed my video card incorrectly, used VESA driver instead (for those of you who don't know what VESA is, it is a video standard that all video cards since about 1995 understand, and allowed the graphical installer to work for me)

Detected BLAG 10K as FC1 (is there anything that can be done about this?)

Configure lynx, it still has all the Fedora defaults

The menus (especially the borders on them) look horribly Bluecurvish.

I believe there was a way to make nautilus non-spatial, maybe this could be the default if I could figure out how it get it non-spatial.

Note: i found it
http://www.fedorafaq.org/#nautilus-spatial

Also found during my search, a way to boot from floppy:
http://sourceforge.net/projects/btmgr/
Note, I haven't tested this.

Also, congrats, gdm doesn't have such an ugly default theme now!

More than 100 packages were broken for me (related to GCC, most likely very few would be broken in an average user's install).

I'll genereally add to this as we go along...

Thanks,

Stephen Clement (stevo32)

_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).


Top
 Profile  
 
PostPosted: Thu Jan 27, 2005 8:16 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Note to folks googling this in the future: he's talking about an early alpha of 30k, not the final release. Perhaps we should be referring to 29k instead of 30k since this is clearer. (I changed Subject to reflect this).

stevo32 wrote:
Media Check says it is checking a DVD instead of a CD


Yep. Not sure where that is buried ;)

stevo32 wrote:
Guessed my video card incorrectly, used VESA driver instead (for those of you who don't know what VESA is, it is a video standard that all video cards since about 1995 understand, and allowed the graphical installer to work for me)


What kind of video card do you have? In general 30k has been picking up devices quite well. FWIW, at least it is defaulting to VESA when it can't find things. Lots of times in the past it would just bork.

stevo32 wrote:
Detected BLAG 10K as FC1 (is there anything that can be done about this?)


Hmm. I'm not certain that's a bad thing. At least it detected it. ;)

stevo32 wrote:
Configure lynx, it still has all the Fedora defaults


Such as? If you have a nice defaults file, i may be able to work it in.

stevo32 wrote:
The menus (especially the borders on them) look horribly Bluecurvish.


Look for lots of changes to blagCanyon in the coming week or so. Hyland has been working on this.

stevo32 wrote:
I believe there was a way to make nautilus non-spatial, maybe this could be the default if I could figure out how it get it non-spatial.


Yes, I will set default to non-spatial--I know where it is set. gconftool-2 sets system defaults, by the way. Interesting tool. Suggested command for you to explore:

Code:
gconftool-2 -R / | less


See also: blag-firstboot RPM and /usr/sbin/blag-firstboot. Note: it hasn't been touched for fc3 yet. Also, add a new user and see what its defaults are, as in an upgrade your own defaults aren't necessarily the same as a new user. This will get a major tweak. When you find tasty morsels in gconftool-2, lemme know. :)

stevo32 wrote:
Also, congrats, gdm doesn't have such an ugly default theme now!


And a new gdm theme in the works. Looks vnice.

stevo32 wrote:
More than 100 packages were broken for me (related to GCC, most likely very few would be broken in an average user's install).


Yep. I haven't done /anything/ to Obsolete: old stuff yet (e.g. tdbfsb or was it tbd...). You're getting much earlier alphas than I posted in the past.

I really don't know what do to for upgrade for folks that have grabbed tons of things from the repos that's not on the CD. If you /have/ grabbed lots of repo packages and are capable of installing from DVD, I recommend DVD upgrades. If you can't, after a CD upgrade, run something like:

Code:
apt-get update
apt-get dist-upgrade  [and when this barfs]
rpm -e [packages you know you can whack]
apt-get -f install
apt-get dist-upgrade


r7 was the first brave one to try an `apt-get dist-upgrade` from 19k->29k. It was very messy, but we got it sorted. It may be due to /dev now using udev. I haven't tested it meself yet. I do /not/ recommend doing a dist-upgrade at this point unless you have `man rpm`d 50+ times in your life and know "boot: linux rescue" & chroot. ;)

========================
Note, I plan to make it PERFECTLY CLEAN to upgrade from a stock 9k or 10k release (but no promises on 19k--it was alpha...).
========================

stevo32 wrote:
I'll genereally add to this as we go along...


Thanks. This is very very helpful, btw. Bugzilling will make sure it doesn't get lost. http://bugzilla.blagblagblag.org/ Don't worry about making everything perfect in the bug report (e.g components, owner, etc.). If it just gets in there, that's enough. :)

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2005 5:10 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 6:08 pm
Posts: 973
Location: Canada
Ok, just for some clarification here:

Quote:

What kind of video card do you have? In general 30k has been picking up devices quite well. FWIW, at least it is defaulting to VESA when it can't find things. Lots of times in the past it would just bork.


NVidia GeForce 4 MX. First it detected it as a Matrox G200 Millenium, my other graphics card, and then it recognized it as a GeForce 4 MX, but X refused to start when it was set in anything but VESA mode on the installer.

Quote:
Such as? If you have a nice defaults file, i may be able to work it in.

How about use the one that was used for 10K in mozilla? I liked that one and it works pretty damn well with Lynx, minus the cool javascript presentation.

Quote:
Look for lots of changes to blagCanyon in the coming week or so. Hyland has been working on this.


Sounds good :) I love the blag default theme.

As soon as 30K goes stable, I'll be making the upgrade on my main box (hopefully). Currently, WordPerfect for Linux which is binary only (and uses the libc5 I've installed, and is also quite ancient) does not cooperate very well with BLAG 30K.

_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2005 6:46 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
stevo32 wrote:
Quote:
What kind of video card do you have? In general 30k has been picking up devices quite well. FWIW, at least it is defaulting to VESA when it can't find things. Lots of times in the past it would just bork.


NVidia GeForce 4 MX. First it detected it as a Matrox G200 Millenium, my other graphics card, and then it recognized it as a GeForce 4 MX, but X refused to start when it was set in anything but VESA mode on the installer.


nvidia does not provide info to developers so they can make Free drivers. Nvidia makes proprietary binary-only drivers available on their site (an also @ atrpms, iirc).

stevo32 wrote:
Currently, WordPerfect for Linux which is binary only (and uses the libc5 I've installed, and is also quite ancient) does not cooperate very well with BLAG 30K.


WTF do you need wordperfect for? OOo?

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2005 1:23 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 6:08 pm
Posts: 973
Location: Canada
Quote:
WTF do you need wordperfect for? OOo?

I've got a few hundred files in WordPerfect format that I've saved over the past few years. I'm now saving all my files in the OOo format.

_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group