FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
CVS lib problem

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
stuffit
PostPosted: Thu Jan 27, 2005 11:14 am    Post subject: CVS lib problem Reply with quote

hi there

i installed cvs using apt-get and when i try and use it i get the following:
[root@localhost etc]# cvs
cvs: relocation error: cvs: undefined symbol: GSS_C_NT_HOSTBASED_SERVICE
i read it might be a problem with kerberos lib so i removed that from /etc/ld.so.conf and updated lib then got the following:

[root@localhost etc]# cvs
cvs: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object file: No such file or directory

so i'm a bit stuck! any ideas?

thanks
ste

jebba
PostPosted: Thu Jan 27, 2005 4:35 pm    Post subject: Reply with quote

Ok. This just means that whoever packaged the CVS RPM didn't include a dependency to krb5-libs or...dunno. I thought you pretty much needed kr5b-libs for pam & stuff.

Anyway, apt-get install kr5b-libs. If it is there, do an `rpm -q krb5-libs` and let me know what release you are running.

FYI: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=100924

-Jeff

stuffit
PostPosted: Thu Jan 27, 2005 8:09 pm    Post subject: Reply with quote

tried to install but got the following:

The following packages have unmet dependencies:
perl: Obsoletes: perl-CGI but 2:3.05-0_5.rh9at is to be installed
E: Broken packages

if i rpm -q i get:

krb5-libs-1.2.7-14

version of blag is 9000

i noticed that i have enabled apt sources for both 9000 and 10000 so i'm wondering if this is causing a problem.

anyway i've apt-get removed perl-CGI, and then tried to install krb5-libs

It threw up a whole list of upgrade packages and 1new one, compat-db.

after that it now works!

jebba
PostPosted: Thu Jan 27, 2005 8:25 pm    Post subject: Reply with quote

Ok. It looks like you at ATRPMs repository enabled and that was causing some sort of conflict.

-Jeff

stuffit
PostPosted: Fri Jan 28, 2005 7:40 pm    Post subject: Reply with quote

cvs works fine now. my redhat confi stuff is fcked tho - tried redhat-config-network and got:

Code:

rror in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 68, in <lambda>
    PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 291, in handleException
    fs = FileSelection(_("Please specify a file to save the dump"))
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 209, in __init__
    import gnome.ui
ImportError: /usr/lib/libkrb5.so.3: undefined symbol: add_error_table

Original exception was:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 186, in ?
    from netconfpkg import NC_functions
  File "/usr/lib/python2.2/site-packages/PIL/__init__.py", line 41, in ?
    # ;-)
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 994, in GenClass_read_classfile
    __GenClass_read_classfile(boxpath, mod, OptLower)
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 947, in __GenClass_read_classfile
    doc = xml.dom.minidom.parse(boxpath)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 962, in parse
    return _doparse(pulldom.parse, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 953, in _doparse
    events = apply(func, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/pulldom.py", line 338, in parse
    parser = xml.sax.make_parser()
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/sax2exts.py", line 37, in make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 64, in make_parser
    return self._create_parser(parser_name)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 42, in _create_parser
    drv_module = __import__(parser_name,{},{},['create_parser'])
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/drivers2/drv_pyexpat.py", line 20, in ?
    from xml.sax.expatreader import create_parser
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/expatreader.py", line 28, in ?
    from xml.sax import xmlreader, saxutils, handler
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxutils.py", line 8, in ?
    import types, sys, urllib, urlparse, os, string
  File "/usr/lib/python2.2/urllib.py", line 26, in ?
    import socket
  File "/usr/lib/python2.2/socket.py", line 41, in ?
    from _socket import *
ImportError: /usr/lib/libkrb5.so.3: undefined symbol: add_error_table




hmm. doesn't nother me at the moment cos it means i have to go and figure out what txt files to change :-)

jebba
PostPosted: Fri Jan 28, 2005 7:46 pm    Post subject: Reply with quote

Hmm, try `netconfig`

You may have gotten someone else's python (e.g. ATRPMs) or something which is foo...

-Jeff

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP