BLAG

BLAG Forums
It is currently Mon Dec 22, 2014 11:32 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: RPM Build error
PostPosted: Sun Jun 21, 2009 10:47 am 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 194
I've been trying to build the latest versions of stfl and newsbeuter rpm packages b ut have been failing at the first hurdle which is building the stfl rpm.

I am looking for any help that I can get so have posted the rpmbuild output on pastbin,
http://pastebin.ca/1468604
please have a look maybe someone can see where I've been going wrong. Also take into account that I am a novice at building RPMs so make your replies simply/easy for all of us to learn.

Thanks in advance for any help.

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 21, 2009 4:06 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
a quick look at the output suggests that DESTDIR is prepending "/var/tmp/stfl-0.20-3-root-%" incorrectly - i.e. output should be going to /usr/share/xsessions instead of /var/tmp/stfl-0.20-3-root-%/usr/share/xsessions, etc. Not having the build script in front of me I'm wondering if DESTDIR can be configured, or if another variable is responsible for the bogus prefix.

BTW - looking through some Fedora-related forums it looks like you're not the only one who's encountered issues building this library. Here is a posting from the linuxquestions.org forum that might be insightful.

Just my two cents.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 21, 2009 8:37 pm 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 194
extraspecialbitter wrote
Quote:
a quick look at the output suggests that DESTDIR is prepending "/var/tmp/stfl-0.20-3-root-%" incorrectly - i.e. output should be going to /usr/share/xsessions instead of /var/tmp/stfl-0.20-3-root-%/usr/share/xsessions, etc. Not having the build script in front of me I'm wondering if DESTDIR can be configured, or if another variable is responsible for the bogus prefix.


Thanks for the suggestion but I think the DESTDIR is as you suggest but please have a look at it, I made the RPM for the first version which is on Trac and that built ok, however the spec file is here> http://pastebin.ca/1469147 for the lastest version.

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Jun 21, 2009 10:07 pm 
Offline

Joined: Thu Jul 13, 2006 5:01 pm
Posts: 509
Location: Boston, MA, USA
Here's my suggestion - although I don't know if it will make any difference - change line #78 from:

Code:
install -d $RPM_BUILD_ROOT%{_datadir}/xsessions


to

Code:
install -d ${RPM_BUILD_ROOT}%{_datadir}/xsessions


I'll keep looking and might even try a spin for good measure...


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jun 22, 2009 1:54 am 
Offline

Joined: Wed Jun 16, 2004 9:54 pm
Posts: 194
sorry that did not work...same error message

Thanks for all the help...see if you can do a spin, newsbeuter is a great application would be cool to do the new version for the next blag.

_________________
If it hurts it's because you're alive.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group