FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Network pxe boot BLAG

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
frankmill12
PostPosted: Mon May 02, 2011 7:21 am    Post subject: Network pxe boot BLAG Reply with quote

Has anybody successfully implemented a network boot solution for BLAG? I am trying to add BLAG into my PXE and tftp server for booting off the network. However, it keeps showing error 'invalid kernel' for me.

Is there any specific steps that I should follow to get this working?

Thanks!

bonniechaney
PostPosted: Wed May 11, 2011 1:36 pm    Post subject: Reply with quote

that's also my problem, help, anyone?
robertmoore
PostPosted: Fri May 13, 2011 12:45 am    Post subject: Reply with quote

please make a reply. we badly need your help.
helgman
PostPosted: Sun Oct 16, 2011 12:47 pm    Post subject: Reply with quote

I've been wrestling this same problem for the last ... too many hours.

I'm going for a TFTP/HTTP set up but I guess I need some help ... Maybe some other form of intrid.img might make it work? I can make the system boot from the TFTP and it loads the vmlinuz and intrid.img just fine from the TFTP but it dies at the next step - unable to mount root system (don't really know what to put in the pxelinux.cfg/default files root=). I've made the setup before (with Ubuntu) and I've managed to network-boot a live CD but this time (with Blag) I'm stuck ... and the search-engines gives me nothing useful.

Any pointers or tips are most welcome as I have a computer with a broken system (non-Blag) that I have no wish to fix (it breaks on every other update) with no CD/DVD-drive to install Blag from.

If I get it up and running I'm more than willing to try and retrace my steps to make a (hopefully) useful guide for other users ...

extraspecialbitter
PostPosted: Sun Oct 16, 2011 10:22 pm    Post subject: Reply with quote

Here's a thread from 2008 that might help. I was using BLAG 70000 at the time, and there are a few other considerations, but perhaps it will be of use.
helgman
PostPosted: Mon Oct 17, 2011 5:39 am    Post subject: Reply with quote

extraspecialbitter wrote:
Here's [link remove] a thread from 2008 that might help.


I appreciate the link.

I used it yesterday with no luck. I seems i might be able to do it with NFS but not with HTTP (and I really don't want to go the NFS-way ... to many bad memories - on the other hand, I'm creating new ones here so). Is it dracut that is the problem? Does it even support HTTP?

I've got VMware set up at the office but I've had no luck installing Blag 64 ... hangs when doing the clean up (post-install) and it won't boot - but I'm gonna give it try this afternoon if I find the time.

helgman
PostPosted: Tue Oct 18, 2011 2:55 pm    Post subject: Reply with quote

Might be the machine I'm installing on that's old and rusty. Tried my setup on a laptop and it seems to work (didn't want to go any further than seeing the installer pop up since it's my wife's primary workstation).

Trying it on the old machine an it "hangs" on "Trying to unpack rootfs image as initramfs ...". This seems to happen to some Fedora user when there's not enough RAM (in this case I have 512MB).

I'll see what I can do about this tomorrow. When I get it working I'll post some of my setup if someone else stumbles upon this thread.

extraspecialbitter
PostPosted: Wed Oct 19, 2011 12:16 pm    Post subject: Reply with quote

Does your old machine offer "network boot" as one of the boot options? I know that some late-model desktops didn't back in the day. Sometimes a BIOS update can help - if available for your hardware.
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP