FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
SAMBA home fileserver

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
gorans
PostPosted: Sun Jun 13, 2004 4:10 pm    Post subject: SAMBA home fileserver Reply with quote

Hi

Im trying to install samba and make my computer a fileserver, but ive got problems.
Samba is up and running. I have made the shares available to all.
Now I go to the Windz machine and ask for computers in my workgroup. The BLAG computer shows up and as I have put %h and %v in the server string I know that its been recognized as computer samba and that the macine use correct version.
When i click the samba server, windz says that it has no path. I search the machine from Windz and Windz can find it, but when i try to connect it has no path.
What have I missed?
Thanks for your exellent dist, its a pleasure to use it. I have tried the 9002 and now im on 10000.

Regards
Goran

PS the previous screen for logging in was nicer for me. I use swedish language and some of the characters in användarnamn (user nme) are outside the screen. can i change that? DS


_________________
Cars and Computers are equal. There is no patent on steering wheel or breaks as drivers tools.
No Software patents!!
jebba
PostPosted: Sun Jun 13, 2004 9:21 pm    Post subject: Reply with quote

I don't really do samba so I'll let that part be answered by someone around here who works on it more.

WRT login screen, ya, at some screen resolutions it appears that the fonts grow even bigger... The file that sets this is here:
/usr/share/gdm/themes/blagCanyon/blagCanyon.xml

-Jeff

gorans
PostPosted: Mon Jun 14, 2004 8:24 am    Post subject: Reply with quote

Hi
More information. I have used the terminal to start and stop the deamon and MC to edit the smb.conf in /etc/samba. Now I tried SWAT. Here I can see that smbd is not running but nmbd is running - both started with -./smb start-.
I tried to start smbd from within SWAT but it did not start.
I have checked the smb.conf file with -testparm smb.conf- and it says its OK.
Next I asked in the terminal windoiw -./smb status- and both deamons are reported running.When I go back to SWAT report, it insists that smbd is NOT running after trying to restart smbd it still says its NOT running. In the terminal it says that snbd is running.
There is a discrespancy one report that smbd is running the other that it is not running.
Can anyone explain this.
- Goran

PS I like BLAG, nice dist - nice people DS


_________________
Cars and Computers are equal. There is no patent on steering wheel or breaks as drivers tools.
No Software patents!!
jebba
PostPosted: Mon Jun 14, 2004 8:49 am    Post subject: Reply with quote

You can start stop smb thusly:
Code:
/sbin/service smb stop
/sbin/service smb start
/sbin/service smb restart


If you see smb (and it's subprocesses running) in `ps ax` then its running--this is more accurate than swat.

As for configuring samba, I, well, forget.... Can someone post a "typical" smb.conf to here or the wiki please?

-Jeff

gorans
PostPosted: Tue Jun 15, 2004 8:18 am    Post subject: Reply with quote

Hi Jebba
Tried to use your suggestiions, but the problem remains.
nmbd seems to give the right name to the network but when I try to go back to the samba machine from the Windz XP machine -the network path was not found-. Same answers from the code you showed , Both smbd and nmbd are running, but SWAT shows that smbd is not running and cannot be started.
I have tried to find Linneighborhood or jagd to see the networh from whithin BLAG10000 but they seems to be missing. Can I use apt-get to install them?
I have tested the smb.conf file with testparm and its OK.
- Goran

crush157
PostPosted: Wed Jun 16, 2004 3:04 pm    Post subject: Reply with quote

To see the samba network from within your server, you can run:

smbclient -L <host name or IP>

It will ask for a password which is not required to list the services, so just hit enter.


If this command is not available, install the package samba-client-3.0.2-7.FC1 from the blag10000 repository.

This will display the SMB services that the smbd server is offering up from your config file in /etc/smb/smb.conf.

P.S. I have not had luck with SWAT since redhat 6 and just used the smb.conf file directly as it is pretty well commented.

kazim
PostPosted: Wed Jun 16, 2004 6:17 pm    Post subject: smb not showing up Reply with quote

remember to use
Code:

iptables --flush

before you try to test samba stuff.
I also use
Code:

lsof -i:139

to show which apps are using the smb 139 port.

If remember correctly thing like SWAT also want other ports opened in iptables...

There was another thread about samba on this forum some time ago..
http://forums.blagblagblag.org/viewtopic.php?t=33&highlight=samba

Ronald_from_Holland
PostPosted: Thu Jun 17, 2004 5:03 pm    Post subject: Setting up Samba Reply with quote

Hi,

I got pretty far following this link:

http://fedora.redhat.com/projects/config-tools/redhat-config-samba.html

to this treasure room:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

Click this file:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/system-config-samba-1.2.9-2.noarch.rpm

And choose open with default app (install apps)

A Samba util appears under your System settings | Server Settings


:mrgreen:

jebba
PostPosted: Thu Jun 17, 2004 6:28 pm    Post subject: Reply with quote

There is a `redhat-config-samba` in 10000.

By the way, in 20000 (fedora core 2), all the redhat-config-* have been renamed to system-config-*

-Jeff

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP