FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
inkscape added to repository

 
Post new topic   Reply to topic    BLAG Forum Index -> open discussion
View previous topic :: View next topic  
Author Message
jebba
PostPosted: Tue Jun 15, 2004 9:28 pm    Post subject: inkscape added to repository Reply with quote

If you use sodipodi or any vector graphics programs, check out inkscape. It's really nice. To add it to BLAG10000:

Code:
apt-get update
apt-get install inkscape


More info @ http://www.inkscape.org/

-Jeff

stuffit
PostPosted: Wed Jun 16, 2004 2:53 pm    Post subject: Reply with quote

is there a lib resource for helping earlier blag users keep up to date with software? i need libsigc to install inkscape

ta

jebba
PostPosted: Thu Jun 17, 2004 6:22 pm    Post subject: Reply with quote

You can get the libs you need for inkscape from Dag. It also needs perl-GD, perl-GD-SVG, & perl-SVG.

-Jeff

stuffit
PostPosted: Sat Jun 19, 2004 10:58 am    Post subject: Reply with quote

do i have to manually go and get the above from dag? my apt sources have a listing for dag, but its saying unmet dependencies of the perl stuff:

Code:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
 
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
  inkscape: Depends: perl(SVG)
E: Broken packages


jebba
PostPosted: Sun Jun 20, 2004 1:25 am    Post subject: Reply with quote

I added inkscape and it's needed RPMs to the repository for 9000 as well. So you can just:

Code:
apt-get update
apt-get install inkscape


under 900x and it will install inkscape. I haven't tested it yet, so let me know how it goes.

-Jeff

stuffit
PostPosted: Wed Jun 23, 2004 2:46 pm    Post subject: Reply with quote

Code:


Hit http://www.blagblagblag.org 9000/i386/os pkglist
Hit http://www.blagblagblag.org 9000/i386/os release
Hit http://www.blagblagblag.org 9000/i386/updates pkglist
Hit http://www.blagblagblag.org 9000/i386/updates release
Get:1 http://www.blagblagblag.org 9000/i386/errata pkglist [84.6kB]



these are my blag repositeries. i get the same error about perl-svg as before even after updating.

i tried to install perl-SVG but said need perl-GD, so tried to install perl-GD and got:

Code:


The following packages have unmet dependencies:
  perl-GD: Depends: libgd.so.2 but it is not installable
E: Broken packages


thanks anyway

jebba
PostPosted: Wed Jun 23, 2004 4:06 pm    Post subject: Reply with quote

For some reason the "extras" repository isn't enabled. Add that one and you should get what you need.
stuffit
PostPosted: Wed Jun 23, 2004 4:38 pm    Post subject: Reply with quote

oops sorry , extras is enablled, im getting the same errors.

Code:

Get:1 http://www.blagblagblag.org 9000/i386 release [922B]
Get:2 http://apt.physik.fu-berlin.de redhat/9/en/i386 release [1521B]
Get:3 http://sluglug.ucsc.edu redhat/9 release [505B]
Fetched 2948B in 0s (4281B/s)
Hit http://www.blagblagblag.org 9000/i386/os pkglist
Hit http://www.blagblagblag.org 9000/i386/os release
Hit http://www.blagblagblag.org 9000/i386/updates pkglist
Hit http://www.blagblagblag.org 9000/i386/updates release
Hit http://www.blagblagblag.org 9000/i386/errata pkglist
Hit http://www.blagblagblag.org 9000/i386/errata release
Hit http://www.blagblagblag.org 9000/i386/extras pkglist
Hit http://www.blagblagblag.org 9000/i386/extras release
Hit http://apt.physik.fu-berlin.de redhat/9/en/i386/at-stable pkglist
Hit http://apt.physik.fu-berlin.de redhat/9/en/i386/at-stable release
Hit http://sluglug.ucsc.edu redhat/9/macromedia pkglist
Hit http://sluglug.ucsc.edu redhat/9/macromedia release
Reading Package Lists... Done
Building Dependency Tree... Done

jebba
PostPosted: Wed Jun 23, 2004 5:09 pm    Post subject: Reply with quote

Ok. Disable all the repositories except the blag ones. I think you may be getting a different inkscape or perl-GD or something.

The blag9000 perl-GD requires gd 1.8, which is installed on your system already. If it's requiring gd 2.0, that's for FC1/BLAG10000. Some other repository must be triggering that.

-Jeff

stuffit
PostPosted: Thu Jul 01, 2004 4:36 pm    Post subject: Reply with quote

hi thanks very much for that , it works fine now (excpt having a few problems with it finding fonts)

i was wondering if there are any DTP packages for linux with kerning capabilities?

thanks again

ste

jebba
PostPosted: Thu Jul 01, 2004 6:09 pm    Post subject: Reply with quote

Only real DTP I know of is scribus. I'm not sure if it has kerning or not. I'll see if I can get Dag to do a newer version for when i crank out 10001. The scribus developers say that their most recent development branch release is actually more stable, better, etc than their "stable" release. It has a pile more features too, perhaps kerning. http://www.scribus.org methinks.

If you really dig fonts, check out pfaedit too (soon to be called fontforge in blag). It's pretty heavy but mongo powerful.

Later,

-Jeff

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> open discussion
Page 1 of 1

Protected by Anti-Spam ACP