FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
49k and KDE
Goto page 1, 2  Next
 
Post new topic   Reply to topic    BLAG Forum Index -> development
View previous topic :: View next topic  
Author Message
claudejones
PostPosted: Sun Mar 19, 2006 1:29 pm    Post subject: 49k and KDE Reply with quote

This is my first post to the forum. I was pleased to discover the announcement over at DistroWatch about this project, and downloaded/installed it immediately. I'm a TV producer in the vicinity of Washington, DC, and I have been discovering Linux for the past 20 months. After trying multiple distros, I had concluded that with all its imperfections, Fedora was still my preferred project - I like it because of its rapid pace of development, large user base, and huge collection of repositories. I had hoped to become profficient enough that some day I could unite these qualities and build a Fedora distro that was oriented to the content creator community - so, this what was great about discovering your project. OK - enough introductions.

I actually tried your stable version first, 30002, I think it's called. I prefer KDE to Gnome, and I found some posts in the forum that suggested using Synaptic to install KDE. I did that without any trouble, and KDE came up cleanly after a re-logging in. Then I installed your new 49k, I think it was 49993 - when I tried to log into KDE after the install, I got an error to the effect that the system couldn't start "kstartconfig" - and clicking the OK button returned me to the login screen. Googling this error has produced a bunch of hits on various SUSE forums - I wonder if anyone else has encountered this and found a solution before I try those SUSE user suggestions?


_________________
Claude Jones
Brunswick, MD USA
jebba
PostPosted: Sun Mar 19, 2006 6:41 pm    Post subject: Reply with quote

Uh did you do a fresh install or an upgrade of 30k->50k?

KDE is not on the CD as you probably know. Gnome is quite nice now, btw. ;)

Anyway, this may fix your stuff if you did an upgrade:

Code:
apt-get update
apt-get -f install


If you have a fresh install, i suggest installing yumex then using it to download/install the kde bits you want:

Code:
apt-get update
apt-get install yumex

claudejones
PostPosted: Mon Mar 20, 2006 1:10 am    Post subject: Reply with quote

[quote="jebba"]Uh did you do a fresh install or an upgrade of 30k->50k?

Fresh install

[quote="jebba"]KDE is not on the CD as you probably know. Gnome is quite nice now, btw. ;)

I understand that people like it. I just don't - I have spend a considerable amount of time with it, but, it's not my choice. I have KDE 3.5 running on multiple machines, both Fedora and other distros. It's my preference - but I certainly have no interest in starting a Gnome vs KDE war, not to mention all the other desktops...

[quote="jebba"]If you have a fresh install, i suggest installing yumex then using it to download/install the kde bits you want:

That's what I did. "yum install yumex" then, checked the repos, and it seemed as though the defaults were simply the blag repos, which I left that way - then I installed all the KDE packages.


_________________
Claude Jones
Brunswick, MD USA
john maclean
PostPosted: Mon Mar 20, 2006 12:55 pm    Post subject: Reply with quote

I've not used kde before but is there a --debug option? If there is it could be useful to iron out your problems and for googling.

_________________
BLAG 'em up!
Guest
PostPosted: Mon Mar 20, 2006 8:00 pm    Post subject: Reply with quote

john maclean wrote:
I've not used kde before but is there a --debug option? If there is it could be useful to iron out your problems and for googling.


Doing some further research - the error I'm getting gives me a "details" option in a second box that pops up sometimes, after I click the "OK" in the first error dialog. That informs me that KDE is trying to open /home/cj/.kde/share/config/startupconfig and can't find it. It would seem that something in the installation process is breaking, and that probably one-time-use file is not being written to the destination - I looked in the location and it's definitely not there. There is a file called "startupconfigkeys" in there.

john maclean
PostPosted: Mon Mar 20, 2006 11:21 pm    Post subject: Reply with quote

are there any other clues that you can think of? for example
Code:


$ whereis gnome
gnome: /usr/share/gnome

$ ls /usr/share/gnome
apps          default.session  gkb   panel     wm-properties
cursor-fonts  default.wm

$ ls /usr/share/doc/gnome-
gnome-applets-2.8.0/          gnome-python2-2.6.0/
gnome-audio-2.0.0/            gnome-python2-bonobo-2.6.0/
gnome-desktop-2.8.0/          gnome-python2-canvas-2.6.0/
gnome-kerberos-0.3.3/         gnome-python2-gtkhtml2-2.6.0/
gnome-keyring-0.4.0/          gnome-session-2.8.0/
gnome-keyring-manager-0.0.3/  gnome-themes-2.8.0/
gnome-media-2.8.0/            gnome-utils-2.8.0/
gnome-mime-data-2.4.1/        gnome-vfs2-2.8.2/
gnome-netstatus-2.8.0/        gnome-volume-manager-1.1.0/
gnome-panel-2.8.1/   

$ ls /usr/share/doc/gnome-desktop-2.8.0/
AUTHORS  ChangeLog  COPYING  NEWS  README

There could be a copy of the missing file which you could put into the right location in your home dir....


_________________
BLAG 'em up!
stevo32
PostPosted: Mon Mar 20, 2006 11:37 pm    Post subject: Reply with quote

I'm more inclined to think that deleting your entire kde configuration directories in your home dir (rm -rf /home/`whoami`/.kde*) and having the new version recreate them or ensuring that you've got all the necessary programs to run KDE.

Thanks,
Stephen Clement


_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).
Guest
PostPosted: Tue Mar 21, 2006 4:57 pm    Post subject: Reply with quote

stevo32 wrote:
I'm more inclined to think that deleting your entire kde configuration directories in your home dir (rm -rf /home/`whoami`/.kde*) and having the new version recreate them or ensuring that you've got all the necessary programs to run KDE.

Thanks,
Stephen Clement


Here's what's installed - now, the strange thing is that KDE is no longer even offered as an option in the session options at the login screen! I've removed and reinstalled several times, to no avail - it just seemed to make matters worse.

[root@localhost ~]# rpm -qa | grep kde*
lockdev-1.0.1-9.2.1
kdebase-3.5.1-5
kdeartwork-icons-3.5.1-1.2
kdeaddons-3.5.1-1.2
kdenetwork-devel-3.5.1-1.2
wordtrans-kde-1.1pre13-12.2.1
kdebindings-3.5.1-1.2
kdeedu-devel-3.5.1-1.2
kdeaddons-atlantikdesigner-3.5.1-1.2
kdepim-3.5.1-1.2
kdesdk-3.5.1-1.2
kdeutils-3.5.1-1.2
kdevelop-3.3.1-1.2
kdemultimedia-devel-3.5.1-2
kdeadmin-3.5.1-1.2
kdebindings-devel-3.5.1-1.2
kdelibs-3.5.1-2.3
kdenetwork-3.5.1-1.2
kdesvn-0.7.4-1.fc5
kdebase-devel-3.5.1-5
kdemultimedia-3.5.1-2
kdeedu-3.5.1-1.2
kdeutils-devel-3.5.1-1.2
kdepim-devel-3.5.1-1.2
kdegames-devel-3.5.1-1.2
kdewebdev-devel-3.5.1-1.2
kdelibs-apidocs-3.5.1-2.3
kdelibs-devel-3.5.1-2.3
kdbg-2.0.2-1.2
kdetoys-3.5.1-3.fc5
kdegames-3.5.1-1.2
kdegraphics-3.5.1-3
kdegraphics-devel-3.5.1-3
kdesdk-devel-3.5.1-1.2
kdewebdev-3.5.1-1.2
kdeartwork-3.5.1-1.2
kdeaccessibility-3.5.1-2

john maclean
PostPosted: Tue Mar 21, 2006 5:54 pm    Post subject: Reply with quote

Have you tried the `which` command? As in `which kde-foo` or what ever it's called?

_________________
BLAG 'em up!
stevo32
PostPosted: Thu Mar 23, 2006 1:42 am    Post subject: Reply with quote

Anonymous wrote:
stevo32 wrote:
I'm more inclined to think that deleting your entire kde configuration directories in your home dir (rm -rf /home/`whoami`/.kde*) and having the new version recreate them or ensuring that you've got all the necessary programs to run KDE.

Thanks,
Stephen Clement


Here's what's installed - now, the strange thing is that KDE is no longer even offered as an option in the session options at the login screen! I've removed and reinstalled several times, to no avail - it just seemed to make matters worse.

[root@localhost ~]# rpm -qa | grep kde*
--snip--


Alright, try doing this:

Switch to virtual terminal 1. (Ctrl+Alt+F1), log in as a regular user besides yourself.

Run this:
Code:
X :1 &
export DISPLAY=:1
kdeinit


After doing the X :1 &, you'll get switched into your new X session on virtual terminal 9. Switch back to the first, then run the second two commands, then you'll have to switch back to virtual terminal 9 (Ctrl+Alt+F9). Although this works with 30k, I'm not sure if it'll work with 49k. Not sure if you already know this, but Ctrl+Alt+F7 to get back to your other graphical session (yes, you can have two copies of graphical linux running! the wonders of a real multi-tasking operating system, unlike some others we know...). Hit Ctrl+Alt+Backspace when you're in VT9 in order to kill the X server. And that's about it. I hope. I've probably made a mistake somewhere 'round here, but I guess you'll have to find out. ;)

Thanks,
Stephen Clement


_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).
jebba
PostPosted: Thu Mar 23, 2006 5:04 am    Post subject: Reply with quote

Woah stevo nice one. :)

I've done that in the past, but never so simply.

We should wiki that up. And get e17 in the repo!

-Jeff

jebba
PostPosted: Thu Mar 23, 2006 5:16 am    Post subject: Reply with quote

Actually very nice. I'm running gnome with 21 virtual desktops, blackbox, fluxbox, and enlightenment simultaneously -- F7 through F10.
jebba
PostPosted: Thu Mar 23, 2006 5:22 am    Post subject: Reply with quote

Actually very nice. I'm running gnome with 21 virtual desktops, blackbox, fluxbox, and enlightenment simultaneously -- F7 through F10. Works on 30k & 50k.
jebba
PostPosted: Thu Mar 23, 2006 6:01 am    Post subject: Reply with quote

FWIW I got kde going on 49k logging in via GDM and changing the session. My old 20k (!) .kde dirs worked fine, but I yanked 'em to start fresh. I also switched to the really-little-guys icon theme. :)

XFCE works fine too and can use the really-little-guys SVG icon set and the blagCanyon gnome theme. It's just not set by default.

-Jeff

stevo32
PostPosted: Thu Mar 23, 2006 9:07 am    Post subject: Reply with quote

Nice to hear you've got it working. I plan to write a wiki entry on this.

Thanks,
Stephen Clement


_________________
E-mail me at s.clement@localhost (replace localhost with sympatico.ca) or stevo32@localhost (replace localhost with blagblagblag.org).
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> development Goto page 1, 2  Next
Page 1 of 2

Protected by Anti-Spam ACP