BLAG

BLAG Forums
It is currently Thu Dec 18, 2014 4:21 am

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed Apr 27, 2005 4:39 pm 
Offline

Joined: Tue Jan 25, 2005 9:09 pm
Posts: 72
Location: chicago
I've run many version of 29.x test releases without problem, but they were all fresh installs on a test box. Upgraded my main box from 10k to 30k yesterday and got 43 broken packages. Trying to fix broken packages in synaptic just spawned errors. I tried apt-get -f intall but didn't get anywhere. Here's what I got:

Code:
# apt-get -f install
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
  GConf2-devel: Depends: GConf2 (= 2.4.0) but 2.8.1-1 is installed
  ORBit2-devel: Depends: ORBit2 (= 2.8.2) but 2.12.0-3 is installed
  SDL-devel: Depends: SDL (= 1.2.7-3) but 1.2.7-8 is installed
  SDL_mixer-devel: Depends: SDL_mixer (= 1.2.4) but 1.2.5-4 is installed
  SDL_net-devel: Depends: SDL_net (= 1.2.4-8) but 1.2.5-2 is installed
  XFree86-devel: Depends: XFree86-libs (= 4.3.0-55)
  abiword-plugins-impexp: Depends: libcrlayeng.so.1
                          Depends: libcroco.so.1
                          Depends: libcrseleng.so.1
  atk-devel: Depends: atk (= 1.4.0) but 1.8.0-2 is installed
  audiofile-devel: Depends: audiofile (= 1:0.2.3) but 1:0.2.6-1 is installed
  esound-devel: Depends: esound (= 1:0.2.31) but 1:0.2.35-2 is installed
  fontconfig-devel: Depends: fontconfig (= 2.2.1) but 2.2.3-5 is installed
  freetype-devel: Depends: freetype (= 2.1.4-5) but 2.1.9-1 is installed
  gcc: Depends: cpp (= 3.3.2-1) but 3.4.3-22.fc3 is installed
  gcc-c++: Depends: libstdc++ (= 3.3.2) but 3.4.3-22.fc3 is installed
  glib2-devel: Depends: glib2 (= 2.2.3) but 2.4.8-1.fc3 is installed
  glibc-devel: Depends: glibc (= 2.3.2) but 2.3.5-0.fc3.1 is installed
  glibc-headers: Depends: glibc (= 2.3.2) but 2.3.5-0.fc3.1 is installed
  gnome-desktop-devel: Depends: gnome-desktop (= 2.4.0) but 2.8.0-3 is installed
  gnome-vfs2-devel: Depends: gnome-vfs2 (= 2.4.1) but 2.8.2-8 is installed
  gnopernicus: Depends: libgnome-mag.so.1
  gtk2-devel: Depends: gtk2 (= 2.2.4) but 2.4.14-3.fc3 is installed
  libIDL-devel: Depends: libIDL (= 0.8.2) but 0.8.4-1 is installed
  libbonobo-devel: Depends: libbonobo (= 2.4.0) but 2.8.0-2 is installed
  libbonoboui-devel: Depends: libbonoboui (= 2.4.0) but 2.8.0.99cvs20040929-2 is  installed
  libglade2-devel: Depends: libglade2 (= 2.0.1) but 2.4.0-5 is installed
  libgnome-devel: Depends: libgnome (= 2.4.0) but 2.8.0-2 is installed
  libgnomecanvas-devel: Depends: libgnomecanvas (= 2.4.0) but 2.8.0-1 is install ed
  libgnomeui-devel: Depends: libgnomeui (= 2.4.0.1) but 2.8.0-1 is installed
  libpng-devel: Depends: libpng (= 2:1.2.5) but 2:1.2.8-1.fc3 is installed
  libpng10-devel: Depends: libpng10 (= 1.0.15) but 1.0.18-1.fc3 is installed
  libstdc++-devel: Depends: libstdc++ (= 3.3.2-1) but 3.4.3-22.fc3 is installed
  libtiff-devel: Depends: libtiff (= 3.5.7) but 3.6.1-9.fc3 is installed
  libtool: Depends: libtool-libs (= 1.5-8) but 1.5.6-4.FC3.2 is installed
  libungif-devel: Depends: libungif (= 4.1.0) but 4.1.3-1 is installed
  libxml2-devel: Depends: libxml2 (= 2.6.6) but 2.6.16-3 is installed
  libxslt-devel: Depends: libxslt (= 1.0.33) but 1.1.11-1 is installed
  openoffice.org: Depends: XFree86 but it is not installed
                  Depends: libdb_cxx-4.1.so
  openoffice.org-libs: Depends: libdb_cxx-4.1.so
  pango-devel: Depends: pango (= 1.2.5) but 1.6.0-7 is installed
  php-domxml: Depends: libxsltbreakpoint.so.1
              Depends: php (= 4.3.8-1.1) but 4.3.11-2.4 is installed
  startup-notification-devel: Depends: startup-notification (= 0.5) but 0.7-1 is  installed
  tdfsb: Depends: libsmpeg-0.4.so.0
         PreDepends: smpeg (>= 0.4) but it is not installed
  zlib-devel: Depends: zlib (= 1.2.0.7) but 1.2.1.2-1 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by he ld packages.
E: Unable to correct dependencies


Any suggestions about what to try next? I backed up my data before upgrading, so if I have to do a clean install I can, but if there's a simpler solution....

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 9:31 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Did you do update first? This should clean it up:

Code:
apt-get update
apt-get -f install
apt-get dist-upgrade


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 9:47 pm 
Yeah, already tried that. Didn't seem to fix anything.


Top
  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 10:01 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Not to beat the issue here, but you /certain/ you ran the "apt-get update" first????


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 10:16 pm 
Offline

Joined: Tue Jan 25, 2005 9:09 pm
Posts: 72
Location: chicago
Absolutely certain. I just did it again, and watching more closely saw that apt was hitting the repositories for 30k and 10k. So I disabled the 10k repositories and repeated, and now apt is downloading packages. I should know in a few minutes how things work out.

Should the upgrade disable the 10k repositories automatically? Don't know if this is some quirky thing on my system or possibly with the upgrade script?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 10:36 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
The new apt from the CD should have replaced your config, so there should be /no/ reference to 10k anywhere. Delete all references to 10k and it should be fine.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 10:50 pm 
Almost there...

Everything worked (and synaptic is happy again) except both apt-get -f install and apt-get dist-upgrade gave me this:

Code:
[Invalid UTF-8] Could not parse file '/usr/share/applications/blag-net-xsane.desktop': desktop entry contain line 'Description[sv]=Ett GIMP-insticksprogram som erbjuder ett bildl\xe4sargr\xe4nssnitt.' which is not UTF-8


and then continued on with other packages. Is this anything I should care about?

Thanks.


Top
  
 
 Post subject:
PostPosted: Wed Apr 27, 2005 11:12 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Don't worry about that xsane complaint. There's just some bad UTF-8 in the SV language for that entry.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group