BLAG

BLAG Forums
It is currently Sun Dec 21, 2014 5:22 pm

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Can't Play Audio CDs
PostPosted: Tue Jul 14, 2009 12:47 am 
Offline

Joined: Wed Apr 15, 2009 12:13 am
Posts: 13
Location: Los Angeles, Oaxaca, Chiapas
Blag recognizes the CD as an audio CD, but all apps fail to play said CD whether the attempt is made via the "Do you want to open the audio CD with..." alert, double clicking on the audio CD icon, double clicking on individual files as seen in Nautilus, etc.
For example, VLC gives the error:
Your input can't be opened:
VLC is unable to open the MRL 'cdda://sr0/'. Check the log for details.

Of course, they don't hint where those logs live.
But all apps are failing to play the CD on either machine.

I think this may be some weird permissions thing since I am able to copy the files from the audio CD to a folder and have no trouble playing it with any of the apps available (zine, mplayer, vlc, etc...). Also Nautilus shows the locks on the WAV file icons, although Properties/Permissions says the "permissions could not be determined"..

Thanks!


Top
 Profile  
 
 Post subject: Re: Can't Play Audio CDs
PostPosted: Wed Jul 15, 2009 2:03 pm 
Offline

Joined: Fri Sep 17, 2004 3:53 pm
Posts: 42
This isn't going to be a complete answer as I don't use Gnome, Nautilus or VLC usually, but I might be able to point you in the right direction.

Audio CDs aren't mounted in order to be played, so it's normal that Nautilus can't determine file permissions (and shows the locks). The problem is most likely to do with the Gnome virtual file system (gvfs) not communicating with VLC.

Fire-up VLC with a CD in the drive and select 'File' --> 'Open Disc' select the 'Audio CD' radial button; can you play the CD from there? If not what device is it trying to play?

Open a terminal and try
Code:
vlc cdda:///dev/scd0@1

Let us know any error messages.

I use Gnome-mplayer for audio CDs and expressly open the CD from within the program. It has a simple interface and allows easy selection of tracks.

Let us know how you get on.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jul 15, 2009 3:28 pm 
Offline

Joined: Wed Apr 15, 2009 12:13 am
Posts: 13
Location: Los Angeles, Oaxaca, Chiapas
This doesn't just occur with VLC, but with mplayer, Xine, etc. , but here's the VLC error msgs:
[00000435] main stream error: cannot pre fill buffer
[00000474] pulse audio output: No. of Audio Channels: 2
[00000474] pulse audio output error: Failed to connect to server: Connection refused
[00000474] pulse audio output error: Pulse initialization failed

Looks like it's trying to use pulse audio instead of ALSA... And the connection is being refused which does sound like it maybe a permissions thing.

When I changed the VLC preference from 'default' to ALSA it would plavy from Media - Open Disk with the Audio CD checked...


Top
 Profile  
 
 Post subject: Re: Can't Play Audio CDs
PostPosted: Thu Jul 16, 2009 2:54 pm 
Offline

Joined: Fri Sep 17, 2004 3:53 pm
Posts: 42
Frank Discussion wrote:
Of course, they don't hint where those logs live.

They're in /var/log/messages. Open a terminal
Code:
sudo tail -f /var/log/messages

Have a look at
Code:
/tmp/pulse-youruser
to see if the ownership s correct. You could check if it's a permissions problem by logging in as root.

What happens when you try each of
Code:
mplayer -ao pulse /usr/share/sounds/phone.wav
mplayer -ao alsa /usr/share/sounds/phone.wav


Sorry I can't be of much help. Anyone else?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jul 17, 2009 3:02 pm 
Offline

Joined: Sat Apr 05, 2008 10:41 pm
Posts: 92
Location: Mesoamerica
same problem with me, here's part of my dmesg

Code:
end_request: I/O error, dev sr0, sector 0
Buffer I/O error on device sr0, logical block 0
Buffer I/O error on device sr0, logical block 1
Buffer I/O error on device sr0, logical block 2
Buffer I/O error on device sr0, logical block 3
Buffer I/O error on device sr0, logical block 4
Buffer I/O error on device sr0, logical block 5
Buffer I/O error on device sr0, logical block 6
Buffer I/O error on device sr0, logical block 7
end_request: I/O error, dev sr0, sector 0
...


sorry! I tried to play audio disk with a dirty CD!! so, this dmesg is not related at all

I tried again with another audio disc and everything is working good, music is now playing with vlc

maybe you need to install alsa utils, also my user is in 'audio' and 'pulse-rt' groups
Code:
yum install alsa-utils


anyway, I'm looking around about this message
Code:
program vlc is using a deprecated SCSI ioctl, please convert it to SG_IO


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jul 17, 2009 11:49 pm 
Offline

Joined: Sat Jan 05, 2008 4:16 pm
Posts: 84
@ Frank Discussion: I had a similar problem a while back, and it was a permission thing. I assume you can play cds if you start the player as root from command line?

As far as I remember, the solution was to change the mode in the # block section of /etc/udev/rules./50-udev-default.rules to look like this:
Code:
# block, tapes, block-releated
SUBSYSTEM=="block", GROUP="disk", MODE="0660"



Robert


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group