FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
WHAT ABOUT THOSE PESKY browser PLUGINS? - gnubie asks again

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
glogo
PostPosted: Sat Aug 13, 2005 10:19 am    Post subject: WHAT ABOUT THOSE PESKY browser PLUGINS? - gnubie asks again Reply with quote

Hey,

here's the next question I have:

Is there any replacement, GNU-wise, for the macromedia flashplayer. It is somehow disappointing when surfing around GNU-powered,
A) not to be able to see half the time what the images are about and worse
B) not to be able to close some of those popup windows when they open.
(Now I know there must be popup-stoppers, but there are also websites that don't work if you have them blocked, or there used to be).

The other thing is, there are a few sites I surf to regularly, because I like to hear the audio they are playing. When I am BLAGGING, the sound does not play. There must be something missing.

Okay, I am off to surf the firefox supports to see what I can find there. Probably I am doing this all backwards. FIRST I should RTFM, and then I should SEARCH for support forums and google the topic, THEN I should ask here, but hey,

I have fallen in LUV... as in, this is my HOME away from home, in the ethers.

Yours again,
Gloria

PS:

I was just reflecting that it is probably really hard for you all to know that I love to kid around and carry on online about certain topics and have a very oddball, dry sense of humor. Nothing I say should be taken very seriously... thankxxx for any help.

glogo
PostPosted: Sat Aug 13, 2005 10:44 am    Post subject: IN ANSWER TO MY OWN QUESTION Reply with quote

Okay,

here I found part of the answer:

http://applications.linux.com/applications/05/06/01/2041253.shtml?tid=39&tid=63&tid=51

about the development of the GPLflashplayer and the GPL2flashplayer.
There is a condensed history of the project. It says that macromedia developed a linux compatible player when they got wind of what was being developed by Oliver Debon. Now it seems the project is active again and they are trying to make a player that is not so bloated.
Well, I guess that means I could load the bloated variety, if I could find a build for my core, right? But I don't know if it is worth it.

Now off to investigate about the sound issue.

LUV
G

glogo
PostPosted: Sat Aug 13, 2005 11:01 am    Post subject: Found the download site for Flashplayer Reply with quote

Now, I know, (JEFF), from snooping around your blog that you don't like the flash player...
And I know that the Blag is being developed as a package of completely free software. BUT,
as an exercise for me, I would like to know if it is possible to install it to the blag.
I mean, the blag is about FREEDOM right? Freedom to move and develop and use a computer, a system, the way one chooses, am I correct here?
So I am thinking it might be an interesting experiment to try to load the flash. I might just get rid of it afterwards, too. I learn a lot by loading and reloading and unloading etc.
I think I said somewhere, I reload my OS about as often as I wash my bath towels. And I am not really that grubby. I was not really exaggerating too much there. I reload a lot, my preferred method of learning about computers being trial and error. I have scr--d my OS so many times in the last 6 years or so, I cannot begin to count. And the box I have now, I have thought it was a gone-er about 4 or 5 times already and by some miracle, it was always possible to get it up and going again. Most people I know (I must say I don't know many geeks) would have given up and trashed it long ago. So it kind of gives me a perverse satisfaction to bugger it and then un-bugger it again, if you know what I mean.
So, I am just thinking to load the flash player for the heck of it.
Here is the thing. I do not know anything about this stuff, so I am just swinging with an axe in the forest blindfolded.
AT this link:
http://www.macromedia.com/shockwave/download/alternates/
are the 2 possibilities I see.
the links say:
Flash Player 7 for Mozilla 1.2
Flash Player 6 for Mozilla 1.1
Footnote says:
These Linux packages (RPM, DEB, ebuild) are available for manual download, apt-get, urpmi, or emerge for these supported operating systems: RedHat, Mandrake, SuSE, Conectiva, Debian, Gentoo, Generic.

So that means I have to see which one of these should work for this core? Which is Fedora 3? And Fedora is Red Hat? They said it is compatible with Red Hat 9, right? Does that fit here?
What is the best way to get it, aptget? Okay, off to surf some more and answer my own questions as long as it works...
XXX
G
PS: I am assuming I have to load the Mozilla, that being a dependency, but, wait a minute, is not the Firefox built on Mozilla? So would that not mean that this player should work with it, everything being downwards compatible usually??

glogo
PostPosted: Sat Aug 13, 2005 12:08 pm    Post subject: GETTING OVER MY SHYNESS... Reply with quote

So,

Hello, again,

I am starting to get over my shyness about removing files, updating packages, installing widgets and going in as root and rm-ing any file when requested to do so. So that is what I just did and the flash player seem to be working to some degree, at least on some of the flash stuff.
Well, that is interesting for me. Now for all of those who are that garden-variety, raised on command-line, non-gui linux functionality, I feel somehow sure this may seem trivial.
But I think this kind of exclusive looking-down-the-nose attitude that some (very few, but very vocal) of this geek (in the positive sense now) community tends to put those of us off, who would really love to make the switch to open source software, but who have been raised on the spoon-fed windows gui, dependency mentality, and just have a hard time, climbing through all the mountainous protocol in order to get started using any open source system. After all, we are practically WED to the WEB and our PCs and if they are down even for a few hours we tend to feel somewhat lost without them. (Until, of course, we discover, again, that life goes on, with or without 'puters.)
This has been a marked difficulty for me. But I have been highly motivated to dispense with windows. Now I have nothing against learning about using the command line and getting away from the dependency and spoon-fed-ness of my windows upbringing. But it is really a big learning curve, n'est ce pas?
So, I for one am always happy and IN LUV when anything, just ANYTHING, works.
So, I just updated a whole slew of packages and it seems I installed the mozilla browser but it was not necessary. So now I seem to have 3. Mozilla, firefox and thunderbird, whatever that is.
So, I was going to go back and look after the sound issue. But that will have to wait for another day.
The download and install from the macromedia site went off without a hitch, it seems, up until this point. We will see what develops down the line.

As always, yours, gratefully.

Gloria

PS:
It just occurred to me, maybe this would be better as a blog, since I am in a kind of self-gratification mode anyway? hmm?

jebba
PostPosted: Sat Aug 13, 2005 1:33 pm    Post subject: Reply with quote

Heh.

Soooo, packages that are compatible with FC3 should work fine w/ blag, including flash. To install flash, there are a number of ways. You can just download the RPM from macromedia & install it. Or you can enable the macromedia repository in synaptic and install "flash-plugin" or...there are more ways you can go about it. ;)

Thunderbird is a firefox-esque MAIL client, btw.

This is my first message of the day, so I'm a bit out of it.

The next one you'll probably start wondering about (esp wrt sound) is w32codec. Have fun. ;)

-Jeff

glogo
PostPosted: Sat Aug 13, 2005 7:31 pm    Post subject: loaded realplayer 10 Reply with quote

Hi, loaded the real player 10 but it does not seem to work properly with the flash plugin, at least at my friend's site, where I go to hear this one sound file sometimes.
So, maybe that is it, I need some codecs.
You are right, this is kind of fun.
But, Jeff, what if we have a world war and nobody uses computers any more?
Hiha, just some more morbid humor, but really, sometimes I wonder if I am not wasting time.
It's fun though.
LUV,
G
PS, I have to boot up, open the network gui, give the root password and activate the ppp0. Then I can surf, it is a bit of a pain but it works, happily. I know that is not the way it is supposed to work, but then I remember the old days when i was trying to get various things to work with the older windows os's (started with win 3.11). This must be good for something.
g

john maclean
PostPosted: Sun Aug 14, 2005 11:31 am    Post subject: Re: GETTING OVER MY SHYNESS... Reply with quote

glogo wrote:
....After all, we are practically WED to the WEB and our PCs and if they are down even for a few hours we tend to feel somewhat lost without them. (Until, of course, we discover, again, that life goes on, with or without 'puters.) ....


Huh? There isn't a power point at the park, so my laptop's **useless** there. Won't take the laptop to the beach... I mean come on, all that water. :twisted:
Regarding realplayer. If you install it from somewhere like here then you should be able follow the instructions to get it installed. (Beleive me if \I\ can, then anyone can).

Tip: After you've installed realplayer, try to run it from the command line. Simple reason, it won't work but you'll see a usefull message that you'll use to fix that.

You'll notice that libdistc or some such is required, which you may not have.

Code:

jayeola@11:50:38$ apt-cache search libstdc++
compat-libstdc++ - Compatibility standard C++ libraries
libstdc++ - GNU Standard C++ Library
libstdc++-devel - Header files and libraries for C++ development
compat-libstdc++-devel - Header files and libraries for C++ compatibility compiler


To be honest, I've never known which exactly which one of these is required by RP so I just install all of them :oops: . [/me is very lazy]

Code:
root@11:50:14#apt-cache search libstdc++ | cut -d" " -f1| xargs apt-get -y install


and apt-tells us
Code:

libstdc++ is already the newest version.
libstdc++-devel is already the newest version.
The following NEW packages will be installed:
  compat-libstdc++ compat-libstdc++-devel
0 upgraded, 2 newly installed, 0 removed and 0 not upgraded.


So that @should@ be it and rp should be installed and working....






_________________
BLAG 'em up!
glogo
PostPosted: Sun Aug 14, 2005 1:38 pm    Post subject: HI GUY.... Reply with quote

Hey John,

are you the same John (I know there are a lot of Johns in LondonUK, but I mean the blag.john) that I was sort of "email-chatting" with about a year back? I wonder...the one who likes poetry and was writing a blog somewhere and (this could be any chinese princess, I know)???
Greetings, in any case.

Yes, thanks, I got the RP installed somehow and it does work and no, when I run it from the command line it does not spit out anything, it just... works.
It plays mp3, ram and wav formats so far without too much of a hitch. The ram sounded a bit distorted.
I tried to look at a trailer on the real.movies site but there was no tone. I guess I need to load some codecs, huh? And I don't know why, but the realplayergold10.bin which I used somehow is not recognized on my friend's site. The plugin still shows "download this plugin" and the sound does not play there.
Maybe the .bin is not update enough even though the rp10-version?

I downloaded some codecs from a site last night and un-tar-balled the tarball, but I don't know what the heck to do with them now. Where do you stick them? do you have to update the codec-config files (I saw one of those, gawd, I don't even know if I want to start on that yet. I just took a big breath and then exhaled and went to bed. after all it was 6 a.m and I was supposed to go to church today before 11 a.m. Yes, I was able to somehow get up in time and I did make it there.)

JOHN, now I am remembering. Were you the one I confessed all that embarrassing pyscho-babel, crazy stuff to and then we were both silent for many weeks and then our chatting just kind of went to sleep? hmm?? I am just as crazy as I was, but the only difference is now I am not suffering from it any more, AT ALL. I cannot say the same for those around me, however, necessarily. But seriously, I am okay. Still bwoke but not bwoken.

Oh, actually I wanted to say, JEFF (hi), I fired up the gnutella now that I have the portforwarding on, and there was something in the interface in order to allow other computers to have access to my 'puter and now the thing has been running for over 12 hours, and has not crashed my ppp0 or eth0 or whatever (and yes, the box is configured so that you need both of them, very odd), AND people have been able to upload from my hard drive, as well.
But the gnutella is still buggy and is actually de-uploading some of the things I had downloaded. One movie was a 100% finished, it should have had less then one kb to go, but it did not ever finish, then the process reversed and this morning when I got up, it was back to 21% or something. I just purged it. What the heck, I'll just rent that one from the video store.
It's a known gtk-g issue. I was dissappointed the french version of KB1 (killbill), ALSO was doing this reverse download trick and out of 34% only 2,3 % were left this morning, but it has started again and is up to 8 or 9 % now. It only wants 4 or 6 days to download the file (one CD), not a good sign. I suspect these have to do with push requests and the link breaking in the middle of downloading and getting corrupt data. Whatever. Not a blag issue at all, I know.':)'

But really, here I go again, I am off to surf in the forums and look for a way to install those pesky codecs. But, do feel free to answer.

JOHN, my dear, I do not know what to say, You were trying so hard to help me. I wonder what all that code is that you wrote. But someday someone will need it and will google this page, n'est ce pas?

Love,
G
(when it works)

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP