FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
GRUB fails to boot windoze

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
kazim
PostPosted: Mon May 24, 2004 10:22 am    Post subject: GRUB fails to boot windoze Reply with quote

I am having problems getting another OS (Win2000) to boot from GRUB. Can anyone else who uses dual boots post some examples of their working grub.conf and partition tables?

Mine are currently:

[code]
Device Boot Start End Blocks Id System
/dev/hda1 1 13 98248+ 83 Linux
/dev/hda2 14 4148 31260600 83 Linux
/dev/hda3 4149 9937 43764840 5 Extended
/dev/hda4 * 9938 10337 3024000 83 Linux
/dev/hda5 4149 4562 3129808+ 83 Linux
/dev/hda6 4563 4837 2078968+ 83 Linux
/dev/hda7 * 4838 5389 4173088+ 7 HPFS/NTFS
/dev/hda8 5390 5526 1035688+ 82 Linux swap
[code]


GRUB.CONF
[code]
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz

title Red Hat Linux (2.4.20-30.9)
root (hd0,0)
kernel /vmlinuz-2.4.20-30.9 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-30.9.img

title DOS
root (hd0,6)
makeactive
chainloader +1
[/code]

When I try to boot to DOS I get this error:

[code]
Booting 'DOS'
root (hd0,6)
Filesystem type unknown, partition type 0x7
makeactive
Error 12: Invalid device requested

Press any key to continue
[/code]

The DOS partition (6) is definitely bootable (it was booting before I set up BLAG) ;)

I have tried "hide (hda0,x)" for partitions prior to 6 from Windoze, that didn't work either.

Can anyone else who uses dual boots post some examples of their working grub.conf and partition tables?

Jason
PostPosted: Tue May 25, 2004 2:40 am    Post subject: Reply with quote

My grub.conf is

Code:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,1)
#          kernel /boot/vmlinuz-version ro root=/dev/hda2
#          initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
title BLAG (2.4.20-30.9)
        root (hd0,1)
        kernel /boot/vmlinuz-2.4.20-30.9 ro root=LABEL=/ hdd=ide-scsi
        initrd /boot/initrd-2.4.20-30.9.img
title Windows
        rootnoverify (hd0,0)
        chainloader +1


My partitions are


Code:

Disk /dev/hda: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      5099  40957686    7  HPFS/NTFS
/dev/hda2          5100     14754  77553787+  83  Linux
/dev/hda3         14755     14945   1534207+  82  Linux swap
 
Disk /dev/hdb: 40.9 GB, 40982151168 bytes
255 heads, 63 sectors/track, 4982 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             2      4982  40009882+   f  Win95 Ext'd (LBA)
/dev/hdb5             2      4982  40009851    b  Win95 FAT32


Hope this helps.

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP