FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Failed to open audio device (/dev/dsp)

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
kazim
PostPosted: Fri Apr 23, 2004 1:31 pm    Post subject: Failed to open audio device (/dev/dsp) Reply with quote

Everytime an application uses the dsp device in 9002, it seems to leave a lock on it (even after the app has been shut down) Then when another app needs to use it, it will error like this:

Code:
Checking audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 44100 hz, little endian signed int
AF_pre: 44100Hz 2ch Signed 16-bit (Little-Endian)
audio_setup: Can't open audio device /dev/dsp: Device or resource busy
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

or
** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): Device or resource busy

It's a real problem cos if evolution get mail and sings its song, then I cant play the reggae music which makes the workshop happy ;)

I have tried using gnome-sound-properties, enabling sound server, but this appears to make no difference.

jebba
PostPosted: Sat Apr 24, 2004 2:21 am    Post subject: Reply with quote

hmm. see if a process called `esd` is running. Perhaps evolution itself keeps the lock.

Also, you can run `lsof` as root. lsof=list of open files

so something like:
Code:
lsof | grep dsp


will tell you which file has "dsp" open.

-Jeff

kazim
PostPosted: Sat May 29, 2004 9:46 am    Post subject: Reply with quote

I have found that although you can set Evolution options to use esd (the sound server) rather than accessing the sound system directly, it still locks the sound system directly. Solution is to choose "Beep" for New Mail Nofification rather than "Play File".
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP