FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
First day impressions
Goto page 1, 2  Next
 
Post new topic   Reply to topic    BLAG Forum Index -> open discussion
View previous topic :: View next topic  
Author Message
jebba
PostPosted: Tue Mar 23, 2004 2:25 am    Post subject: Reply with quote

Sound Card
==========
Two programs, run as root, may help with finding your soundcard:
redhat-config-soundcard
/usr/sbin/sndconfig

What kind of sound card do you have? You can find details running:
/sbin/lspci and
/sbin/lspci -vv

If you have a blag install you can get further info by running:
/usr/sbin/lswh


BLAGifying RedHat9
=================
The best way is with apt. You must first install apt as it doesn't come with rh9.

To install apt, run:
rpm -Uvh apt-0.5.5cnc6-4blag.rh9.i386.rpm

This will download & get your system current with latest rh9 package releases:
apt-get update
apt-get dist-upgrade

You can then install specific blag applications thusly:
apt-get install lshw mplayer audacity

etc...listing which programs you want.


You can also do it via cd, by exploring the apt-cdrom program.

jebba
PostPosted: Tue Mar 23, 2004 4:38 am    Post subject: Reply with quote

You can add blag to your /etc/apt/sources.list.d/ by adding a file there called blag.list with the contents:

rpm http://www.blagblagblag.org/ 9000/i386 os updates errata
rpm http://www.blagblagblag.org/ 9000/i386 extras

For BLAG10000 (the next major release) I plan on being as compatible with the "mega-merge" as possible. That's the combined efforts of dag/aptrpms/freshrpms/newrpms/dries. See:
http://dag.wieers.com/home-made/apt/mega-merge.php

I don't think you'll see major conflicts with them right now, just as long as you don't do a
apt-get dist-upgrade
with all of them enabled. If you're going to have a really repository-mixed box I recommend chosing the package from the "authoritative" maintainer of the mega-merge and if it's not in there grab it from BLAG.

-Jeff

Guest
PostPosted: Wed Mar 24, 2004 3:50 pm    Post subject: Reply with quote

Hi jebba!

Yesterday was a very busy day for me. I couldn't answer you before.

The two sound cards that haven't been detected were a. ENSONIC 5880 Audio PCI and b. C-Media CM 8738.

I had also troubles installing BLAG on the P 233 MMX. It was impossible to boot via CDRom. I had modified it to be able to boot from the CDRom and arrived to install both FEDORA 1 and RedHAt 9 but i just couldn't get to the CD boot to BLAG. I tried also to make a floppy with the image of BLAG but it just refuses to boot. I arrived till the first prompt (boot: ) and then a big nothing..

I intended to install the deskblag option but at no avail...

If you have any other insight I'll be very glad to try it.

By the way, I did an apt-cdrom to my home computer and got the media stuff working. Maybe it will be worthable to write some HOWTOS on the wiki's pages. Since long time I wish I could hear internet radio on in a *nix box. It works like a charm...

Cheers!

Jacques

jebba
PostPosted: Thu Mar 25, 2004 2:20 pm    Post subject: Reply with quote

I don't quite get this. You are able to get to the
boot:
prompt, but not after that? What happens if you just hit enter? Or type "deskblag" then enter? I've heard of people not being able to boot CDs on really old systems, but if they get to the "boot:" prompt, they are usually home free.

Also, I suggest burning CDs at 2x or 4x, especially when they are going to be used on an older system.

jebba
PostPosted: Fri Mar 26, 2004 4:44 pm    Post subject: Reply with quote

BLAG iso's are make with the same mkisofs command used to build RH9.

One difference is that the BLAG .iso is for a 700 meg CD, but RH9 is for 650 meg CDs. It could be that your (old?) cdrom drive can't read 700 meg discs. That's sort of a shot in the dark, but it's about the only difference I can think of.

Do I understand correctly that the CD works fine though when you boot from floppy? If it does, then it means the above doesn't apply and there is something else going on. If it doesn't work when you boot from floppy either, then it could be the disk size issue. What kind of CDROM drive do you have? You can find out info about it by running `dmesg` or `lshw`.

Thanks,

-Jeff

Jason
PostPosted: Fri Mar 26, 2004 6:10 pm    Post subject: Reply with quote

Perhaps it has been burned wrong? Sometimes the ISO is burned as a data file rather than an image. If you use Windows with Nero, then you need to click File > Burn Image rather than just dragging it from the right pane to the left.

Also I have to burn my CD's at 8x or under to get them to read in my older machines. So maybe you have burned yours at a higher speed? I would be happy to mail you a fully working and tested CD if you want.

jebba
PostPosted: Sat Mar 27, 2004 10:02 am    Post subject: Reply with quote

If knoppix is using 650+ megs on that system, then it can read 700 meg CDs fine.

If you can read the CD in other computers, it is likely burned fine.

Sooo....The answer is I don't have an answer.

I didn't see what kind of drive it is in the dmesg. But the dmesg looks OK. Also, it's a 12x drive, so it's recent enough.

a bit perplexed on this one,

-Jeff (who will think about this throughout the day!)

jebba
PostPosted: Sat Mar 27, 2004 8:07 pm    Post subject: Reply with quote

Ok, the magic line I was looking for was:
hdc: MATSHITA CR-584, ATAPI CD/DVD-ROM drive

There's a bit about that drive having a problem booting FreeBSD too:
http://berklix.com/~jhs/free/labels/boot.html

Is the media you used CD-R/W instead of just CD-R? If so, try CD-R media instead.

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> open discussion Goto page 1, 2  Next
Page 1 of 2

Protected by Anti-Spam ACP