FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Can't mount CD ROM

Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
PostPosted: Fri Sep 17, 2004 11:34 am    Post subject: Can't mount CD ROM Reply with quote

Sorry, back with more questions.

Like it says, I can't seem to mount a CDROM - the disk and drive should be ok, as they are the ones used to do the installation. The drive is a Samsung unit with the regular IDE interface.

If I use the user mount tool from the system tools menu, it comes back with an error - mount: not a directory. The entries there for CDROM are /dev/cdrom /mnt/cdrom

Trying manually from a terminal (straight from booting, no previous attempt to mount the CD):

[steve@localhost steve]$ mount /dev/cdrom /mnt/cdrom
mount: only root can do that
[steve@localhost steve]$ su
[root@localhost steve]# mount /dev/cdrom /mnt/cdrom
/dev/cdrom: Input/output error
mount: block device /dev/cdrom is write-protected, mounting read-only
/dev/cdrom: Input/output error
mount: /dev/cdrom already mounted or /mnt/cdrom busy
[root@localhost steve]#

heres /etc/fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hdb3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

Any suggestions please?



PostPosted: Fri Sep 17, 2004 12:30 pm    Post subject: Reply with quote

well,thats odd....I can usually mount a cdrom as a user by typing in this

mount /mnt/cdrom

It should work fine....probably the mount tool was still using that device...I hate when that happens. But anyway you should be able to mount a cdrom as a user.

PostPosted: Fri Sep 17, 2004 4:33 pm    Post subject: Reply with quote

I'm used that working on my SuSE box, but on this one all I get is:

[steve@localhost steve]$ mount /mnt/cdrom
<very long delay>
mount: Not a directory
[steve@localhost steve]$


PostPosted: Fri Sep 17, 2004 9:51 pm    Post subject: Reply with quote

Have you tried different CDs? Try some of these:

mount /dev/hdd /mnt/cdrom
mount /dev/scd0 /mnt/cdrom

Substitute your CD drive for /dev/hdd (e.g. /dev/hdc or /dev/hdb).

Also, is it a burner? Is there a line in /etc/grub.conf with "ide-scsi" in it?


PostPosted: Fri Sep 17, 2004 11:33 pm    Post subject: Reply with quote

Perhaps a silly suggestion but does the folder cdrom even exist in the /mnt folder? It is easy to overlook these things.
PostPosted: Fri Sep 17, 2004 11:46 pm    Post subject: Reply with quote

Hmm. This is a bit weird. Two folks can't mount CDs suddenly. Hmm. You're running 10k though, right? I think the other user is using 20k.
PostPosted: Sat Sep 18, 2004 8:14 am    Post subject: Reply with quote

Responding to several posts:

/mnt/cdrom does exist as a directory. Owner is root, all others have read and execute permissions.

I'm running 10k - as an experiment trying to sort out the SCSI stuff, I did try installing the latest 20k (v00081) but it stalled after the initial isolinux load, saying that it couldn't find a valid blag CD in the drive. Maybe that's linked? I can read that CD fine on other computers.

Tried mount /dev/hdc /mnt/cdrom, and got the dialog from my earlier post starting with 'only root can do that'...

/dev/scd0 doesn't work - not a valid block device.

The drive is not a burner. There's no 'ide-scsi' reference in grub. Here's grub.conf:

# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdb2
# initrd /initrd-version.img
title "BLAG" (2.4.22-1.2188.nptl)
root (hd0,0)
kernel /vmlinuz-2.4.22-1.2188.nptl ro root=LABEL=/ rhgb
initrd /initrd-2.4.22-1.2188.nptl.img

Thanks for the inputs.


PostPosted: Fri Sep 24, 2004 10:51 am    Post subject: Reply with quote

Try to add "user" in device description in fstab, that allows everyone to mount/umount cdrom with uninstalling the gnome automount tool.
If you are running Gnome, the automount tool was buggy and with no utility because you can mount/umount listed devices in fstab by rightclicking on desktop (Gnome).

PostPosted: Wed Sep 29, 2004 10:45 am    Post subject: Reply with quote

I think I might have tried that - I tried so many things I can'r remember any more! I've come to the conclusion that there's something wierd either all in the motherboard, or between the motherboard and the particular Samsung CDROM drive. I hooked up an old Mitumi X8 drive and it works fine under Blag with the Gnome automounter, desktop right click thingy and command line. I wanted to use this computer to experiment with different Linux versions, but the others I've tried can't find either brand of CDROM for installation after the initial boot.

I think it's time to cut my losses.



PostPosted: Wed Sep 29, 2004 1:00 pm    Post subject: Reply with quote

Just a quick suggestion, did you check the jumpers? Sometimes you have to change to slave or cable select to get it run right, sometimes doing a straight slave off the hard drive my experience some cdroms are a bit flakey on some boards Just a suggestion you may have all ready this tryed it though... :)
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP