FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Nvidia Desktop Effects

 
Post new topic   Reply to topic    BLAG Forum Index -> non-free
View previous topic :: View next topic  
Author Message
mypulitzer
PostPosted: Fri Nov 30, 2007 9:38 pm    Post subject: Nvidia Desktop Effects Reply with quote

So, I've searched the forums and found similar questions to the one I have, but nothing that has been able to solve my problem. I have a Nvidia graphics card and have installed Nvidia's driver on BLAG without a problem. Now that I've installed it, I figured I'd be able to enable advanced desktop effects via compiz, but when I click enable desktop effects I am still getting the message that the effects cannot be enabled. I'm using the nvidia-Vendor-supplied driver for nvidia cards under the hardware settings of display. I'm guessing there might be something I need to edit in the config file, so if anyone would be so kind as to let me know what might need to be edited or done, or just to point me in the direction of an online tutorial, I would be most gracious. Also, I'm somewhat of a linux newbie so exact terminal commands help.

Thank you.

john maclean
PostPosted: Fri Nov 30, 2007 11:54 pm    Post subject: Reply with quote

We could start by finding out exactly what device(s) you have. This is an example tp find out what device(s) you may have.
Code:
 /sbin/lspci | grep -i dis
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)


The "dis" part is just there to try to extract only what we require, which is the graphics part.


_________________
BLAG 'em up!
mypulitzer
PostPosted: Sat Dec 01, 2007 12:06 am    Post subject: Reply with quote

Well, thanks for the quick response, but it turns out that a little more google research did the trick for me.

I edited my xorg.conf as such, and now the desktop effects are working:

Section "Module"
Load "glx"
Load "extmod"
EndSection
...
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "RenderAccel" "True"
Option "NoLogo" "True"
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite"
EndSection

I don't know if all this editing was necessary (I did it one addition at a time until it finally worked), but something must be right :) I have a feeling the Load "extmod" did the trick though.

john maclean
PostPosted: Sat Dec 01, 2007 12:12 am    Post subject: Reply with quote

Glad you are sorted. You know how to change this file back to it's original state[1]?

[1] just in case..


_________________
BLAG 'em up!
mypulitzer
PostPosted: Sat Dec 01, 2007 12:19 am    Post subject: Reply with quote

john maclean wrote:
Glad you are sorted. You know how to change this file back to it's original state[1]?

[1] just in case..


I have no clue...is there a simple way to do so?

edit: also, I'm familiar with the compiz manager ubuntu uses, but not quite so with the one I retrieved from add/remove software in BLAG - is there anyway to get the manager used in ubuntu, or does BLAG only use the alternative "gset-compiz - 0.3.4-0blag.fc5.i386"?

john maclean
PostPosted: Sat Dec 01, 2007 12:36 am    Post subject: Reply with quote

simple .just cp /path/to/file /path/to/file.orig then you edit the first file knowing that .orig is the original. Files don't really need extensions so you can call the back up what you like.

_________________
BLAG 'em up!
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> non-free
Page 1 of 1

Protected by Anti-Spam ACP