FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Games only come up in "boxed" screen
Goto page 1, 2  Next
 
Post new topic   Reply to topic    BLAG Forum Index -> non-free
View previous topic :: View next topic  
Author Message
Saint of Killers
PostPosted: Tue Feb 05, 2008 6:49 am    Post subject: Games only come up in "boxed" screen Reply with quote

Hello again. Great distro. Everything seems fine, but I needed to install the NVIDIA driver for 3D accel for games, and installed that fine with a bit of research, all runs fine. Thing is, when I open up a game, be it Penguin Command, or Unreal Tournament , the window for the game appears to be about only half size, leaving the surrounding half of the screen black. The window shows fine, and everything displays wonderfully clear, but for some reason only seems to use half of the screen, and this is quite annoying. Below is a copy of my /etc/X11/xorg.conf


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Dec 13 19:09:35 PST 2007

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "Monitor 1600x1200"
HorizSync 31.5 - 94.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1920x1440" "1600x1200" "1280x1024" "1024x768"
EndSubSection
EndSection


-----------------

I'm about average in my linux knowledge, mainly general stuff, and normally get by. Never had quite this issue before, so not quite sure where I should look. Cannot see anything obvious, but then I'm not sure what I need to look for. Any help is appreciated. Thanks in advance. :)

gr00ve
PostPosted: Tue Feb 05, 2008 6:12 pm    Post subject: Reply with quote

run nvidia-settings as root, and in this screen set the resolution + refresh rate the game uses when it runs in black box.
play around with refresh rate setting until the screen is expanded or alternatively/in addition to that resize your actual screen to this resolution (it will resize back to previous state once different resolution applied)
there could be a chance that the setting which causes "black box" might be either refresh rate outside of what your monitor can handle, or from the vid card side it might be the resolution which card can not handle.

Saint of Killers
PostPosted: Thu Feb 07, 2008 12:01 pm    Post subject: Reply with quote

This only occurs while the game is running tho, once the game is closed, such as Penguin-Command, the view occupies the full-screen again, no black. When the game runs, only the middle half of the screen is being used, the outer-half is black. So changing the resolution does nothing., I appreciate the advice, but it doesn't seem to have any bearing on what it's doing. Perhaps I did not explain myself clearly enough.
gr00ve
PostPosted: Thu Feb 07, 2008 2:30 pm    Post subject: Reply with quote

if tremulous looks something like this, it means you didn't set resolution in game, just connect to any server or start new server - escape - options - set either 1024x768 or 1280x1024.
Saint of Killers
PostPosted: Thu Feb 07, 2008 3:27 pm    Post subject: Reply with quote

No, I have only tried it with Penguin-Command (I miss Missile-Command from when I was a kid:p) and Unreal Tournament, and the ratios are fine, and the resolution seems fine, but everything is shrunk down to about half size, the outer-half of the screen being black, as tho the video boundary does not extend that far, and the game is confined to the centre half of the screen.

There is no option in Missile Command to change this, and it has not been a problem in the other 2 distros I run, PCLinuxOS and Debian Etch. Both games run fine there, but something is screwing with the video here. The full game is on screen, but confined to the centre half of the screen. I'm sorry if I'm not explaining it well, I just can't seem to see why this is occurring.

gr00ve
PostPosted: Thu Feb 07, 2008 5:02 pm    Post subject: Reply with quote

so what happens when you set your screen resolution to be same as "in game" resolution (prior to starting the game) - still a black box?

ps << never had any problems with ut or any other game resolution/black box wise.

Saint of Killers
PostPosted: Fri Mar 07, 2008 3:40 am    Post subject: Reply with quote

I ended up logging in as root temporarily, then running the nvidia config menu, setting the resolution and refresh rate there, saving it, then logging out and back in as user. This seems to have fixed it, and allowed me to play things in full-screen. Thanks for your assistance guys. :)
s6k
PostPosted: Sun Mar 09, 2008 4:28 pm    Post subject: Reply with quote

I have a similar problem I have changed my driver to the NVIDIA dr iver and now when I click on Tremulous my computer goes black and read it cannot support the resolution and read that my optimum resolution is 1680x1050 I also have a problem logging on to my non user account I posted a new topic on as "screen Resolution Error"
he is my x-config any help is appreaciated
Xorg configuration created by system-config-display

Code:
 Xorg configuration created by system-config-display

Section "ServerLayout"
   Identifier     "single head configuration"
   Screen      0  "Screen0" 0 0
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option       "XkbModel" "pc105"
   Option       "XkbLayout" "us"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   ModelName    "DELL E207WFP"
   HorizSync    30.0 - 83.0
   VertRefresh  56.0 - 75.0
   Option       "dpms"
EndSection

Section "Device"
   Identifier  "Videocard0"
   Driver      "nvidia"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Videocard0"
   Monitor    "Monitor0"
   DefaultDepth     24
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes    "1680x1050" "1280x1024" "1280x960" "1280x800" "1280x768" "1280x720" "1152x864" "1024x768" "832x624" "800x600" "640x480" "640x400"
   EndSubSection
EndSection

gr00ve
PostPosted: Mon Mar 10, 2008 1:08 am    Post subject: Reply with quote

comment out Option "dpms" & remove all resolutions except 1680x1050

PS Dell - ha ha ha ha ha ha ha... :P

s6k
PostPosted: Mon Mar 10, 2008 1:37 am    Post subject: Reply with quote

gr00ve wrote:
comment out Option "dpms" & remove all resolutions except 1680x1050

PS Dell - ha ha ha ha ha ha ha... :P

Thanks again for helping heres the change but I still have the same problem

x config reads

nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Feb 14 18:21:33 PST 2008

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL E207WFP"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150 LE"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "nvidia-auto-select +0+0; 1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
yeah dell, I have a 1 year old dell PC that I deleted windows from a few months back. at the time it was cheaper than building my own with the 20 " plat panel monitor included

weyasey
PostPosted: Mon Mar 10, 2008 2:15 am    Post subject: Reply with quote

You did not comment out Option "dpms"

try doing as the post said and see if it works, make a backup of your Xorg config before doing any changes....just to be on the safe side ;)


_________________
If it hurts it's because you're alive.
s6k
PostPosted: Mon Mar 10, 2008 2:57 am    Post subject: Reply with quote

ok I am a tardo what does "comment out Option "dpms" " mean? also on the other post you left some instructions could you please elaborate as well
thanks
//sunny//

Saint of Killers
PostPosted: Mon Mar 10, 2008 3:24 am    Post subject: Reply with quote

s6k wrote:
ok I am a tardo what does "comment out Option "dpms" " mean? also on the other post you left some instructions could you please elaborate as well
thanks
//sunny//


To comment something out, you put a hash # in front of it, that tells the OS to ignore what comes after it.

john maclean
PostPosted: Mon Mar 10, 2008 3:31 am    Post subject: Reply with quote

If you put a # as the first character on the line then the text on that line is not processed as a command. It's ignored and is not run by the box. So just put a "#" character at the start of the line where Option "dpms" is in that and save it.

Code:
#Section "Monitor"                                                                                                                                                       
#        Identifier      "Generic Monitor"                                                                                                                               
#        Option          "DPMS"                                                                                                                                           
#        HorizSync       28-51                                                                                                                                           
#        VertRefresh     43-60                                                                                                                                           
#EndSection         

I've just commented out a section of code.


_________________
BLAG 'em up!
s6k
PostPosted: Mon Mar 10, 2008 3:51 am    Post subject: Reply with quote

i commented out the # Option "dpms" but I still have the same problem when i selected super tux the game my screen went black and and my monitor read "can not display mode optimum resolution 1680x1050" this also happens when i log in to my non root account as well
here is my x config
thanks for the help
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Thu Feb 14 18:21:33 PST 2008

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL E207WFP"
HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0
# Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 6150 LE"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "nvidia-auto-select +0+0; 1680x1050 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> non-free Goto page 1, 2  Next
Page 1 of 2

Protected by Anti-Spam ACP