FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
dell 1390/broadcom 4311 wifi issues

Post new topic   Reply to topic    BLAG Forum Index -> non-free
View previous topic :: View next topic  
Author Message
PostPosted: Mon May 26, 2008 3:39 am    Post subject: dell 1390/broadcom 4311 wifi issues Reply with quote

I've gotten nearly all must-haves working on my laptop with BLAG 70k 2.6.24. Only wireless remains, and it's the painful bcm4311 chipset on the Dell 1390 mini-pci wireless card.

I have a HP dv6605us dual booted with XP SP3. I've tried both ndiswrapper and bcm43xx/b43-fwcutter to no avail. I'm not sure I'm correctly doing the fwcutter method, as I am still fuzzy on exactly how the system loads the firmware, but the ndiswrapper goes perfectly smooth until it comes to actually using the connection.

With ndiswrapper I have used the driver they have on the site under my listing in the supported device list as well as the one that is running the wifi on my install of XP. Both install fine, depmod -a doesn't complain, the device is seen (-l returns: driver installed and device (14E4:4311) present), I put alias wlan0 ndiswrapper in /etc/modprobe.conf, which shows up in network configuration. When I try to use it it says the device is not there with either driver. The light never turns blue, reboot or not.

With the fwcutter I've used the default 006 version and pulled the fw from the .sys file on my XP partition, as well as from a wl_apst.o file, which is supposed to be newer. I've had both in the /lib/firmware folder (at different times) but using modprobe I can't see any sort of bcm or broadcom modules, even after reboot. I've been reading quite a few sites and they all seem to imply that modprobing and rebooting will make the system load the firmware up... Is that correct? When I look, the system identifies it as Broadcom Dell 1390 Wireless Mini-PCI card in network config.

I've also tried upgrading to fwcutter 011 and trying the b43 drivers, but same thing... no response.

I think something strange might be going on, as the network config gui keeps telling me that eth0, the wired connection, is using the Broadcom/Dell hardware when it's using the nvidia chipset LAN, but I dont want to re-install and have to update and customize all over again...

Thanks for any help.

PostPosted: Mon May 26, 2008 3:48 am    Post subject: Reply with quote

Sorry, booting to slaveware.

Something on this list may work better:


PostPosted: Mon May 26, 2008 4:56 am    Post subject: Reply with quote

Opps, i'm sorry. Thanks for the move.
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> non-free
Page 1 of 1

Protected by Anti-Spam ACP