FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Synaptic Package Manager

 
Post new topic   Reply to topic    BLAG Forum Index -> development
View previous topic :: View next topic  
Author Message
hoppy72
PostPosted: Sat Jul 12, 2008 12:25 am    Post subject: Synaptic Package Manager Reply with quote

I installed 90k alpha because I love dealing with stuff I know nothing about. When I reloaded synaptic, it came back with a warning of 11 broken packages. I ran the "fix broken packages and tried to update. It came back with a 4 broken packages warning and I again ran "fix broken packages". I then clicked on the apply changes and it returned the following errors when trying to apply changes:

APT system reports:
Checking GPG signatures...
%% 25.000000
%% 50.000000
%% 75.000000
%% 100.000000
E: Unknown signature /var/cache/apt/archives/lockdev-1.0.1-12.fc9.1.i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#4f2a6fd2)
E: Unknown signature /var/cache/apt/archives/gphoto2-2.4.0-10.fc9.i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#4f2a6fd2)
E: Unknown signature /var/cache/apt/archives/gvfs-0.2.3-11.fc9.i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#4f2a6fd2)
E: Unknown signature /var/cache/apt/archives/bluez-gnome-0.26-1.fc9.i386.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#4f2a6fd2)
E: Error(s) while checking package signatures:
0 unsigned package(s)
4 package(s) with unknown signatures
0 package(s) with illegal/corrupted signatures

I ran "fix broken packages" one more time simply because I didn't know what else to do. I got the same error message obviously. I realize that I shouldn't be messing around with an alpha distro unless I know what I'm doing, but thought I'd pass this error along in the hope it proves useful to the developers.

jebba
PostPosted: Sat Jul 12, 2008 1:00 am    Post subject: Reply with quote

The fix broken packages is a known bug in 89999.42222. I dont think it happens with yum however. Apt and yum calculate the dependencies different. Does `yum update` work ok?

The next CD I roll i'll definitely fix this.

As for the GPG, you need to uncomment the GPG line in /etc/apt/apt.conf. ahem....

hoppy72
PostPosted: Sat Jul 12, 2008 3:20 am    Post subject: Reply with quote

My yum works fine and I uncommented the GPG line in /etc/apt/apt-conf, but it still doesn't let me install or update anything.
hoppy72
PostPosted: Sat Jul 12, 2008 3:28 am    Post subject: Reply with quote

I just ran into another interesting error that when I go to "Places" on my panel and click on Home Folder, I get the following error:

Could not open location 'file:///home/nhigh' (the correct home folder for me)
No application is registered as handling this file

Don't know if the two problems are connected or not. My yum, however, has full function and I can update, install, remove packages, etc.

jebba
PostPosted: Sat Jul 12, 2008 4:01 am    Post subject: Reply with quote

hoppy72 wrote:
I just ran into another interesting error that when I go to "Places" on my panel and click on Home Folder, I get the following error:

Could not open location 'file:///home/nhigh' (the correct home folder for me)
No application is registered as handling this file

Don't know if the two problems are connected or not. My yum, however, has full function and I can update, install, remove packages, etc.


The problems are not related.

But it may be that gnome-mimetypes or something is missing. I really stripped things down so we need to track down missing bits like that. :)

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> development
Page 1 of 1

Protected by Anti-Spam ACP