FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
gpodder 0.11.3 or earlier : import gtk failure

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
ririkourou94
PostPosted: Thu Jun 26, 2008 5:18 pm    Post subject: gpodder 0.11.3 or earlier : import gtk failure Reply with quote

My computer : Mac Book Pro
My favorite distro : GNU/Linux BLAG 60001
My podacast client : gpodder

gpodder version provided by BLAG is 0.9.0 release.

I did updated gpodder with 0.11.1 release (tar.gz archive) sucessfully a couple of weeks ago. It has been working like a charm since 22nd June when I decided to install gpodder 0.11.3 (the latest release) : unfortunately, when I launched gpodder with the graphical menu launcher, nothing happened. I therefore tried 'make test' to get some information (I could alternatively have launched manually the installed version by typing /usr/bin/gpodder in an xterm window) :
[root@lns-bzn-54-82-251-117-86 gpodder-0.11.3]# make test
bin/gpodder --local --verbose
Traceback (most recent call last):
File "bin/gpodder", line 166, in
sys.exit( main())
File "bin/gpodder", line 125, in main
from gpodder import console
File "/opt/gpodder-0.11.3/src/gpodder/console.py", line 20, in
from gpodder import util
File "/opt/gpodder-0.11.3/src/gpodder/util.py", line 35, in
import gtk
ImportError: No module named gtk
make: *** [test] Error 1
[root@lns-bzn-54-82-251-117-86 gpodder-0.11.3]#

I've also tried "python setup.py install", instead of "make install". But gpodder does not start, reporting the same "gtk" error.


I then tried to revert to gpodder 0.11.1, because this version had been working fine. But unfortunately, now, irrespective of the gpodder version I install (from 0.9.5 to 0.11.3) I always got the "ImportError: No module named gtk" error. I've re-installed python and pygtk2 this evening. It did not fix the problem. I've carefully checked the presence of the mandatory dependencies, just in case I would have make a mistake at some stage.
Thanks for your help. I've tried to find tips&hints on the web , quite extensively, but no one is ok.

Kind regards

Eric

Kind regards

Eric

jebba
PostPosted: Thu Jun 26, 2008 5:39 pm    Post subject: Reply with quote

Do you have gtk and/or gtk2 installed?
ririkourou94
PostPosted: Thu Jun 26, 2008 6:02 pm    Post subject: Reply with quote

jebba wrote:
Do you have gtk and/or gtk2 installed?


gtk+, gtk+-devel, gtk2, gtk2-devel, gtkdatabox, gtk+extra .......

This small test proves that pygtk is not properly installed :

[root@localhost ~]# python
Python 2.5.2 (r252:60911, Apr 6 2008, 13:45:29)
[GCC 4.1.2 20070626 (Red Hat 4.1.2-13)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pygtk; pygtk.require('2.0')
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named pygtk
>>> import gtk
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named gtk
>>>

As gpodder 0.11.1 used to work fine, I thought that all *gtk* stuff was ok.

I could send you the result of 'rpm -qa' command. thanks

Eric

ririkourou94
PostPosted: Sat Jul 12, 2008 5:25 pm    Post subject: Reply with quote

I've decided to erase my BLAG60001 partition. Then I've re-installed Blag 60001 from my installation CD-ROM. Obviously, the problem is fixed. I'm using gpodder 0.11.3.
Post can be CLOSED.

jebba
PostPosted: Sat Jul 12, 2008 5:29 pm    Post subject: Reply with quote

Glad you solved it.

FWIW, the 60001 release is quite old at this point (even our "stable" release is getting a bit ancient at the moment). ...

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP