FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
wireless module problem
Goto page 1, 2  Next
 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
ewl
PostPosted: Tue Jul 22, 2008 7:40 pm    Post subject: wireless module problem Reply with quote

I'm having trouble compiling the module for my wireless card. I need rt61, rt61pci doesn't work right. Here's the error I get after "make:"
make[1]: Entering directory `/usr/src/kernels/2.6.25.10-libre.86.fc9.1.i686'
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_main.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/mlme.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/connect.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/sync.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/assoc.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/auth.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/auth_rsp.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_data.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_init.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/sanity.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_wep.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/wpa.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/md5.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_tkip.o
CC [M] /home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.o
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c: In function ‘rt_ioctl_giwscan’:
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1926: warning: passing argument 1 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1926: warning: passing argument 3 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1926: warning: passing argument 4 of ‘iwe_stream_add_event’ makes pointer from integer without a cast
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1926: error: too few arguments to function ‘iwe_stream_add_event’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1940: warning: passing argument 1 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1940: warning: passing argument 3 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1940: warning: passing argument 4 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1940: error: too few arguments to function ‘iwe_stream_add_point’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1961: warning: passing argument 1 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1961: warning: passing argument 3 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1961: warning: passing argument 4 of ‘iwe_stream_add_event’ makes pointer from integer without a cast
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1961: error: too few arguments to function ‘iwe_stream_add_event’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1979: warning: passing argument 1 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1979: warning: passing argument 3 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1979: warning: passing argument 4 of ‘iwe_stream_add_event’ makes pointer from integer without a cast
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1979: error: too few arguments to function ‘iwe_stream_add_event’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1996: warning: passing argument 1 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1996: warning: passing argument 3 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1996: warning: passing argument 4 of ‘iwe_stream_add_point’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:1996: error: too few arguments to function ‘iwe_stream_add_point’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2015: warning: passing argument 1 of ‘iwe_stream_add_value’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2015: warning: passing argument 4 of ‘iwe_stream_add_value’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2015: warning: passing argument 5 of ‘iwe_stream_add_value’ makes pointer from integer without a cast
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2015: error: too few arguments to function ‘iwe_stream_add_value’
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2138: warning: passing argument 1 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2138: warning: passing argument 3 of ‘iwe_stream_add_event’ from incompatible pointer type
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2138: warning: passing argument 4 of ‘iwe_stream_add_event’ makes pointer from integer without a cast
/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.c:2138: error: too few arguments to function ‘iwe_stream_add_event’
make[2]: *** [/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module/rtmp_info.o] Error 1
make[1]: *** [_module_/home/ewl/ubu/lwe2/Desktop/rt61-cvs-2008071522/Module] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.25.10-libre.86.fc9.1.i686'
rt61.ko failed to build!
make: *** [module] Error 1
[root@cambot Module]#


_________________
Ed LaBonte
jebba
PostPosted: Tue Jul 22, 2008 8:47 pm    Post subject: Reply with quote

Hmm, no clue offhand, but it doesnt look like anything blag specific. I'd suggest asking upstream where you got the code from.
john maclean
PostPosted: Tue Jul 22, 2008 10:36 pm    Post subject: Reply with quote

what's the device and where did you get the source from?

_________________
BLAG 'em up!
ewl
PostPosted: Tue Jul 22, 2008 11:58 pm    Post subject: Reply with quote

It's an edimax pci card wireless. I downloaded it from " http://rt2x00.serialmonkey.com/wiki/index.php?title=Downloads ". It works with other distros, I don't know about fedora 9.

_________________
Ed LaBonte
jebba
PostPosted: Wed Jul 23, 2008 12:03 am    Post subject: Reply with quote

Did you try this driver? Its in the kernel shipped in blag90k. If that doesn't work for you we should figure that out instead of figuring out how to get your own one built (?)>

rt61pci.ko

datman
PostPosted: Wed Jul 23, 2008 3:55 am    Post subject: Wireless Problem Reply with quote

You said the rt61pci didn't work correctly, right? Can you connect at all with it? Can you set the access point, or do you not need one? Does it try to start? Have you tried researching the problem on the serialmonkey forums?

I have a similar problem with the rt2500pci module. It hasn't worked for me in Fedora 9 or Blag since about kernel 2.6.25.4. It tries to start but fails, and I can't set an access point. So, I'm using a 2.6.25.2-libre.7.fc10.i686 kernel in both places and hoping for a fix. Don't know whether it's a kernel module problem, or changes in the configuration tools. Do know that my card works fine with no change in configuration just by booting the older kernel.

Also trying to compile recent cvs sources for the legacy driver, same as you, with the same "error: too few arguments to function ......." . Wonder if that may be related to the versions of gcc and glibc we're using.

Know this is not an answer, but at least you know you are not alone.

Good luck.

datman

klhrevolutionist
PostPosted: Thu Jul 24, 2008 3:09 am    Post subject: Reply with quote

From a pal living on a volcano here is a howto:

Download http://www.ralinktech.com.tw/data/RT61_Firmware_V1.2.zip, unzip it and place the *.bin files under /lib/firmware/.

Of course 90001 might have corrected this..

jebba
PostPosted: Thu Jul 24, 2008 6:45 am    Post subject: Reply with quote

klhrevolutionist wrote:
Of course 90001 might have corrected this..


It's not something we'd "correct" because we don't ship non-free firmware. It's a "policy" decision...

klhrevolutionist
PostPosted: Thu Jul 24, 2008 10:15 pm    Post subject: Reply with quote

I figured it was done by design, I have to admit I was not sure or not cause I'm no expert in this area.

I fully support the kernel-libre! And I hope your time & dedication will spur more activity in this direction. I think it is long over due & time.

ewl
PostPosted: Thu Jul 24, 2008 11:55 pm    Post subject: Reply with quote

I don't think it's linux-libre because I just tried out fedora 9 and I had the same problem with that, at least as far as compiling the rt61 module is concerned. But I was able to get the rt61pci module working with fedora. But the same module is available in linux-libre, so I don't know what the problem could be.

_________________
Ed LaBonte
datman
PostPosted: Fri Jul 25, 2008 7:20 pm    Post subject: wireless module problem Reply with quote

Glad to hear you got the rt61pci module working under fedora 9. May I ask what version kernel you were using? And how did you configure wireless - manually, system-config-network, or network-manager? Does iwconfig show an access point?
You should be able to install the exact same kernel rpm under blag, and theoretically, networking would work there also.
Thanks.

datman

jebba
PostPosted: Wed Aug 27, 2008 6:08 am    Post subject: Reply with quote

I am seeing the same error as originaly post compiling a module under 90k. It appears Fedora backported a number of wifi things "early" so this caused a bit of chaos (e.g. drivers look and think they have 2.6.25 kernel, but really have some 2.6.27rc stuff)...
datman
PostPosted: Thu Sep 04, 2008 7:29 pm    Post subject: Wireless Module Problem Reply with quote

Thanks to a recent update to the ralink legacy cvs sources which accommodated changes in gcc/glibc, I am now able to compile a working rt2500 module under FC10 alpha. Have not tried it under BLAG 90K yet but should work. Still unable to connect using the distributed kernel support for this wifi since about 2.6.25-4. Perhaps the rt61 legacy source has been updated also.
ewl
PostPosted: Sat Sep 27, 2008 8:37 pm    Post subject: Reply with quote

I finally got it to work. I reinstalled 90k and updated it to 90001 and the module for rt61 compiled. So I added rt61pci to /etc/module.d/blacklist and it seems to work. But it won't connect with the Network Manager applet, I have to go to System > Adminstration > Network and start it from there. It might have something to do with the fact that there are no options in Network Manager applet for 64 bit wep. I tried putting the hexadecimal code in at the Wep 128 bit hexadecimal entry, but it didn't connect.

Anyway, I've got it working... :)


_________________
Ed LaBonte
ewl
PostPosted: Sat Sep 27, 2008 11:59 pm    Post subject: Reply with quote

One little glitch. I stopped Network Manager applet from starting with the Gnome Session. Firefox and epiphany have a bug where they check to see if Network Manager has a connection. If not, they start up in Offline mode. I googled around and couldn't find a good work around, so I've switched to seamonkey.

_________________
Ed LaBonte
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support Goto page 1, 2  Next
Page 1 of 2

Protected by Anti-Spam ACP