BLAG

BLAG Forums
It is currently Sat Dec 20, 2014 11:07 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sun Aug 10, 2008 7:13 pm 
Offline

Joined: Sat Aug 09, 2008 1:48 pm
Posts: 3
Hello,

First of all I apologize for my poor English, I am Italian and it has long time since I have used to write English.

I installed BLAG 90k on an old pci, for a friend of mine. It is the only distro I was able to install (other distros don't function, they stop for kernel panic or, in any case, they can't work X) and it works fine.

I have only a problem. No sound at all. The audio controller is 82801 EB/ER (ICH5/ICH5R) Intel.
I found on Fedora forum (How to) there is a problem with Intel audio controller and a workaround for it.

Code:
1)Add atrpms repo for sound . Include only necessary packages alsa-driver and alsa-kmdl

2)Install alsa-driver and alsa-kmdl
yum install alsa-driver alsa-kmdl-`uname -r`

3)To get sound working after suspend
cat /etc/pm/config.d/unload_modules

SUSPEND_MODULES=”snd_hda_intel”

chmod +x  /etc/pm/config.d/unload_modules

4) Reboot


Can I use on Blag?

Thanks in advance.

Maria Teresa


Last edited by mariateresa53 on Mon Aug 11, 2008 11:50 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: no sound BLAG 90 k
PostPosted: Sun Aug 10, 2008 7:17 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
mariateresa53 wrote:
Hello,

First of all I apologize for my poor English, I am Italian and it has long time since I have used to write English.

I installed BLAG 90k on an old pci, for a friend of mine. It is the only distro I was able to install (other distros don't function, they stop for kernel panic or, in any case, they can't work X) and it works fine.

I have only a problem. No sound at all. The audio controller is 82801 EB/ER (ICH5/ICH5R) Intel.
I found on Fedora forum (How to) there is a problem with Intel audio controller and a workaround for it.

Code:
1)Add atrpms repo for sound . Include only necessary packages alsa-driver and alsa-kmdl

2)Install alsa-driver and alsa-kmdl
yum install alsa-driver alsa-kmdl-`uname -r`

3)To get sound working after suspend
cat /etc/pm/config.d/unload_modules

SUSPEND_MODULES=”snd_hda_intel”

chmod +x  /etc/pm/config.d/unload_modules

4) Reboot


Can I use on Blag?

Thanks in advance.

Maria Teresa



You probably don't need to install anything or do any of the above tricks. Just double-click on the speaker icon in the upper right corner to bring up the mixer. Then make sure the levels are all up and ok. Like on mine it has "Front Speakers" muted all the way down. This is likely your problem--the sound card is there, it's just muted.

-Jeff


Top
 Profile  
 
 Post subject: Re: no sound BLAG 90 k
PostPosted: Mon Aug 11, 2008 8:21 am 
Offline

Joined: Sat Aug 09, 2008 1:48 pm
Posts: 3
Thank you for your reply.
I opened mixer and up all the levels, but it didn't function.
Then I set all options in
system > preferences > hardware > sound
to ALSA, then I logout and login back, but neither this function.

When I tried test I received in answer this:
Code:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink:
Could not open audio device for  playback. Device is being used by another application.


I looked Messages log and I found this
Code:
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:21:02 localhost pulseaudio[2018]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:02 localhost pulseaudio[2018]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Aug 11 09:21:23 localhost pulseaudio[2111]: pid.c: Stale PID file, overwriting.
Aug 11 09:21:23 localhost pulseaudio[2111]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:21:23 localhost pulseaudio[2111]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:21:23 localhost pulseaudio[2111]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:23 localhost pulseaudio[2111]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:25 localhost gconfd (tere-2053): Resolved address "xml:readwrite:/home/tere/.gconf" to a writable configuration source at position 0
Aug 11 09:21:26 localhost pulseaudio[2111]: module-x11-xsmp.c: X11 session manager not running.
Aug 11 09:21:26 localhost pulseaudio[2111]: module.c: Failed to load  module "module-x11-xsmp" (argument: ""): initialization failed.

Aug 11 09:26:51 localhost pulseaudio[2341]: polkit.c: Cannot set UID on session object.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:26:51 localhost pulseaudio[2341]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:26:52 localhost pulseaudio[2341]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Aug 11 09:27:03 localhost pulseaudio[2434]: pid.c: Stale PID file, overwriting.
Aug 11 09:27:03 localhost pulseaudio[2434]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:27:03 localhost pulseaudio[2434]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:27:03 localhost pulseaudio[2434]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:27:03 localhost pulseaudio[2434]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:27:05 localhost pulseaudio[2434]: module-x11-xsmp.c: X11 session manager not running.
Aug 11 09:27:05 localhost pulseaudio[2434]: module.c: Failed to load  module "module-x11-xsmp" (argument: ""): initialization failed.


I don't understand much, but it may be useful to you.

By the way yesterday I run Fedora 9 live cd on my computer where I installed Ubuntu 8.04 (Kde and Gnome, Intel 82801 ICH9 family) and I had no sound, besides with Ubuntu sound functions.

Thanks.

Maria Teresa


Top
 Profile  
 
 Post subject: Re: no sound BLAG 90 k
PostPosted: Mon Aug 11, 2008 9:01 am 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
mariateresa53 wrote:
Thank you for your reply.
I opened mixer and up all the levels, but it didn't function.
Then I set all options in
system > preferences > hardware > sound
to ALSA, then I logout and login back, but neither this function.

When I tried test I received in answer this:
Code:
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink:
Could not open audio device for  playback. Device is being used by another application.


I looked Messages log and I found this
Code:
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:21:01 localhost pulseaudio[2018]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:21:02 localhost pulseaudio[2018]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:02 localhost pulseaudio[2018]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Aug 11 09:21:23 localhost pulseaudio[2111]: pid.c: Stale PID file, overwriting.
Aug 11 09:21:23 localhost pulseaudio[2111]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:21:23 localhost pulseaudio[2111]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:21:23 localhost pulseaudio[2111]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:23 localhost pulseaudio[2111]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:21:25 localhost gconfd (tere-2053): Resolved address "xml:readwrite:/home/tere/.gconf" to a writable configuration source at position 0
Aug 11 09:21:26 localhost pulseaudio[2111]: module-x11-xsmp.c: X11 session manager not running.
Aug 11 09:21:26 localhost pulseaudio[2111]: module.c: Failed to load  module "module-x11-xsmp" (argument: ""): initialization failed.

Aug 11 09:26:51 localhost pulseaudio[2341]: polkit.c: Cannot set UID on session object.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:26:51 localhost pulseaudio[2341]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:26:51 localhost pulseaudio[2341]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:26:52 localhost pulseaudio[2341]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.

Aug 11 09:27:03 localhost pulseaudio[2434]: pid.c: Stale PID file, overwriting.
Aug 11 09:27:03 localhost pulseaudio[2434]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
Aug 11 09:27:03 localhost pulseaudio[2434]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
Aug 11 09:27:03 localhost pulseaudio[2434]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:27:03 localhost pulseaudio[2434]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Aug 11 09:27:05 localhost pulseaudio[2434]: module-x11-xsmp.c: X11 session manager not running.
Aug 11 09:27:05 localhost pulseaudio[2434]: module.c: Failed to load  module "module-x11-xsmp" (argument: ""): initialization failed.


I don't understand much, but it may be useful to you.

By the way yesterday I run Fedora 9 live cd on my computer where I installed Ubuntu 8.04 (Kde and Gnome, Intel 82801 ICH9 family) and I had no sound, besides with Ubuntu sound functions.

Thanks.

Maria Teresa



It's quite a dump there, but nothing looks out of the ordinary. The pulseaudio things you see are just because it's not doing "realtime" (which I dont think it really does anyway), so that's all just noise.

Pulseaudio "owns" the soundcard and prevents other applications from accessing it. You're "supposed" to send sound to it.

Try like this:

Code:
mplayer -ao pulse /usr/share/sounds/phone.wav
mplayer -ao alsa /usr/share/sounds/phone.wav


You should just get an error on the *second* one. If that's correct, then you definitely just have something flipped. Sometimes you have to turn off or on things like headphone jack sense and such. In sum, if it's not giving you errors, then its probably just muted somewhere!

Or you could just `killall pulseaudio` when you log in and play things directly, but that's kind of cheap ;)

-Jeff


Top
 Profile  
 
PostPosted: Mon Aug 11, 2008 11:48 am 
Offline

Joined: Sat Aug 09, 2008 1:48 pm
Posts: 3
Thanks very much for your patient. Problem solved.


Quote:
Try like this:

mplayer -ao pulse /usr/share/sounds/phone.wav
mplayer -ao alsa /usr/share/sounds/phone.wav


I did as you suggested and then sound works fine.

Thanks again for your patient.

Bye

Maria Teresa


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group