FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Blaghead update problems

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
weyasey
PostPosted: Thu Oct 23, 2008 6:51 pm    Post subject: Blaghead update problems Reply with quote

Having these dependencies issues when trying to update blaghead
Code:
xine-lib-extras-1.1.15-1.fc10.1.i386 from blag has depsolving problems
  --> Missing Dependency: xine-lib = 1.1.15-1.fc10.1 is needed by package xine-lib-extras-1.1.15-1.fc10.1.i386 (blag)
1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-base-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 (installed)
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-brand = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
xine-lib-extras-nonfree-1.1.15-1.lvn10.i386 from blag has depsolving problems
  --> Missing Dependency: xine-lib(plugin-abi) = 1.24 is needed by package xine-lib-extras-nonfree-1.1.15-1.lvn10.i386 (blag)
xine-lib-devel-1.1.15-1.fc10.1.i386 from blag has depsolving problems
  --> Missing Dependency: xine-lib = 1.1.15-1.fc10.1 is needed by package xine-lib-devel-1.1.15-1.fc10.1.i386 (blag)
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-draw-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
--> Running transaction check
---> Package xine-lib-extras.i386 0:1.1.15-1.fc10.1 set to be updated
---> Package xine-lib-extras-nonfree.i386 0:1.1.15-1.lvn10 set to be updated
--> Processing Dependency: openoffice.org-base-core = 1:3.0.0-1.1.fc10 for package: openoffice.org-report-builder
---> Package xine-lib.i386 0:1.1.15-1.fc10.1 set to be updated
---> Package xine-lib-devel.i386 0:1.1.15-1.fc10.1 set to be updated
--> Processing Dependency: openoffice.org-brand = 1:3.0.0-1.1.fc10 for package: openoffice.org-draw
--> Processing Dependency: openoffice.org-draw-core = 1:3.0.0-1.1.fc10 for package: openoffice.org-draw
--> Finished Dependency Resolution
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-brand = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-draw-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-base-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 (installed)
--> Running transaction check
--> Processing Dependency: openoffice.org-base-core = 1:3.0.0-1.1.fc10 for package: openoffice.org-report-builder
--> Processing Dependency: openoffice.org-brand = 1:3.0.0-1.1.fc10 for package: openoffice.org-draw
--> Processing Dependency: openoffice.org-draw-core = 1:3.0.0-1.1.fc10 for package: openoffice.org-draw
--> Finished Dependency Resolution
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-brand = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
1:openoffice.org-draw-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-draw-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-1.1.fc10.i386 (installed)
1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 from installed has depsolving problems
  --> Missing Dependency: openoffice.org-base-core = 1:3.0.0-1.1.fc10 is needed by package 1:openoffice.org-report-builder-3.0.0-1.1.fc10.i386 (installed)
Skip-broken could not solve problems
Error: Missing Dependency: libboost_thread-mt.so.3 is needed by package gnash-0.8.3-2.fc10.i386 (installed)
Error: Missing Dependency: pentaho-reporting-flow-engine is needed by package 1:openoffice.org-report-builder-3.0.0-9.1.fc10.i386 (blag)
Error: Missing Dependency: libboost_date_time-mt.so.3 is needed by package gnash-0.8.3-2.fc10.i386 (installed)
Error: Missing Dependency: xine-lib = 1.1.12 is needed by package xine-lib-moles-1.1.12-1.fc9.i386 (installed)
Error: Missing Dependency: openoffice.org-pdfimport = 1:3.0.0-9.1.fc10 is needed by package 1:openoffice.org-draw-3.0.0-9.1.fc10.i386 (blag)

Any chance of a fix? It's not much of a problem at the moment but it would be nice to be able to update without having these messages :)


_________________
If it hurts it's because you're alive.
jebba
PostPosted: Thu Oct 23, 2008 6:54 pm    Post subject: Reply with quote

For now run:

Code:
yum --skip-broken update



If you want to help maintain the repo lemme know... ;)

I didnt look closely at the above but i'm sure it's just a question of a new missing dep which just needs to be added to the system. I have scripts to do that i can show you how to use if you want. In freeeee it's as simple as `freeeee-package foo` and it gets added to the system. It's slightly more complex for blaghead as the upstream is known to have non-free software in it, so that has to be checked anyway...

weyasey
PostPosted: Thu Oct 23, 2008 7:25 pm    Post subject: Reply with quote

jebba wrote
Quote:
For now run:

Code:
yum --skip-broken update

The result I posted was done with yum --skip-broken update that didn't resolve the issue.

jebba wrote

Quote:
If you want to help maintain the repo lemme know... ;)


The answer to that question is...yes please, just send some instructions. If you don't have my email address shout me on irc ;)


_________________
If it hurts it's because you're alive.
jebba
PostPosted: Thu Oct 23, 2008 7:40 pm    Post subject: Reply with quote

Ya, via irc easiest to set up.
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP