FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
16/03/2009 Dowdloaded blag 90001 but no surver on line ??

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
SilverSurfer
PostPosted: Mon Mar 16, 2009 6:49 pm    Post subject: 16/03/2009 Dowdloaded blag 90001 but no surver on line ?? Reply with quote

I have just downloaded blag 90001 but I can't seem to update or add programs. I get ERROR 403 . I would have thourgh that the server would have been up by now. Or the blag software updated to fix this problem.
View user's profile

Junichirô
PostPosted: Mon Mar 16, 2009 7:31 pm    Post subject: Reply with quote

http://forums.blagblagblag.org/viewtopic.php?t=4992
SilverSurfer
PostPosted: Tue Mar 17, 2009 9:42 pm    Post subject: Hmm.. Not much hellp. Reply with quote

Thank you Junichirô for the link. Unfortunately I am not a programmer and would not know how to change the code.
renilgh
PostPosted: Tue Mar 17, 2009 10:15 pm    Post subject: Reply with quote

Don't worry, you just need to change the text in a textfile.
You can use any texteditor to do this. I will use a very simple one, nano in the example. If you want something graphical it should be possible to use gedit. Just replace the 'nano -w' in the following description with any texteditor you want to use, e.g. gedit, emacs, vim....

Okay, here we go:

Open a terminal, become root by typing 'su' and entering the root password when prompted.
Type
Code:

nano -w /etc/yum.repos.d/blag.repo


The text editor nano now displays the file at /etc/yum.repos.d/blag.repo and wraps lines if they are too long for the screen (-w).

It should look something like

Code:

[blag]
name=BLAG
baseurl=http://blagblagblag.org/something/BLAG/linux/90000/en/os/i386/BLAG
enabled=1
gpgcheck=0


Since the repository at blagblagblag.org is down we simply need to change the baseurl.
Navigate to the baseurl line and change it to

Code:

baseurl=ftp://therion.noldrin.com/pub/BLAG/linux/90000/en/os/i386/BLAG


Now we just need to save the changes. If you're using nano, press ctrl+X (you can see various commands on the bottom of the screen with ^ indicating ctrl) and answer yes when asked if you want to save the changes to the file.

We're done. Running 'yum check-update' 'yum update' or 'yum upgrade' should give you lots of updates now.
If you want to use a graphical frontend for package installation and updating install yumex by typing
Code:

yum install yumex



Did that help? Any further questions are welcome.


--renilgh

SilverSurfer
PostPosted: Tue Mar 17, 2009 10:23 pm    Post subject: Reply with quote

Thanks renilgh. Ill give it a go, and let you know.
SilverSurfer
PostPosted: Tue Mar 17, 2009 10:58 pm    Post subject: Reply with quote

Hello renilgh. I did as you said, I got the nano editor working ok but the yum.repos.d was empty.
I typed the code it anyway and changed the URL as you suggested. But Synaptic still gives errors and yum check-update gives the following :

[paul@localhost ~]$ yum check-update
Error: Cannot access repository dir //var/cache/yum/blag
[paul@localhost ~]$

Junichirô
PostPosted: Tue Mar 17, 2009 11:21 pm    Post subject: Reply with quote

Try this:
Code:
yum clean all
yum makecache

Synaptic doesn't work. Don't use apt. for now.
After that an update via:
Code:
yum update


And if you want something gui:
Code:
yum install gnome-packagekit



Last edited by Junichirô on Wed Mar 18, 2009 1:33 am; edited 2 times in total
jisis
PostPosted: Wed Mar 18, 2009 12:14 am    Post subject: Reply with quote

Hi SilverSurfer,

If as you say, the file was empty when you opened it, then I suspect you have typed the file name incorrectly.

Consequently, the text editor 'nano' has opened with a new file (of the wrong name) rather than opening with the existing file, named blag.repo

yum.repos.d is the name of the directory that blag.repo resides in.

Try running through renilgh's instructions again and let us know how you get on.

SilverSurfer
PostPosted: Wed Mar 18, 2009 6:35 pm    Post subject: Reply with quote

Hello all. OK I have tried to change the blag.repos.d file but I have noticed that it will not let me save it. I have used ctrl x and both 'y' and 'Y' .
Junichirô
PostPosted: Wed Mar 18, 2009 6:36 pm    Post subject: Reply with quote

Are you root? In the terminal enter su then your password.
SilverSurfer
PostPosted: Wed Mar 18, 2009 10:44 pm    Post subject: Reply with quote

Hello Junichirô. Yes I am in root . I change the file to

[blag]
name=BLAG
baseurl=ftp://therion.noldrin.com/pub/BLAG/linux/90000/en/os/i386/BLAG
enabled=1
gpgcheck=0

and press ctrl x and Y

Then when I exit the terminal and go back in and edit blag.repo it looks like this

[blag]
name=BLAG
baseurl=http://www.blagblagblag.org/90000/$basearch/
enabled=1
gpgcheck=0

Junichirô
PostPosted: Wed Mar 18, 2009 10:58 pm    Post subject: Reply with quote

Try with gedit:
Code:
su
gedit /etc/yum.repos.d/blag.repo

Modify then save.
And after do what I said above.

SilverSurfer
PostPosted: Thu Mar 19, 2009 6:55 pm    Post subject: Reply with quote

FANTASTIC - Thank you every one. Although gedit gave errors when I ran it in root, it did let me save the file and I now have an updated blag.
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP