FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Permission Denied...

Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
PostPosted: Tue Sep 08, 2009 4:26 pm    Post subject: Permission Denied... Reply with quote

So im developing an application in Eclipse using c++, I have all the files on a seperate drive (mounted to /media/disk ) which is an ntfs file system. Up until recently it worked fine... But now, it all works fine, it compiles and links and generates the executable. But then when i go to run the program i get this error.


.../Debug$ ./WarTornlinux
bash: ./WarTornlinux: Permission denied

not sure if it has anything to do with it, but the drive gets mounted as root (owner and group) but i get the same error message even if i try to run it as root. I tried chowning it but that didnt work either. (it stayed as root and still wouldnt run)... any other ideas?[/code]

PostPosted: Wed Sep 09, 2009 1:38 am    Post subject: Reply with quote

oh and the permissions are -rwxrwxrwx
john maclean
PostPosted: Tue Sep 22, 2009 9:51 pm    Post subject: Reply with quote

can you run the comand `stat /path/to/file` and past it here? example:-
 stat info.txt                                                                                                                                             
  File: `info.txt'
  Size: 19              Blocks: 8          IO Block: 4096   regular file

Device: 801h/2049d      Inode: 46391811    Links: 1
Access: (0644/-rw-r--r--)  Uid: (  512/    koji)   Gid: (  512/    koji)
Access: 2009-09-17 21:08:37.000000000 +0100
Modify: 2009-07-22 12:14:15.000000000 +0100
Change: 2009-08-20 21:11:12.000000000 +0100 

BLAG 'em up!
Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP