FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
F12 (Blag 120K) suspend/resume problem with linux-libre.

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
Junichirô
PostPosted: Sun Jan 17, 2010 2:35 pm    Post subject: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

I know, it's not exactly Blag but will be the next Blag. So we have to see some problems now. They'll the next.
When I resume after suspend, sometime Alt Gr key has no more effect. So I can't write # or @. I didn't find any solution but reboot. Some idea?

PS: And it'll make the support forum active!



Last edited by Junichirô on Tue Jan 19, 2010 7:15 pm; edited 1 time in total
Junichirô
PostPosted: Sun Jan 17, 2010 7:29 pm    Post subject: Reply with quote

More exactly the problem is with suspend/resume. When I install the last default fedora 12 kernel, I have no problem to suspend/resume correctly.
Do you think it comes from selinux or the system which tracks and send bug directly?
I think it's something to solve because it'll be in the next blag. Maybe it comes only with the last freed-ora kernel?

Junichirô
PostPosted: Tue Jan 19, 2010 7:17 pm    Post subject: Reply with quote

Tested with selinux disabled: no change. And no suspect messages in /var/log/
A new idea?

Junichirô
PostPosted: Sat Jan 23, 2010 1:45 pm    Post subject: Reply with quote

To add "nomodeset" option to the kernel linux-libre in grub.conf seems to make suspend/resume works correctly.
bla
PostPosted: Sat Jan 30, 2010 4:20 pm    Post subject: Kernel Mode Setting(KMS) Reply with quote

The problem that junichiro mentioned is due to a feature in Fedora known as Kernel Mode Setting(KMS). For more information about KMS, please take a look at:

http://fedoraproject.org/wiki/Features/KernelModesetting

If you are using Fedora 12, I would also recommend looking over Common F12 Bugs at

http://fedoraproject.org/wiki/Common_F12_bugs

if you have been having problems as well.

vx
PostPosted: Mon Feb 01, 2010 4:32 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

Junichirô wrote:
I know, it's not exactly Blag but will be the next Blag. So we have to see some problems now. They'll the next.


finally I have a F12 installation on my box;
using the encrypted partition option and all the default installation... but system is acting weird because it have a 3-5seconds delay when any administration task is launched no matter is from console or gui ... I'm not seein nothing related in the F12-bugs lists,,,


_________________
/'0'\
bla
PostPosted: Thu Feb 04, 2010 12:12 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

Hi,

Have you used encryption before on this system without a problem? What are the specs on the system? Do you happen to know the speed of your hard drive specifically? The fedora install guide mentions performance as a drawback when using encryption

http://docs.fedoraproject.org/install-guide/f10/en_US/sn-understanding-encryption.html

but does not offer any solutions to performance tuning the disk.

Can you also try booting your system with vga=0x318 on the kernel command line and let us know if there is any change with the delay. If there is not, when the system boots up can you update a package on your system called plymouth as root using, 'yum update plymouth'. Do a reboot and let us know if the problem persists. In your reply, can you please send answers to the questions above as well.

Thank You

v0 wrote:
Junichirô wrote:
I know, it's not exactly Blag but will be the next Blag. So we have to see some problems now. They'll the next.


finally I have a F12 installation on my box;
using the encrypted partition option and all the default installation... but system is acting weird because it have a 3-5seconds delay when any administration task is launched no matter is from console or gui ... I'm not seein nothing related in the F12-bugs lists,,,

vx
PostPosted: Sun Feb 07, 2010 10:08 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

tearms wrote:

Have you used encryption before on this system without a problem?

no, is the first time I'm using it

tearms wrote:

What are the specs on the system?


P4, intel 3.03Ghz, ATA-HD, 1G RAM

tearms wrote:

Do you happen to know the speed of your hard drive specifically? The fedora install guide mentions performance as a drawback when using encryption


:/

tearms wrote:

Can you also try booting your system with vga=0x318 on the kernel command line and let us know if there is any change with the delay. If there is not, when the system boots up can you update a package on your system called plymouth as root using, 'yum update plymouth'.


ok,, I'll try this and let you know about


_________________
/'0'\
vx
PostPosted: Mon Feb 08, 2010 6:36 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

tearms wrote:

Can you also try booting your system with vga=0x318 on the kernel command line
(...)
'yum update plymouth'


mmh... wait,,,,
to pass a video option or with an graphical manager while booting can be related with hard disk perfomance when using crypto technologies like luks?


_________________
/'0'\
bla
PostPosted: Mon Feb 08, 2010 6:39 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

Hi,

Not necessarily. It was just a recommendation

v0 wrote:
tearms wrote:

Can you also try booting your system with vga=0x318 on the kernel command line
(...)
'yum update plymouth'


mmh... wait,,,,
to pass a video option or with an graphical manager while booting can be related with hard disk perfomance when using crypto technologies like luks?

Junichirô
PostPosted: Mon Feb 15, 2010 3:02 pm    Post subject: Reply with quote

Here is the bug report when resuming from suspend without the "nomodeset" option given to the kernel:
Code:
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/radeon/r100.c:242 r100_irq_set+0x34/0xa4 [radeon]()
Hardware name: Inspiron 1501
Can't enable IRQ/MSI because no handler is installed.
Modules linked in: cryptd aes_x86_64 aes_generic fuse cpufreq_ondemand powernow_k8 freq_table ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput snd_hda_codec_idt arc4 ecb snd_hda_intel b43 snd_hda_codec mac80211 snd_hwdep snd_seq snd_seq_device b44 dell_laptop cfg80211 snd_pcm rfkill sdhci_pci sdhci snd_timer ssb edac_core dell_wmi mmc_core joydev snd wmi k8temp edac_mce_amd shpchp soundcore ricoh_mmc dcdbas snd_page_alloc i2c_piix4 mii pata_acpi ata_generic video dm_multipath output pata_atiixp radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Pid: 2051, comm: pm-suspend Not tainted 2.6.32.8-libre.48.rc2.fc12.x86_64 #1
Call Trace:
[<ffffffff81056348>] warn_slowpath_common+0x7c/0x94
[<ffffffff810563b7>] warn_slowpath_fmt+0x41/0x43
[<ffffffff8101268e>] ? common_interrupt+0xe/0x13
[<ffffffffa00a65b2>] r100_irq_set+0x34/0xa4 [radeon]
[<ffffffffa00ab1e0>] rs400_startup+0x4d/0xff [radeon]
[<ffffffffa00ab559>] rs400_resume+0xa3/0xae [radeon]
[<ffffffffa0085d4b>] radeon_resume_kms+0x74/0xae [radeon]
[<ffffffffa00720bf>] radeon_pci_resume+0x1d/0x1f [radeon]
[<ffffffff8123cf1d>] pci_legacy_resume+0x38/0x47
[<ffffffff8123d07c>] pci_pm_resume+0x54/0x87
[<ffffffff812de054>] pm_op+0x6b/0xea
[<ffffffff812deb45>] dpm_resume_end+0xe5/0x455
[<ffffffff8108e414>] suspend_devices_and_enter+0x17d/0x1af
[<ffffffff8108e525>] enter_state+0xdf/0x130
[<ffffffff8108dcad>] state_store+0xb6/0xd3
[<ffffffff812275fb>] kobj_attr_store+0x17/0x19
[<ffffffff8117697d>] sysfs_write_file+0xf7/0x133
[<ffffffff8111b7a8>] vfs_write+0xae/0x10b
[<ffffffff8111b8c5>] sys_write+0x4a/0x6e
[<ffffffff81011d32>] system_call_fastpath+0x16/0x1b

vx
PostPosted: Fri Feb 19, 2010 6:07 pm    Post subject: Re: F12 (Blag 120K) suspend/resume problem with linux-libre. Reply with quote

tearms wrote:
Hi,

Not necessarily. It was just a recommendation

v0 wrote:
tearms wrote:

Can you also try booting your system with vga=0x318 on the kernel command line
(...)
'yum update plymouth'


mmh... wait,,,,
to pass a video option or with an graphical manager while booting can be related with hard disk perfomance when using crypto technologies like luks?


well.. doesn't work anyway,,, maybe is better to use another tools for personal data security like ecryptfs or the even truecrypt (there's a thread about http://forums.blagblagblag.org/viewtopic.php?t=4188)


_________________
/'0'\
zenblagger
PostPosted: Thu May 20, 2010 2:19 pm    Post subject: Reply with quote

So I tested trisquel 4.0 live cd (not installed) yesterday and and had the same problem (KMS active in new trisquel version kernel). But I saw that it resumes when waiting for it. So I remove the "nomodeset" option I passed in grub for the kernel on my blag 119k and tested it since yesterday. What happens? Nothing very disturbing. Same as on trisquel: it takes a long time for resuming after suspend but all seems to work correctly after resuming. So I'll use it without "nomodeset" option now and will see.
Junichirô

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP