FAQ   Search   Memberlist  
Profile    Log in to check your private messages    Register    Log in
Problem with Linux-libre Repo File

 
Post new topic   Reply to topic    BLAG Forum Index -> support
View previous topic :: View next topic  
Author Message
cyrille
PostPosted: Sun Aug 22, 2010 6:07 pm    Post subject: Problem with Linux-libre Repo File Reply with quote

Hi ! Again me ! To believe that I'm really not gifted!

I'd like to use the Linux-libre Repo File (with a BLAG 119000, 64bit).
Thus I read the recommendations of this documentation :
https://blag.wiki.aktivix.org/Repo

Code:

[cyrille@vegtux ~]$ cat /etc/yum.repos.d/linux-libre.repo
[linux-libre-development]
name=libre-libre-development
failovermethod=priority
baseurl=http://www.fsfla.org/~lxoliva/fsfla/linux-libre/freed-ora/devel
enabled=0

[linux-libre-release]
name=linux-libre-release
failovermethod
baseurl=http://www.fsfla.org/~lxoliva/fsfla/linux-libre/freed-ora/F-12/x86_64/
enabled=1

[linux-libre-testing]
name=linux-libre-testing
failovermethod=priority
baseurl=http://www.fsfla.org/~lxoliva/fsfla/linux-libre/freed-ora/F-12/x86_64/
enabled=0

[linux-libre-detesting]
name=linux-libre-detesting
failovermethod=priority
baseurl=http://www.fsfla.org/~lxoliva/fsfla/linux-libre/freed-ora/F-12/x86_64/
enabled=0



But I 've got problem with the import aof key.
Code:

[root@vegtux cyrille]# rpm --import http://www.fsfla.org/~lxoliva/fsfla/linux-libre/SIGNING-KEY.linux-libre
erreur: http://www.fsfla.org/~lxoliva/fsfla/linux-libre/SIGNING-KEY.linux-libre: échec de l'import.



The purpose of this operation is to install the kernel last one in development.
( http://www.fsfla.org/download/linux-libre/freed-ora/devel/x86_64/ )
Is the good way to be followed?

Thx Cyrille

veganix
PostPosted: Sun Aug 22, 2010 8:48 pm    Post subject: Re: Problem with Linux-libre Repo File Reply with quote

cyrille wrote:
Hi ! Again me ! To believe that I'm really not gifted!

Hi!
You are surely gifted, as you chose BLAG:)

cyrille wrote:
But I 've got problem with the import aof key.

Try either doing
Code:
# rpm --import http://www.fsfla.org/download/linux-libre/SIGNING-KEY.linux-libre
to import the key, or adding
Code:
gpgcheck=0

to the [linux-libre-release] section (and any other section you choose to enable).



robert

cyrille
PostPosted: Sun Aug 22, 2010 9:05 pm    Post subject: Reply with quote

Hi & thx for the answer

Code:
[root@vegtux cyrille]# rpm --import http://www.fsfla.org/download/linux-libre/SIGNING-KEY.linux-libre
erreur: http://www.fsfla.org/download/linux-libre/SIGNING-KEY.linux-libre: échec de l'import.


So I put the value on 0. But I don't understand why the import of the key : the key file exists on the server.


Another problems :
Code:

root@vegtux cyrille]# yum search kernel | grep libre
[root@vegtux cyrille]#


So don't seem work...

Cyrille[/code]

cyrille
PostPosted: Sun Aug 22, 2010 9:16 pm    Post subject: Reply with quote

Oh I put the var "$releasever" rather than the absolue value and it's works (but always the pb of the import)
++
Cyrille

veganix
PostPosted: Sun Aug 22, 2010 9:28 pm    Post subject: Reply with quote

I remember tearms posting something about trouble with the fsfla url. You could also try using
Code:
baseurl=http://www.lsd.ic.unicamp.br/~oliva/fsfla/linux-libre/freed-ora/F-$releasever
in the repo file and doing
Code:
rpm --import http://www.lsd.ic.unicamp.br/linux-libre/SIGNING-KEY.linux-libre



robert

cyrille
PostPosted: Mon Aug 23, 2010 4:55 pm    Post subject: Reply with quote

No, always the same error.
Code:
[root@vegtux cyrille]# rpm --import http://www.lsd.ic.unicamp.br/~oliva/fsfla/linux-libre/SIGNING-KEY.linux-libre
erreur: http://www.lsd.ic.unicamp.br/~oliva/fsfla/linux-libre/SIGNING-KEY.linux-libre: échec de l'import.


++
Cyrille

veganix
PostPosted: Sat Aug 28, 2010 11:59 pm    Post subject: Reply with quote

cyrille wrote:
[root@vegtux cyrille]# rpm --import http://www.lsd.ic.unicamp.br/~oliva/fsfla/linux-libre/SIGNING-KEY.linux-libre
erreur: http://www.lsd.ic.unicamp.br/~oliva/fsfla/linux-libre/SIGNING-KEY.linux-libre: échec de l'import.


Same result on my updated system, but just tried it on a fresh install of 119k (before updating), and it worked. Perhaps some compatibility issue between GnuPG 1.4.10 and GnuPG2.


robert

Display posts from previous:   
Post new topic   Reply to topic    BLAG Forum Index -> support
Page 1 of 1

Protected by Anti-Spam ACP