BLAG

BLAG Forums
It is currently Thu Dec 18, 2014 1:06 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: CVS lib problem
PostPosted: Thu Jan 27, 2005 11:14 am 
Offline

Joined: Tue Apr 27, 2004 9:52 am
Posts: 73
hi there

i installed cvs using apt-get and when i try and use it i get the following:
[root@localhost etc]# cvs
cvs: relocation error: cvs: undefined symbol: GSS_C_NT_HOSTBASED_SERVICE
i read it might be a problem with kerberos lib so i removed that from /etc/ld.so.conf and updated lib then got the following:

[root@localhost etc]# cvs
cvs: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object file: No such file or directory

so i'm a bit stuck! any ideas?

thanks
ste


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 27, 2005 4:35 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Ok. This just means that whoever packaged the CVS RPM didn't include a dependency to krb5-libs or...dunno. I thought you pretty much needed kr5b-libs for pam & stuff.

Anyway, apt-get install kr5b-libs. If it is there, do an `rpm -q krb5-libs` and let me know what release you are running.

FYI: https://bugzilla.redhat.com/bugzilla/sh ... ?id=100924

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 27, 2005 8:09 pm 
Offline

Joined: Tue Apr 27, 2004 9:52 am
Posts: 73
tried to install but got the following:

The following packages have unmet dependencies:
perl: Obsoletes: perl-CGI but 2:3.05-0_5.rh9at is to be installed
E: Broken packages

if i rpm -q i get:

krb5-libs-1.2.7-14

version of blag is 9000

i noticed that i have enabled apt sources for both 9000 and 10000 so i'm wondering if this is causing a problem.

anyway i've apt-get removed perl-CGI, and then tried to install krb5-libs

It threw up a whole list of upgrade packages and 1new one, compat-db.

after that it now works!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 27, 2005 8:25 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Ok. It looks like you at ATRPMs repository enabled and that was causing some sort of conflict.

-Jeff


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2005 7:40 pm 
Offline

Joined: Tue Apr 27, 2004 9:52 am
Posts: 73
cvs works fine now. my redhat confi stuff is fcked tho - tried redhat-config-network and got:

Code:
rror in sys.excepthook:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 68, in <lambda>
    PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 291, in handleException
    fs = FileSelection(_("Please specify a file to save the dump"))
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 209, in __init__
    import gnome.ui
ImportError: /usr/lib/libkrb5.so.3: undefined symbol: add_error_table

Original exception was:
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 186, in ?
    from netconfpkg import NC_functions
  File "/usr/lib/python2.2/site-packages/PIL/__init__.py", line 41, in ?
    # ;-)
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 994, in GenClass_read_classfile
    __GenClass_read_classfile(boxpath, mod, OptLower)
  File "/usr/lib/python2.2/site-packages/rhpl/genClass.py", line 947, in __GenClass_read_classfile
    doc = xml.dom.minidom.parse(boxpath)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 962, in parse
    return _doparse(pulldom.parse, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/minidom.py", line 953, in _doparse
    events = apply(func, args, kwargs)
  File "/usr/lib/python2.2/site-packages/_xmlplus/dom/pulldom.py", line 338, in parse
    parser = xml.sax.make_parser()
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/sax2exts.py", line 37, in make_parser
    return XMLParserFactory.make_parser(parser_list)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 64, in make_parser
    return self._create_parser(parser_name)
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxexts.py", line 42, in _create_parser
    drv_module = __import__(parser_name,{},{},['create_parser'])
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/drivers2/drv_pyexpat.py", line 20, in ?
    from xml.sax.expatreader import create_parser
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/expatreader.py", line 28, in ?
    from xml.sax import xmlreader, saxutils, handler
  File "/usr/lib/python2.2/site-packages/_xmlplus/sax/saxutils.py", line 8, in ?
    import types, sys, urllib, urlparse, os, string
  File "/usr/lib/python2.2/urllib.py", line 26, in ?
    import socket
  File "/usr/lib/python2.2/socket.py", line 41, in ?
    from _socket import *
ImportError: /usr/lib/libkrb5.so.3: undefined symbol: add_error_table




hmm. doesn't nother me at the moment cos it means i have to go and figure out what txt files to change :-)


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2005 7:46 pm 
Offline
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
Hmm, try `netconfig`

You may have gotten someone else's python (e.g. ATRPMs) or something which is foo...

-Jeff


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group