BLAG Forums
It is currently Wed Nov 25, 2015 6:13 am

All times are UTC

Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Mon Mar 07, 2005 7:07 pm 

Joined: Mon Mar 07, 2005 6:53 pm
Posts: 1
I installed BLAG Linux v9.0, with the GRUB boot loader option onto a Pentium4 Dell PC. It has a primary disk with Windows XP and a secondary disk for linux. After installing linux and rebooting, all I get is a black screen with the word GRUB on it and it accepts no commands and requires a ctrl-alt-del command to escape. There is no boot menu as I find on my other dual boot PC. I reloaded Linux several times with other GRUB options and even without the boot loader at all, and get the same result. I cannot even boot Windows anymore.

I tried to use the fdisk /mbr command to recover, but I cannot get a DOS prompt that accepts this command with the computer in its present state.

Pretty much, I am dead in the water. Is there a way to fix or replace the MBR from the install disk for BLAG? Or am I in a position to have to re-install Windows and start over?


 Post subject:
PostPosted: Mon Mar 07, 2005 7:37 pm 
Site Admin

Joined: Sun Mar 14, 2004 3:17 pm
Posts: 4492
Location: Loveland, Colorado, USA
If you are running 9k, lilo should still be an option in the installer. You could give that a spin.

If you are just getting "grub>" it means that your /boot partition can't be found so it can't load the other needed bits.

If you boot from a DOS/windoz CD/floppy, you can run the fdisk /mbr to overwrite the boot sector as well.


 Post subject:
PostPosted: Mon Mar 07, 2005 7:54 pm 

Joined: Fri Apr 02, 2004 2:42 am
Posts: 223
Location: Charleston, SC USA
1>Method One - Boot from Installation CD
boot from the linux CD.
type this at the boot prompt:
linux rescue
use the ensuing rescue procedure to get to a command line, with your / mounted, say as /mnt/rescue
then say this:
chroot /mnt/rescue
now your / on your HDD is mounted as / and not /mnt/rescue (formerly, / was the root of the RAM drive your CD boot sets up.)
Now, type this:
/sbin/grub-install /dev/hda
now this
and reboot.
2> Method 2 - Boot from rescue floppy
once the floppy is booted, and you have logged in:
/sbin/grub-install /dev/hda
now reboot.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group